Previous 1 3 4 5 6 7 8 Next 110 Replies Latest reply: Jul 21, 2015 11:36 AM by alexestornel Go to original post
  • AaronStetson Level 1 (0 points)

    My solution is resolved.  I posted above a few days ago. 

    My trackpad randomly started going crazy, I took it to the genius bar the ran 2 days of tests couldn't get the problem to replicate.  I brought it home and wouldn't you know it the problem started immediatly when i booted up. I called Apple care the did the SMC and the PRAM resets with me over the phone.  I told him that I had just been to the genius bar and they tested it for 2 days to no avail and then it started again.  So they made another genius bar appointment for me over the phone gave me a case#.  I brought it in the tech checked for battery swelling, to no avail.  So they said, we're just going to replace the trackpad.

    They replaced it and it's worked perfectly. 


    It seems to me, that if you are having this problem it's not software, but hardware.  Pressing on the trackpad or SMC resets or any other casting spells over something that is broken probably isn't going to fix it permanently. Bring it in, get it replaced!


    Good luck

  • Salda Level 2 (235 points)

    I too am having the same issue, just started yesterday. I use a Kensington trackball, but there is also no response from clicking. Mouse cursor moves as it should, just no clicking via trackpad or trackball. I have my trackpad setup to click with a tap, no go. Have reset PRAM and SMC.


    I believe this is a SOFTWARE issue, and here's why. About 2 weeks ago I swapped out the DVD for a 2nd hard drive. I installed Mountain Lion on the new HD and left Snow Leopard on the original drive. I can boot back into Snow Leopard and everything works fine (running SL as I type). However, booting back into ML or the Recovery partition, the OS refuses to recognize a click from any input devices.


    Just finished running a permissions repair on the ML drive via SL, will try and reboot in a minute to see if that helped. The only thing I have not tried is cleaning the trackpad, that will be my next step, but honestly, I don't see how that will help if everything works fine in SL. If that doesn't work, going to try and reinstall ML.


    Please, if you post that you are having issues, be sure to list your hardware and software, I think we will start to see a pattern. If something works, be sure to list WHAT it was that fixed your situation, and again, list your hardware and OS version.


    MBP, 15", Early 2011, OS X 10.8.2 (No issues in 10.6.8)

  • Salda Level 2 (235 points)

    Cleaned the trackpad, reinstalled the OS on top of previous (non-clean install), neither helped. Then, all the sudden, it started working. Don't know what changed or fixed it. Very frustrating.

  • dcdigital72 Level 1 (0 points)

    Thanks to all of you...had a buddy point me here when my the pointer on my MacBook Pro suddenly started skipping all over the place...and/or not moving at all as I was trying to get it to.  I did the whole "clean it...then zap PRam ....then...etc. etc."....and even attached an external mouse hoping to gain control by simply not touching the trackpad...nothing fixed it!



    What many of you have mentioned....


    I put my hand over the entire trackpad....and pressed down as firmly and evenly as I could across all of it...held it for 12 seconds, and then let go....and like magic....IT'S FIXED!

  • bbrowett Level 1 (0 points)

    This reply is an update to serveral previous posts, as well as, a response to recent observations and fixes.


    MacBook Pro:  13” MBP (Early 2009) now running OS X 10.8.2 [also we have several other MBPs ... older and younger that do not exhibit the problem behaviour, ... All run OS X 10.8.2.]  Each computer has an external mouse that is used about 90+% of the time.    As others have said, when the problem occurs, the external mouse does not help.


    Reviewing the posts, it could be that there are several root causes to the problems.   Nonetheless, with very careful, frequent, and thorough cleaning, especially paying close attention to the edges of the trackpad that is slightly covered by the computer housing (as was suggested in a very early post to this discussion), the problem occurs much less frequently.


    In my case, I suspect very small particles had become trapped between the TrackPad surface and the computer housing. 


    Others may have required battery or TrackPad changes ... but it is also possible that these changes dislodged or removed the particles, i.e., the hardware only needed to be cleaned thoroughly.   Only the Apple folks could confirm whether there has been some sort of software change to the sensitivity of the TrackPad ...


    So when the problem happens again, I:

    -  Clean the TrackPad and the edges of the TrackPad

    -  Reset the TrackPad by pressing evenly over the full surface of the TrackPad. ... as others on this discussion have indicated.




  • gtom808junk Level 1 (0 points)

    I can't believe your suggestion actually worked. You saved my weekend!

  • Steve Bush Level 1 (40 points)

    Have just suddenly had the same experience with my mouse going crazy. But it seems like too much feedback both ways: software vs hardware. No convincing argument for either so far...I recently had a similar problem with my iphone - the mic wouldn't funtion, and forums were saying all kind of stuff. I took a flat wooden coffee stir-stick and whittled it to a point and stuck it inside the charger contact and dug around. The little fibers of wood acted like micro-barbs and hooked the lint which had gotten stuck and then compacted deep inside the recess. Removing this lint fixed the phone.

    With regard to mouse pads I've found that a piece of plastic works well to slip in along the edge of the pad and the body of the computer. I used a colored "gel" for theatrical / film lighting. Very thin, kinda rigid, and smooth/slippery. It slipped in the tiny crack I was able to move it around the pad and the body. Small amounts of dirt and grime popped out.

    My system has been running the latest OS for a while without any mouse issues. I find it somewhat hard to believe that the software suddenly went banannas. Hardware failure is also possible, but I would reccomend trying this cleaning before tearing apart the mouse pad, replacing the battery, re-installing the OS, etc.

    So far my mouse is working fine again, but lets see how long it lasts! Good Luck!

  • chad57 Level 1 (0 points)

    My MacBook Air has been doing this for about a year and has gotten worse with time.  Why does apple not address this issue?

  • harsh.goel Level 1 (0 points)

    Thank you so much !

    My macbook trackpad had not been working for months.

    i had even bought a magic mouse and since I Had not purchased the apple care i did not want to get it definitely saved me a few 100 dollars.thank u so much

  • Gregh55 Level 1 (0 points)

    Tried the SMC & PRAM resets, cleaning the trackpad to no lasting affect. Saw several notes here about applying pressure to the trackpad or giving it a gentle smack. Low and behold I have it a gentle four finger tap and been working fine since. Give it a go if all else has failed.

  • MissGinger Level 1 (0 points)

    Have you downloaded any chrome apps?, mine did that and even accessed my camera, so check settings under advanced, theres a button you need to click on several of them that wont allow access to mouse, camera may not be your problem but it was mine, pretty freaky i thought, then i got rid of most of the recent downloaded apps cause I wasn't sure which one it was but for some reason google allows that option and they hide it pretty well in their advanced settings.MG

  • jlewchuk Level 1 (0 points)

    "Hi, tried reseting PRAM and PMU. Tried putting pressure on trackpad, helps for a few seconds, then problem came back. Then i noticed a few post on web about dust around the edges of trackpad. My two year old daughter had her fingertips on my macbook pro before this problem started a few weeks ago. I used my fingernail around the edges of the trackpad.... worked."


    Yep...worked for me too.

  • lululola Level 1 (0 points)

    My pointer stopped working last Friday on the plane; just became frozen and inactive save for being able to move it with trackpad. I thought it was only temporarily corrupted due to my sign in to a gogoinflight which I did around the same time as it stopped working. Once home, it was working again, so I continued to think it was an isolated incident... until NOW when it's happening again on a desk at work.


    Computer details:

    MAC OS X

    Version 10.6.8

    Processor 2.4GHz Intel Core 2 Duo

    Memory: 4GB 667 MHz DDR2 SDRAM

    Boot ROM Version: MBP3.1.0070.B07


    Current hard drive capacity: I was down to 51GB hard drive space so I deleted some files to bring it to 61GB+ because I've experienced system instability on my last macbook pro when memory got too low.


    I have performed: holding down the L-shft/control/option/power - and problem remained. I have performed clean-ups via DiskWarrior 4.2 (and removed two .plist riles that were said to be problematic and unrepairable), performed Permisssions check.. more to come.


    It is working for the moment but I expect it is temporary. I will update this more when it fails again!

Previous 1 3 4 5 6 7 8 Next