3 Replies Latest reply: Oct 9, 2012 8:24 AM by stjohnmccloskey
jnll Level 1 Level 1 (0 points)

I have a problem with Ical sync with iCloud on one of my two Imacs, both running latest Lion 10.7.3.  On one of the iMacs, the synch works the way it should - meaning that any change I make in the iCloud calendar gets pushed to that iMac, and any change that I make on the desktop iCal gets pushed to iCloud.

 

But on my other iMac, with exact same configuration of iCal, exact same config of iCloud the results are puzzling.  I have a total of 6 calendars, nonoe local to either desktop and all 6 on the cloud. On 2 out of the 6 calendars, iCloud changes geet pushed to the desktop, but I am unable to even see any events on the other 4 calendars - all of them are checked to display.  I went through the website troubleshooting which included quitting iCal on the desktop with difficulty, then unchecking iCloud clendar, then waiting a minute, then rechecking the iCloud calendar. Then restarting the dsestop. Same results. I did it twice to be sure. I still only see 2 out of the 6 calendars.  Can't figure it out.  Another odd thing is that when I create a new event on the problem iMac desktop, I don't get a chance to indicate which calendar I want, or which dsate I wawnt, or what tiime I want. The event just defaults to my default calendar, gets pushed to the cloud, gets pushed to the other iMac  and shows up, but I can't see it on the problem iMac.


iMac (21.5-inch Late 2009), Mac OS X (10.7.3)
  • MadisonP Level 5 Level 5 (4,505 points)

    Greetings,

     

    1. First make an iCal backup:  Click on each calendar on the left hand side of iCal one at a time highlighting it's name and then going to File Export > Export and saving the resulting calendar file to a logical location for safekeeping.

     

    2. Go to iCal > Quit iCal

     

    3. Remove the following to the trash and restart your computer:

    Home > Library > Caches > com.apple.ical

    Home > Library > Calendars > Calendar Cache, Cache, Cache 1, 2, 3, etc. (Do not remove Sync Cache or Theme Cache if present)

    --- NOTE: To get to "Home > Library" in Lion: Click anywhere on the desktop and then click on the "Go" menu at the top of the computer screen while holding down the "option" key on the keyboard.  You will see "Library" in the menu.

     

    4. Launch iCal and test.

     

    If the issue persists:

    1. Go to iCal > Quit iCal

     

    2. Remove the following to the trash and restart your computer:

    Home > Library > Caches > com.apple.ical

    Home > Library > Calendars > Calendar Cache, Cache, Cache 1, 2, 3, etc. (Do not remove Sync Cache or Theme Cache if present)

    Home > Library > Preferences > com.apple.ical (There may be more than one of these. Remove them all.)

    --- NOTE: Removing these files may remove any shared (CalDAV) calendars you may have access to. You will have to re-add those calendars to iCal > Preferences > Accounts.

     

    3. Launch iCal and test.

     

     

    Hope that helps!

  • jnll Level 1 Level 1 (0 points)

    Amazing!!!

    Although the first trashing didnt fix the problem, the second one did.  I am really impressed and naturally very, very happy. Now all my calendars are working!

     

    Jim

  • stjohnmccloskey Level 1 Level 1 (0 points)

    Helped me as well! thanks a million