Skip navigation

Messages Beta and problems with Bonjour Chat

2754 Views 7 Replies Latest reply: May 6, 2012 11:31 AM by Ralph Johns (UK) RSS
R Knight Level 1 Level 1 (5 points)
Currently Being Moderated
May 1, 2012 10:38 AM

Let me start with that I totally understand Messages is in beta but I'm hoping someone will have a suggestion.

 

In our office we use Bonjour chat extensively for inner-office chat and file sharing. Most of our workstations are still on Snow Leopard few on Leopard and one is on Lion running iChat 6 and 2 MacBooks Pros have the Messages Beta on Lion. The ones with Messages are having sporadic issues with receiving new chat messages. When it does not work, the sender gets the error "The instant messaging connection failed. The other person's computer may be unreachable."  This is from iChat to Messages, or Messages to Messages. (Please note, things like iMessage and Google Talk are working fine for these Lion/Messages Beta systems, the issue is isolated to Bonjour chat.)

 

Now if the person with Messages starts the Bonjour chat to person with iChat it will work fine and then a back and forth chat session will work fine. Message to Message is pretty much broke.

 

Occasionally I get a firewall access dialogue for "imagent" wanting Firewall access and I always click Allow, but seems to do little help. If I disable the OSX Firewall completely (through the GUI) on any system with Messages and the problem will resolve itself.

 

As another troubleshoot I tried leaving the Firewall on, Messages on but logged off of Bonjour and have Adium on and logged in into Bonjour and everything works great.

 

So I can narrow down the issue to Messages, with Bonjour chat and the Firewall. It seems to me Message isn't telling Bonjour to open the right ports.

 

Any suggestions anyone can give will be greatly appreciated. Thanks so much!

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    May 1, 2012 2:05 PM (in response to R Knight)

    Hi,

     

    This may seem strange but add  Public DNS server  to the System Preferences > Network > Advanced Button > DNS tab.

     

    In fact if this shows the greyed out DNS server info from the router then add these manually as well (it may list the router's IP which is not required)

     

     


    10:04 PM      Tuesday; May 1, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    May 2, 2012 12:00 PM (in response to R Knight)

    HI,

     

    Your ISPs DNS servers may or may not be Pubilc DNS servers.

     

    Google run some Public DNS servers (I normally port 8.8.8.8 and 8.8.4.4)

     

    There is a collection  listed here

     

    It does seem that in some cases ISPs DNS servers are limited to what and where they can resolve names.

     

    However OpenDNS would be another option which you seem to have undertaken.

     

    At this point I would try deleting the com.apple.ichat.Subnet.plist

    And restarting Messages or iChat.

     

    In Lion you will have to use the Finder > Go Menu > hold ALT key and Select the Library when it appears > then go to Preferences

    ON other OS version it is in ~/Library/Preferences

    Just drag the file to the Trash.
    Restart iChat/Messages as stated.

     

    Messages still uses the iChat.plists  (it really is iChat version 6.1 in effect).

     

     


    8:00 PM      Wednesday; May 2, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    May 5, 2012 1:30 PM (in response to R Knight)

    HI,

     

    Can you double the chances of the engineers seeing this by also reporting your findings here

    http://www.apple.com/feedback/ichat.html

     

    Messages is in fact iChat+ and Messages is identified as version 6.1

     

    The drop downs for iChat version and OS version have been out of step most of the time since iChat 4 was the main version.  Just type the info on Versions in the free text area.

     

    The fact that this Bonjour file Sharing seems to not be on an expected port is a bit concerning.

     

    The original set of Ports are listed here or rather the set for iChat 3 and upwards

    At note 2 at the bottom it lists the "Local" ports

    Port 5353 is the everyday Bonjour port used by the Finder to find other Bonjour computers or devices.

    This leaves port 5197 and 5298 for Texting and File transfers

    If it follows the AIM model, the UDP 5298  would seem to be the most likely port File transfers are supposed to be on.

    (It is known that A/V chats use the same port whichever Buddy List starts them - 5678 for invites then 16402 for everything else in iChat 4 and above)

     

    Is IMAgent listed in the  Firewall ?

    System Preferences

     

     

    (Messages should also be allowed.)

     

    The other thing about the error message is that the port also seems to want to change as part of the process.

     

     


    9:30 PM      Saturday; May 5, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (66,840 points)
    Currently Being Moderated
    May 6, 2012 11:31 AM (in response to R Knight)

    Hi,

     

    I had an System Preferences pane add-on that always wanted me to allow it in the Mac Firewall.

    This even crossed over to my iMac in Lion when I migrated the apps from a Leopard computer.

     

    The "Fix" was to remove it from the allowed List and then re-add it again.

     

    IMAgent is found in your Hard Drive(Name)/System/Library/PrivateFrameworks/IMCore.framework

     

    You could try "resetting" the firewall on the receiving computers.

     

     


    7:32 PM      Sunday; May 6, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Lion 10.7.3)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.