2 Replies Latest reply: Sep 4, 2015 6:53 PM by SarahMicheleF
mullr Level 1 Level 1

I have a presentation with some embedded videos. I recorded it using the "record slideshow" feature and am now trying to export it to a quicktime movie. The resulting movie is very strange; it renders correctly up until the first video, but the video doesn't play - it just sits at the first frame. Then it renders happily until the second video, but it refuses the show the slide where the second one resides. Instead it just leaves the previous slide showing. Then, when it should be advancing past the second video, it actually advances TO it.

 

The whole thing works beautifully when pressing the play button.

 

Clearly the export feature doesn't work consistently with embedded videos. Is this a known bug for which there is a workaround? I tried the suggestion at https://discussions.apple.com/message/11575298, but to no avail.


Keynote, Mac OS X (10.7.3), Keynote '09 version 5.1.1 (1034)
Solved by mullr on May 6, 2012 9:03 PM Solved

I've been able to work around this problem, at great length, by fidding with the transitions into and out of the slides which have videos. The rules I'm using are:

1) Never use a magic transition into or out of a slide containing a video.

2) The video should always start automatically via the "Start Movie" build in.

2b) The "start movie on click" box should be unchecked.

 

This means that it can be useful to pad the video with dummy slides before and after it to achieve the transition and video start behavior you want.

 

I tried doing an automatic transition after the video finished (with a manual delay), but that may also be broken.

  • mullr Level 1 Level 1

    I've been able to work around this problem, at great length, by fidding with the transitions into and out of the slides which have videos. The rules I'm using are:

    1) Never use a magic transition into or out of a slide containing a video.

    2) The video should always start automatically via the "Start Movie" build in.

    2b) The "start movie on click" box should be unchecked.

     

    This means that it can be useful to pad the video with dummy slides before and after it to achieve the transition and video start behavior you want.

     

    I tried doing an automatic transition after the video finished (with a manual delay), but that may also be broken.

  • SarahMicheleF Level 2 Level 2
    expertise.icloud
    iCloud

    I just ran into a similar problem - when exporting to quicktime from Keynote 6.5.3, I effectively ended up with a doubled delay. For example, for a 20 second video clip, I had the automatic transition (nothing fancy, just advancing to the next slide, per the above advice) set to 20.5 seconds. It worked just fine in Keynote  but when I exported to Quicktime, it appeared to be appending the delay onto the end of the video. I've simply removed the delays, which means the slideshow doesn't work in Keynote anymore, but it seems to be fine in the Quicktime version.