Previous 1 2 3 Next 37 Replies Latest reply: Sep 12, 2013 7:49 AM by nsdjoey
jewiebe Level 1 Level 1

I've been testing Apple Configurator in hopes that we can use it to pre-install our MDM application onto our iPads and iPhone before they are sent to the users.


However, when I try to prepare a blank iPad, configurator gives the error that the Apple ID is not authorized. I have signed in to configurator with an Apple ID that has downloaded the (free) app, and this iMac is authorized in iTunes (and currently signed in to the iTunes store).


Is there something that I'm missing?


Apple Configurator, Mac OS X (10.7.3)
  • gyrhead Level 3 Level 3

    Make sure the computer running configurator is authorized for the itunes account you are using to log into configurator.

  • jewiebe Level 1 Level 1

    Yes, it is. Mentioned in my first post, sorry if that was unclear.

  • gyrhead Level 3 Level 3

    You need to authorize the computer running configurator with a different apple id than the one that was used to obtain the app.

  • jewiebe Level 1 Level 1



    I tried that but still getting the same error. Very frustrating.

  • harryfromreston Level 1 Level 1

    Firstly, i have this problem too.  Secondly, gyrhead seems to have two contradictory suggestions, but perhaps I am missing a nuance.  Oh - now i see (after writing the rest of this message). The preference setting i found requires and Apple ID, and i think it must be a special VPP program apple ID? Didn't know what "log into configurator" -- but i think understanding those two messages is key. Will re-read the docs.




    I have logged into iTunes and alunched the configurator from one computer, downloaded a free app, then attempted to use configurator from THAT mac to intitialze a set of iPads in a Bretford tray.


    I think this means i must have authorized this computer for that apple ID. I even tried authorizing the ipads by connecting them to the store and downloading free apps, and set authorized them for the same app id.


    I see that configurator itself has preference seting for apple ID, and it says "The Appl eID used in the Itunes Store on this Mac to redemm VPP redemption codes and download apps. This is not the VPP PRogram Facilitator's Apple ID."   I know this is not a VPP Program Facilitator's Apple ID; i am not sure if this means i Should use the VPP Program Facilitorto's Apple ID or if this means that it SHOULD NOT be as it won't be used that way.


    In any event i just want to install and manage FREE apps, and don't have a VPP Program account.


    With one regular Apple ID intended for use with free apps, i can't make this work.

  • christopher274 Level 1 Level 1

    If you are only deploying free apps, do not put an Apple ID in the Configurator preferences. Configurator will authorize the app on the devices by using the Apple ID that 'purchased' the free app. This Apple ID must be authorized in iTunes on the Mac that is running Configurator.

  • jewiebe Level 1 Level 1

    Unfortuantly that doesn't work either. I get the same error.

  • christopher274 Level 1 Level 1

    When you add the app to Configurator, is the app listed as 'Free' or does it have or little warning indicator next to it?


    If it's marked as 'Free', try moving your Configurator preferences file out of the way.

  • jewiebe Level 1 Level 1

    It's listed as free.


    I'm not sure what you mean by move the "preferences file out of the way"

  • christopher274 Level 1 Level 1

    Shut down Configurator, got to ~/Library/Preferences, and rename or move This is your preferences for Configurator. It will be recreated when Configurator is started again.

  • jewiebe Level 1 Level 1 is not listed in that path. I don't see anything with "configurator" in the filename.

  • christopher274 Level 1 Level 1

    Are you looking in /Library/Preferences /Users/<yourusername>/Library/Preferences? ~/Library = /Users/<yourusername>/

  • harryfromreston Level 1 Level 1

    "If you are only deploying free apps...".  How is this relevant? If you are getting apps from the app store, they are digitally signed, free or no.  Does your purchase / download get you a version signed with the app ID you are buying with? I thought that was true.  If so, you'd have to have that signer's certificate on every machine you want to run the app on.  Or are free apps different? or only signed by apple and the developer, so signatures are irrelevant to this challenge of using configurator to push apps out to multiple devices?

  • Sinjef Level 1 Level 1

    I had this same issue. My resolution is below.


    1. Apple Configurator - Preferences - General - Apple ID - Set this to the iTunes account you used to download the application (doesnt matter if it was a new download or you are redownloading it from the cloud.)


    2. Make sure your computer is authorized inside of Itunes. ( ITunes - Store - Authorize this computer).


    3. Delete out the apps from Apple Configurator - Click Apply - If you are using a profile then refresh it - Import the apps again - Click apply. (Probably just need to delete out the apps and then import them again, but these are the steps I took.)


    Should work this time



Previous 1 2 3 Next