7 Replies Latest reply: Jan 31, 2013 3:50 AM by allanfromcork
OleFbxAK Level 1 (0 points)

Recently I started having trouble saving webpages & web-based pdf docs via the 'save as' option in Safari.



I get the message: The doc 'xxx' could not be exported as 'xxx'.


I'm not getting the window that allows the options of web archive, pdf, etc. either.  I've tried adding '.pdf' to the end of the name Safari assigns the doc, & tried my own titles.  Never had this problem before, have used Safari for many years.  Using 5.1.5 now.

MacBook Pro, Mac OS X (10.7.3)
  • Carolyn Samit Level 10 (102,840 points)



    Quit Safari.


    Open the Finder.

    From the menu bar click Go > Go to Folder


    Type this exactly has you see it here:    ~/Library/Caches/com.apple.Safari/Cache.db


    Move the Cache.db file to the Trash.


    Relaunch Safari to test.

  • OleFbxAK Level 1 (0 points)



    Copied & pasted the path you suggested into 'go to folder' only to get response 'couln't find folder'. 

    Followed the path manually & indeed there is no 'com.apple.Safari' or 'Cache.db'


    Quit Safari & relaunched anyway, but no change.


    Might a reset of Safari, or uninstall-reinstall be needed ??

  • Carolyn Samit Level 10 (102,840 points)

    Try this...


    Those files do exist...



    Open a Finder window.


    Select your Home folder in the Sidebar on the left.


    Then open the Library folder the Caches folder then the com.apple.Safari folder. You'll see the Cache.db file there.


    Just move it to the Trash.


    Since you are running v10.7.3 Lion, the only way to reinstall Safari is to use Lion Recovery


    You can try, "resetting" Safari. From the Safari menu bar click Safari > Reset Safari.


    Select the top 5 boxes then click Reset.


    Quit then relaunch Safari to test.

  • Linc Davis Level 10 (185,020 points)

    Back up all data.


    Quit Safari. In the Finder, select Go ▹ Go to Folder... from the menu bar, or press the key combination shift-command-G. Copy the line of text below into the box that opens, and press return:


    /Library/Internet Plug-ins


    From the folder that opens, remove any items that have the letters “PDF” in the name. You may be prompted for your login password. Then launch Safari and test.


    If you still have the issue, repeat with this line:


    ~/Library/Internet Plug-ins


    If you don’t like the results of this procedure, restore the items from the backup you made before you started. Relaunch Safari again.

  • OleFbxAK Level 1 (0 points)

    Yikes, glad I didn't try to dump Safri, sure don't want to have to redo Lion, at least not yer.


    Tried reset although I didn't have much faith it would work, & it didn't.  But it did move me through to try other things that led to understanding what was going on, & combined with Linc's suggestion confirm a good resolution.


    So thanks for your contributions !!!!!!


    I returned to the email that had links to important work related resouce docs that I was attempting to save.  The webpage was indeed of a pdf doc, & as I moved my mouse along near the bottom some tool icons appeared.  One was an Adobe icon, which when clicked provided the full menubar up top, clicked 'save' & that allowed me to name the file & save it to my desktop as I typically do. 


    So I took this to be a case of Safari & Adobe not wanting to play nice together & figured I'd find a way to yet again get the intrusive Adobe out of my way when I had more time.  But then Linc's suggestion was waiting for me.

  • OleFbxAK Level 1 (0 points)

    Thanks brother, your suggestion was as timely as can be !! 


    Upon realizing that this was an Adobe v. Safari battle, guess what the only 2 'PDF' plug-ins were in that folder ??  Yep, AdobePDFViewer & AdobePDFViewerNPAPI.  Tossed em in the trash & everything works the way it used to. 


    Now I can finally get back to work, thanks for your help !!

  • allanfromcork Level 1 (0 points)

    Trashing only AdobePDFViewerNPAPI solved the problem for me - thanks Linc! It also cured another problem - that I could not Zoom the View of PDF files coming into Safari from the web.