Skip navigation

iPhoto 09no thumbnails in exported photos

448 Views 11 Replies Latest reply: May 10, 2012 3:24 PM by johnpfree RSS
johnpfree Calculating status...
Currently Being Moderated
May 2, 2012 4:31 PM

I just upgraded to iPhoto 09, and find that exported photos no longer have the thumbnail in their EXIF data.  Help?!

iPhoto '08, Mac OS X (10.4)
  • Old Toad Level 10 Level 10 (113,195 points)
    Currently Being Moderated
    May 2, 2012 5:33 PM (in response to johnpfree)

    Check to see that you have the Finder view options set to Show icon previews?

    Finder001.jpg

     

     

    OT

  • Old Toad Level 10 Level 10 (113,195 points)
    Currently Being Moderated
    May 3, 2012 9:50 AM (in response to johnpfree)

    I've just tried to duplicate the problem with the iPhoto 8.1.2 library and app and have been unable.

     

    Try this:  launch iPhoto with the Option key held down and create a new, test library.  Import some photos and check to see if the same problem persists. If the problem persists in the test library do the following:  make a temporary, backup copy (if you don't already have a backup copy) of the library and try the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home()/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

         User/Home()/Library/Caches/com.apple.iPhoto folder. 

     

    Click to view full size

     

    3 - launch iPhoto and try again.

     

    NOTE: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

    If the new library preserves the thumbnail on exported photos then your current library is damaged. In that case  make a temporary, backup copy (select the library and type Command+D) and apply the two fixes below in order as needed:

     

    Fix #1

     

    Launch iPhoto with the Command+Option keys held down and rebuild the library.

     

     

    Select the options identified in the screenshot

     

    Fix #2

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.
      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option
      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.

     

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.


  • Old Toad Level 10 Level 10 (113,195 points)
    Currently Being Moderated
    May 3, 2012 2:26 PM (in response to johnpfree)

    I'm not familiar with the exif_read_data function. Just to be sure we're on the same page exported photos from your library do not include built in thumbnails, right?

     

    What app requires the thumbnail being present?

     

    Have you tried using EXIF Viewer on the two files?  Is the problem obvious in it?  You can take screenshots of the window and post here.

    EXIF Viewer001.jpg

     

    If you haven't tried deleting the preference file give it a try. Also the other two.

  • Old Toad Level 10 Level 10 (113,195 points)
    Currently Being Moderated
    May 3, 2012 3:24 PM (in response to johnpfree)

    Yes.  Since the new library you tried stripped the thumbnail did you try deleting the preference file?

  • Old Toad Level 10 Level 10 (113,195 points)
    Currently Being Moderated
    May 5, 2012 9:19 AM (in response to johnpfree)

    I do thave a couple of more troubleshooting suggestions:

     

    1 - boot into another user account on your Mac and see if iPhoto does the same there.  If so then it's a system wide issue.  If not then it's a probem with just your user account.

     

    2 - boot into  Safe Mode and try there.  If the problem goes away then there's some system files that are interfering with iPhoto.  If not then it definitely is a system wide problem.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.