Previous 1 2 3 4 5 Next 67 Replies Latest reply: Aug 22, 2014 7:47 AM by LacertaBio Go to original post
  • TommyDANGerous Level 1 (10 points)

    I am having the same problem, disabling Google Drive fixed it for me.

  • oliviercp Level 1 (5 points)

    I've been having the same issue on my new rMBP 15'' with Maverick. I've finally figured out what was causing the issue for me: Google Drive.

     

    When the Google Drive app is active in the background, it seems to be provoking the random switches between spaces. I've tried quitting the app or even pausing it, and it solves the issue. No random screen switching anymore. What's strange is that I installed Google Drive a few days ago, and it was running fine until today when the "screen switching" started. Ah well. Google isn't what it used to be.

     

    I'd be curious to see if you find that Google Drive is also the cause of the issue for you. If not, then I would try by disabling background apps and see if it solves the issue. If it does, then try re-launching each app one by one, and checking when the problem comes back - you've then identified the problematic app.

     

    I'll start to look for any updates on Google Drive to solve this issue. If anyone has an idea... I'd be happy to hear it. Hopefully this helps someone.

  • ericthelutheran Level 1 (0 points)

    Same issue. It's getting really frustrating. 15" MBP with mav.

  • Jocelync16 Level 1 (0 points)

    I'm having a same problem!!!

    APPLE ARE YOU EVEN LOOKING AT THIS FREAKEN WALL???

    I'm wondering if its because we need to update something?

  • hiddenheat9mm Level 1 (0 points)

    I also have a 2012 Air and it just started doing the same thing tonight. I did the google Drive sync unchecked thing and it is fine now. Why this is happenening I don't know, especially since I have had Drive set to sync for a yr now. Must be how it relates to new Mavericks OS

  • T-Will Level 1 (5 points)

    Thanks! Disabling Google Drive's "Show file sync status and right click menu" fixed the issue for me. This issue just started happening today on my 2010 MacBook Pro (Mavericks).

  • Jocelync16 Level 1 (0 points)

    Can you pleas take a picture on how i am suppose to do it thx!!

  • Ben from Ky Level 1 (0 points)

    Macbook Pro Late 2011 Running Mavericks. I had this exact problem. As noted by others, I unchecked "show file sync status" in Google Drive Preferences and it solved it for me. My guess is Google Drive updated in a way that was incompatible with Mavericks and Apple and Google will have to figure out who needs to patch the problem.

  • blueblonde Level 1 (0 points)

    This solved the issue for me as well. I just paused syncing and it did the trick. Thanks so much for sharing!

  • asif.iqbal.shaik Level 1 (0 points)

    Thanks werewolf16! I disabled Google Drive and it fixed the problem.

  • oliviercp Level 1 (5 points)

    Indeed - No need to disable Google Drive entirely; simply disabling the "Show file sync status and right click menu" is enough to fix the issue.

     

    Problem sovled

  • bergjs Level 1 (0 points)

    Same here. Google Drive was the culprit.

  • cjhockey35 Level 1 (0 points)

    I will also confirm that Google Drive was the culprit. I was having the same issue, and found a youtube video suggesting that google Drive was the cluprit. So i discinnected my account and re signed in and now I am having no issues. Weird stuff.

  • cvkalyank Level 1 (0 points)

    Its a bug in Mavericks. Temporary fix is quit Google Drive

  • gotsche Level 1 (0 points)

    Yes same problem here! My mac will jump from any fullscreen app to the desktop every minute. Started after I installed mavericks!