Previous 1 2 3 Next 34 Replies Latest reply: Jun 10, 2015 2:46 AM by BurywoodUK
shovelhead-steve Level 1 (0 points)

Itunes could not copy (name of song) To the ipod (name of ipod) Because an unknown error occurred (-50)

  • planb77 Level 7 (32,315 points)

    The only suggestion I have at this point is to take a look at this Apple support document related to your issue.

    http://support.apple.com/kb/TS1539

     

    B-rock

  • rebeccamenard Level 1 (0 points)

    I don't know how to fix it but I know how to get around it. Copy the error song's files to a USB. Once the error songs are on the USB, drag those songs straight to your iPod from the USB. From the USB files to your iPod that should be connected to iTunes. It worked for me. Hope this helps!

  • planb77 Level 7 (32,315 points)

    Are you saying you dragged the songs from the USB drive over to your iPod in iTunes correct?

     

    B-rock

  • rebeccamenard Level 1 (0 points)

    Yes, exaclty.

  • planb77 Level 7 (32,315 points)

    Thanks. Just thought it would help to clarify that for anybody else who may run across this thread.

     

    B-rock

  • artfuldodgr42 Level 1 (0 points)

    I had this problem with a new album I downloaded this week from Amazon. It looks like they changed their cloud player download functionality within the last few weeks.

     

    I previously tried the steps listed here: http://support.apple.com/kb/TS1539

    I had also tried Windows Updates and a few other suggestions I found on this topic and nothing had worked.

     

    In iTunes, when I right-click on the track to "Get Info," I noticed it lists WHERE at the bottom of the Summary tab to show where the file is located. It said the file was located in \\?\C:\mp3\... Amazon automatically downloads my mp3's to this directory and imports them to iTunes. I assumed there was something wrong with the mapping, due to the \\?\.

     

    If you notice your files are not mapped to a valid location:

    • Highlight the affected tracks and press the <Delete> key on your keyboard.
    • Select the Remove option when prompted to remove the files from your Library.
      • Take care to Keep Files if prompted so you don't completely remove them from your computer.
    • Locate the files on your computer and drag them to import back into iTunes. If you check the location mapping in Get Info, the directory should now be valid.

     

    I think the USB workaround above might resolve this issue, but this probably helps to explain that the files locations weren't referenced in iTunes correctly in the first place.

     

    Message was edited by: artfuldodgr42

  • planb77 Level 7 (32,315 points)

    Thanks for sharing what worked for you!

     

    B-rock

  • Pinner Blinn Level 1 (0 points)

    Thanks for the response.  I just had the same problem with Amazon.  But here's a simpler solution.  Simply delete the tunes from your iTunes account.

    Then go to the File menu, and choose Add Folder to Library...

    Browse to the place where Amazon puts your files

     

    C:\Documents and Settings\(your-account-name)\My Documents\My Music\Amazon MP3

     

    and choose the folder containing your music files.

     

    After  I did that I was able to drag from my itunes music library to my ipod.

  • planb77 Level 7 (32,315 points)

    Very simple indeed.  Thanks for sharing as well!

     

    B-rock

  • KouklaM Level 1 (0 points)

    Nice workaround -- it worked beautifully.

  • planb77 Level 7 (32,315 points)

    Thanks for sharing this also worked for you as well!

     

    B-rock

  • siddenke Level 1 (0 points)

    Thanks, fixed the problem completely and easier than the USB trick, though both worked well.

  • planb77 Level 7 (32,315 points)

    And thank you sir for posting what worked for you!

     

    B-rock

  • nycitygal Level 1 (0 points)

    The songs that were causing this error for me were also from Amazon -- I hadn't even put 2 and 2 together. Thanks for the tips -- re-adding the files worked like a charm.

Previous 1 2 3 Next