3 Replies Latest reply: May 4, 2012 1:10 PM by Carolyn Samit
Jim Constant Level 1 (100 points)

Lately I've been having trouble watching videos on YouTube. They stop and stutter a lot, to the point where I have to give up. At first I discovered that The Google had put me in their HTML5 beta program unbeknownst to me. That was causing some problems as well so I opted out of it for the time being.


I fired up Activity Viewer and saw that when I'm experiencing the problem the process called QTKitsever -(703) Safari Web Content is maxing out my CPU bringing my Macbook Pro to a screaching halt (note I checked a second time and the -(703) had changed to -(812) for some reason). Safari seems to work fine otherwise, but as soon as I go to YouTube and try to watch a video the process kicks in and my Mac chokes.


From what I've been able to find, this process seems to be used to help QT X play QT 7 video, although I'm not sure if this is the case.


Is there anything I can do to fix this?



MacBook Pro, Mac OS X (10.7), 2.2 Ghz Intel Core i7
  • Carolyn Samit Level 10 (102,820 points)

    Hi Jim..


    Most YouTube content requires the Flash plugin...  try troubleshooting.


    Quit Safari.


    Open System Preferences > Flash Player then select the Storage tab. Click: Delete All


    Now uninstall the Flash plugin then reinstall new >  Troubleshoot Flash Player | Mac OS


    Launch Safari From your Safari menu bar click Safari > Empty Cache


    Now try a video.


    BTW... if you have the ClickToFlash extension installed, that can prevent Flash based video from streaming. It can also be installed as a plugin in /Library/Internet-Plug-Ins.


    And check to see if Safari is running in 32 bit mode. Right or control click the Safari icon in your Applications folder then click Get Info. If the box next to:  Open in 32 bit mode  is selected, deselect, quit then relaunch Safari.

  • Jim Constant Level 1 (100 points)

    Thanks Carolyn.


    My problem seems to have been resolved for now. Unfortunately, I'm not entirely sure which action I took fixed it.


    The first thing I did was make sure I wasn't in the YouTube HTML5 trial. A month or so ago I suddenly couldn't play YouTube videos and figured out that I had been added to the trial. I opted out, problem solved.


    However, when my recent problems with YouTube began I went back and checked to make sure I hadn't been put back in the trial. I hadn't, so I started looked for other solutions and posted my question.


    I did the things you suggested (however I upgraded the Flash plugin without unstalling the existing one first). It didn't correct the problem. But on a whim, I went back once again to the HTML5 trial page and found I had been added back into the trial. I opted out again and the problems went away.


    So, I don't know what to attribute it too because there was a short period of time where I wasn't in the trial and also hadn't done any of the things you suggested yet it still worked.


    Anyway, I appreciate the help. Thank you.



  • Carolyn Samit Level 10 (102,820 points)

    (however I upgraded the Flash plugin without unstalling the existing one first)


    Just empting the Safari cache can help.


    If you have problems in the future, make sure and uninstall the current plugin before reinstalling new.