5 Replies Latest reply: Mar 3, 2013 9:41 PM by yokoyam3
KJBHYP Level 1 Level 1 (0 points)

Hey guys, I recently bought a new Macbook Pro (10.7.3) It's past it's 90 day warranty period. I just started using Garage Band to record some audio with music bed.

 

I opened a new project, began setting my levels and effects etc "saved it" ready to start recording. I opened my files folder for new project, clicked on the saved file, then a message came up saying "the file couldn't be opened"

 

I tried this a number of times, same thing happened - except twice when it did open once but then froze again.

 

Over all I keep getting the message "the file couldn't be opened"

 

Any suggestions on how to sort this? Thanks - Cheers


MacBook Pro
  • sierramadre Level 1 Level 1 (0 points)

    I have this same problem. I have a lot of Garage Band files and when I try to open any of them, I get the error message "the file could not be opened."

     

    I can, however, open any of them in my root directory. I have been to the Genius Bar twice and no one seems to be able to firgure this out. They delete the gb playlists but this does not work.

     

    Does anyone have any suggestions?

  • musicguy1979 Level 1 Level 1 (0 points)

    Hi Guys.

     

    Same issue here.

     

    Latest GB version, all up to date.  Randomly yesterday I've been unable to open ANY GB projects.  Cannot create new ones either.

     

    Tried the usual repair permissions, delete prefs, etc.  Still get the "Couldn't open the file" message.  I've been searching online for some kind of solution but to no avail.

     

    I'm all out of ideas.

     

    On a 2011 Macbook Pro 2.2 Ghz core i7, 4Gigs RAM, using OS X 10.7.4

     

    I hope someone sees this who can remedy this!

  • musicguy1979 Level 1 Level 1 (0 points)

    OK, an update.

     

    I've tried uninstalling Garageband completely (labourious process btw) and have reinstalled from the Mac App Store.

     

    Still not working.

     

    I've repaired permissions and deleted preferences again, with no luck.

     

    I have no idea what to do.

     

    Sigh.

     

    Do I need to totally reinstall OS X or what?  Very frustrating.

  • musicguy1979 Level 1 Level 1 (0 points)

    Oh yes, I forgot...

     

    My apologies for hijacking this thread.

     

    More info:  It seems on other users of this computer (my wife's account for example) GB opens and operates fine. So it seems the problem is user specific.  I'm the admin of the computer.

     

    Also, not sure if it's relevant, but I have a Bootcamp Windows partition as well.  Although I don't think it has anything to do with the issue at hand.

     

    That's all the info I have.

     

     

     

    Good Luck to all of us with this problem!

  • yokoyam3 Level 1 Level 1 (0 points)

    I bought Garageband '11 less than a month ago and I had the same problem. I could not open any file nor create any new project in my main account (it is admin account indeed). It totally worked fine from other user accounts. I fist went to Genius Bar at the local Apple store. They could not solve it (they trashed preference files, plist, etc.) so they refered me to Apple support by phone (it was fee since I recently purchsed the Grarageband, less than a month ago). It took two sessions to resolve it but finally it is working!!

     

    What we found was following. First, we enable root login and logged in as root (I forgot the details of how to of this part)., then looked at /Users directory. I found that my account was "locked". I just needed to uncheck the "locked" box in get info window. After that, it suddenly started workin on my account! At least, it worked for me!