3 Replies Latest reply: May 4, 2012 8:53 AM by IreneCT
IreneCT Level 1 (0 points)

I received my iPod (8GB) yesterday and have been struggling to set it up correctly. For some reason it will not recognize my wireless password. I use a Linksys router that has the latest firmware installed - I double checked this already. My other wireless devices are working properly, just not the iPod. I also double-checked, using my other wireless devices, that I was using the correct network id/password.


In addition (please tell me if I should divide these questions into two submissions): my computer (PC) will not recognize the i-pod as being connected via the USB line (enclosed with the i-pod). Again, I tried other USN devices to confirm that the problem is not within the USB port. Basically, I'm having trouble getting the iPod to do anything other than to keep prompting me to enter my wireless network password. Please help, if you can! Thanks

iPod touch, Windows 7
  • lllaass Level 10 (176,213 points)
  • IreneCT Level 1 (0 points)

    Illaass - thank you, very much, for your prompt reply.


    My router is using WPA/WPA2 security


    I was unclear in my first post: the problem I have with the iPod and Windows is that Windows doesn't recognize the iPod when it is attached via the supplied USB cable. Therefore, I cannot download anything to the device from any source.


    As for the WiFi Issue: Prior to posting my issue, I did a search through the site and found the article you reference. After following the outlined steps, the problem remains. I even disabled security and tried to connect, but it still flashes the "cannot connect, invalid password" alert. Another issue has just cropped up: the iPod keeps turning itself off - not sleep mode or darkened screen mode - completely off and must be restarted using the on/off switch. Very odd. Is it possible that there is something wrong with my iPod?

  • IreneCT Level 1 (0 points)

    Sorry - I should add that I will try taking my new iPod to the Apple store, perhaps this weekend, for their hands-on help. Thanks!