10 Replies Latest reply: May 10, 2012 2:39 PM by aleidy
aleidy Level 1 Level 1 (30 points)

I sent a 65-minute video to Compressor from Final Cut Pro X. In Compressor I used the 'Dolby Digital Professional' and 'MPEG-2 for DVD' settings from the Disc Burning folder as targets, and added a job action to create the DVD. I left all default settings. DVD worked fine with good audio and great picture. Then I manually added Chapter marks in Compressor and created another DVD. This DVD had no sound for about half the video. Any ideas on how I can add Chapter marks in Compressor without losing audio? This is for a school Talent Show with about 25 different acts, so I really want to have a Chapter selection on the DVD. If I try other apps to make the DVD (FCP X, iMovie, iDVD) the video quality suffers terribly, so I'm hoping I can get Compressor to work. Thanks for any help.

Compressor, Mac OS X (10.7.3), Compressor v4.0.3
  • Russ H Level 6 Level 6 (18,805 points)

    Interesting…haven't heard of this one before.


    Guess I'd start by verifying that all 25 markers are indeed chapter markers.


    What's the pattern…intermittent…30 minutes norma followed by 30 minutes of silence…or what?


    BTW, if you use chapters with iDVD, did it play correctly (quality aside)?



  • aleidy Level 1 Level 1 (30 points)

    Thanks Russ. Yes, I think they are all indeed chapter markers. The chapter selections work fine on the DVD and all appear to work correctly when selected. They also played correctly when I used iDVD.


    The audio is missing for the first 30 seconds or so, then it sounds fine until about 14 minutes in where it drops out again. I believe it remains off for the rest of the DVD. The audio start and stop times do not correlate with chapter marks.


    My working theory now is that I when made the first DVD without chapter marks, I was at the very limit of what would fit on the DVD. Adding the chapter marks added enough pages to the menu to put me over the DVD capacity limit, so some audio got dropped. Based on recommendations I saw you make in another discussion, I've backed off on the Average Bit Rate from the default of 7.7 Mbps to 7.4 Mbps. I'm hoping that resolves the suspected capacity issue. I'll let you know if that works. I also changed to Two pass VBR (instead of single pass) so processing is taking a very long time.



  • aleidy Level 1 Level 1 (30 points)

    Okay so reducing the average VBR didn't work. Still having the same problem. The audio comes on midway into Chapter 1, and goes out at Chapter 6, about 15 minutes into the video, never to return.

  • Russ H Level 6 Level 6 (18,805 points)

    In the Compressor's Inspector, in the summary pane, what does it give as estimated file size?


    In iDVD, Project>project info, what does it indicate as file size?



  • Studio X Level 7 Level 7 (27,030 points)

    What format is the audio - ac3 or aiff?


    If aiff, convert it to ac3 in compressor before building your DVD.


    AIFF audio takes up a LOT of the DVD's bandwidth.



  • aleidy Level 1 Level 1 (30 points)



    Looks like I have a good workaround, but to answer your questions, Compressor shows estimated file size for the MPEG-2 to be 4.16 GB. It shows the AC3 file estimated file size to be 103.69 MB. iDVD shows a total file size of 3.66 GB.


    I'll explain my workaround in a separate reply.

  • aleidy Level 1 Level 1 (30 points)

    Studio X, thanks for the help. I was using ac3 for the audio. I tried aiff also to see if it would help, but I ran into the same problem with intermittent audio. However, I do have a workaround I'll explain in a separate reply.

  • aleidy Level 1 Level 1 (30 points)

    I've come up with a fairly straightforward workaround for this. In Final Cut Pro X, before sending to Compressor, do an audio-only export to an AC3 file (Share...Export media, select "Audio Only" for Export and "AC file" for Audio file format). Then use the "Send to Compressor" function from the Share menu in FCP X. In Compressor, create a DVD using the standard "Dolby Digital Professional" and "MPEG-2 for DVD" settings and adding a "Create DVD" job action. Make sure the target AC3 file name in Compressor has a different name (or location) than the AC3 file you created in FCP X. The resulting DVD does have intermittent audio as before, so it can be discarded.


    Here's the trick:


    Open the folder containing the Compressor-created AC3 file, copy the file name, then move that file to the Trash. Find the FCPX-created AC3 file, rename it with the name of the Compressor-created AC3 file, and move it into the folder where the Compressor-created AC3 file was before you moved it to the Trash. Now you can resubmit your job from Compressor and it will burn a new DVD using the AC3 file you created from FCP X, which should have good audio. For me this created a great looking DVD with the high quality MPEG-2 video from Compressor, and the good audio AC3 from FCP X.


    I think there is a bug when sending FCP X projects with multi-cam portions to Compressor. I've seen two other cases of this on the discussion boards and multi-cam appears to be the common thread. I can't think of any logical reason that an AC3 file created in FCP X would sound fine, but the same FCP X project sent to Compressor results in an AC3 file with intermittent audio.


    At one time I thought the issue was exceeding the capacity of the DVD. But after experimenting I learned that an AC3 file created in Compressor from my multi-cam FCP X project has intermittent audio, even without a "Create DVD" job action. (I used VLC to play back the AC3 file and had the same intermittent audio I had with the DVD).

  • Russ H Level 6 Level 6 (18,805 points)

    It's great that you found a solution for your problem.


    Your idea that it's multicam-related caused me to a test of a muticam project I delivered last week. Not as long as yours, (mine just under 30 minutes), but I brought the master file into Compressor, chose the DVD preset, added 26 chapter markers, submitted and went to dinner. Returned and tested all 26 chatpers without finding any audio problems.


    So it seems that it's not conclusively a systemic bug – even though it was clearly a very real and substantive issue in your case.


    However, if I ever run into this, I'll definitely try your work-around.



  • aleidy Level 1 Level 1 (30 points)

    Thanks for checking on that, Russ. Hopefully it was an isolated incident.