6 Replies Latest reply: May 11, 2012 8:23 AM by NonTechKaren
NonTechKaren Level 1 Level 1

I own a tangerine iBook, OS X 10.4 operating system.


For a year or so charging the battery while the power cord in has been a "fussy" project -- sometimes it wouldn't charge until I moved the "plug-in-to-the-computer" end of the cord out ever so slightly. I bought a new power cord, but that didn't change things.


I don't have internet at hom, so most days I take my laptop and power cord to the public library and use the library's WiFi to look for work. Yesterday I came home, plugged in the power cord, and no battery charging light. I "jiggled" the cord, got out the old power cord and tried that one, then I tried a different electrical outlet. No battery charging indicator light, and the battery is discharging while I use it with the power cord.


I'm assuming this is an electrical problem that I can't fix, but can anyone fix it? When the battery runs out, will the iBook keep running when plugged into an electircal outlet, or is the electricity not getting to where it need to be?


I've had problems with the battery not charging before, and once I was advised to reset something, but I've alway had the indicator light on, so now I don't know if power is getting to my computer.


I went to About This Computer, clicked on Power and saw this:

AC Charger Information:


  AC Charger (Watts):    0

  Connected:    No

  Charging:    No


which looks like it doesn't think I'm connected to any power source.

Solved by NonTechKaren on May 6, 2012 1:55 PM Solved



Thank you so much for taking the time to help me (and countless others).


The good news for me is that I had two bad power cords. The power cord I was using went bad, I dug out my "spare" power cord, which didn't work, and I assumed the worst. But a working power cord fixed the problem. That's a great relief for me, but I'm rather embarassed to have to 'fess up that I assumed that two non-working power cords meant I had a serious problem.


I'll get a new back up power cord just in case the one I'm using goes bad.

Reply by Ronda Wilson on May 5, 2012 9:04 AM Helpful

Yes, if resetting the PMU doesn't work, it does sound like the DC-in board has failed.


It is not an easy repair (especially for someone who describes herself as "NonTech."




Not exactly cheap, either:


http://www.ifixit.com/iBook-Parts/iBook-Clamshell-DC-In-Board/IF149-023?utm_medi um=frame_module_bottom&utm_term=ibook_g3_clamshell&utm_source=ifixit_guide&utm_c ontent=related_products

All replies