9 Replies Latest reply: May 12, 2012 10:16 AM by Hotwheels_McG
Hotwheels_McG Level 1 Level 1 (0 points)

Ok so like many of you, I have become quite frustrated at home sharing not working properly.  I was all working well until, well i don't know what cause it. Currently it seems to work with all my devices accept my iPhones. We have the following equipment:

 

-iMac running Lion

-Apple TV 2

-iPad

-iPad 2

-2 iPhone 4's

all ios deviceses running latest ios, and all devices are under the same apple id.

 

I can access media with my ipads, use the remote app with iPads, stream to ATV2 from iMac. But the second I try to access anything with an iphone, all bets are off. sometimes they work, other times they seem to crash home sharing all to gether, and at the moment, they don't work at all. can't even see my itunes library to share from or control it with remote app. 

 

Anyone else haveing similar issues? Hopefully this post will add some further info that will alow someone to figure it out and fix it.


iPhone 4, iOS 5.1
  • jmpropst Level 1 Level 1 (0 points)

    Same problem here with 4s. I asked 2 other 4s owners to try theirs with completely different routers and none of us can stream music/video from our macs to our iPhones using home sharing. The shared library option doesn't even appear anymore. Clearly there is a known issue that Apple needs to address or at the very least acknowledge and report a plan to fix.

  • pbarker Level 1 Level 1 (0 points)

    I've been banging my head off this for days, ever since upgrading to an iPhone4s and I just fixed it.

     

    On my router I have a QoS option to enable or disable WWM. The help text describes this as

     

    "WMM (Wireless Multimedia) is a subset of the 802.11e standard. WMM allows wireless traffic to have a range of priorities, depending on the kind of data. Time-dependent information, like video or audio, will have a higher priority than normal traffic. For WMM to function correctly, Wireless clients must also support WMM."

     

    If I disable this home sharing starts to work. With this enabled I cannot see my shared library at all on my iPhone 4S.

     

    Hope this helps someone.

  • jmpropst Level 1 Level 1 (0 points)

    I actually already did that to resolve another issue. The mirroring from ipad2 to apple tv was lagging and disabling wmm fixed it. However, I still cannot see shared libraries on iPhone 4s. iPad works fine though.

  • Hotwheels_McG Level 1 Level 1 (0 points)

    Ok so I checked my router and only found options forS  but not the WMM. Tried disabling it and no luck.

     

    Jmpropst: you should enable those settings again and just assign a higher priority to video and voice. Chances are if your using those, your not using other media at the same time and vice-versa. But if you don't, other media will disrupt you mirroring/ AirPlay. With it disabled, all media shares bandwidth equally,  so if you mirroring, it will work great until someone else starts going to YouTube/Netflix/etc or airplaying a movie and they will both/all suffer reduced quality. 

     

    So here is another note that I just noticed. I cannot AirPlay with my iPhone 4 either. I am able to AirPrint fine. Also, I am able to set up and pair my iPhone 4 to iTunes (I.e. iTunes sees the phone) via the remote app, but cannot control library with it. It does seam to be working to control my ATV 2 now.

     

    Also just got the new iOS 5.1.1 but no change.

  • Hotwheels_McG Level 1 Level 1 (0 points)

    Well, new development. I rebooted my phone and it seems to be working now. Maybe the latest update did fix it. If you don't hear back from me it's because it's all working great. Hope this lasts.

  • jmpropst Level 1 Level 1 (0 points)

    That sounds reasonable. How does one assign higher priorities?

  • Hotwheels_McG Level 1 Level 1 (0 points)

    Well every router is different. Start with finding out the ip address of your router.  If your not sure how just google your brand router and ip address. It's probably 192.168.2.1 login to your router using your browser and that address. Find the options for QoS and the rest should be fairly self explanatory. Mine was. I just selected user defined instead of auto and assigned the various media types your preferred priorities.

     

    P.s. all my stuff still seems to be working. Keeping my fingers crossed.

  • jmpropst Level 1 Level 1 (0 points)

    Ok, I use the cisco program to get in so it should be pretty easy.  I'll give it a try- thanks for the assistance.

  • Hotwheels_McG Level 1 Level 1 (0 points)

    No problem. If you get hung up at all, try using your web browser like I said.  I only say this because for me, in the past, those program's they include for accessing your router were unreliable and frustrating to use. But that was just me. Good luck.