Previous 1 2 Next 21 Replies Latest reply: Apr 20, 2006 4:03 PM by MlG
Mike Loiterman Level 1 (35 points)
I just got my new Intel Mini, but Windows file sharing is not working.

It's running 10.4.5

I open sharing and enable "Windows Sharing" and enable the correct account. First test purposes, the firewall is off.

From Windows, the machine appears within the Network Workgroup browser, and gives me a username and password prompt when I double click the machine name. But, after entering the correct username and password, the Windows username and password just reappears.

When I try to open a Windows share from the Mac, it says that the Alias connects to a missing item.

I can connect to other Macs fine, and I can ping all machines from the terminal.

I have three other Macs on my network that work fine with my current setup. Although they're all PPC and this is an Intel...

What's going on?

15" 1.5 GHz PB G4, 12" 1.33 GHz iBook G4, 1.42 GHz mini G4, 17" 1.8 GHz iMac G5, Mac OS X (10.4.5)
  • Mike Loiterman Level 1 (35 points)
    This is the error in the /var/log/samba/log.smbd when I try to open the share from Windows:

    [2006/03/07 00:53:47, 1] authods.c:opendirectory_smb_pwd_checkntlmv1(371)
    opendirectorysmb_pwd_checkntlmv1: [-14200]opendirectoryuser_auth_and_sessionkey key_length(0)

    Google shows nothing.
  • Mike Loiterman Level 1 (35 points)
    And accessing the Windows shares from the Mac seems to work fine.

    Ugh...what could cause this?
  • E. King Level 1 (0 points)
    I saw the same problem, called Apple but got no help. I can see shares on my iMac G5, but not the Mini Mac Intel. I sniffed arround, and noticed that communication with the iMac is over port 139 Netbios default, while communication the Mini Mac is over microsoft-ds port 445. According to the protocol 445 should do just fine with SMB, but that's not the case here. Windows just repeatedly pops up the dialog box!

    The traces show that NTLM challenge/response for SMB fails.

    Please post if you find any answers...

    Mini Mac Intel Duo   Mac OS X (10.4.5)  
  • DennisCo Level 1 (25 points)
    Folks, I have the same problem; I discovered when I tried to have my Sonos Desktop controller (on my mac PPC/G5) add the iTunes share off of my new Intel lMac Mini. Was on the phone with Sonos for 2.5 hrs.

    The Sonos tech support rep (who was great, btw) explained that Apple broke Windows file Sharing in the latest release of Tiger (10.4.5), specifically (and apparently only) on Intel Mac Minis. Which is exactly what I have.

    to be clear, Bonjour works fine. On my G5 I can see all machines and on the other 3 macs I can see every machine. The problem lies in something being broken in Samba (Windows file sharing) on that particular piece of hardware.

    There are multiple trouble tickets opened by several people including several from Sonos to Apple and Apple tech support knows about the problem. As far as I have been able to tell thus far, until we get an update to 10.4.5 from Apple, we're basically screwed.

    If you hear otherwise, I'd love to know because I can't go any further w/o this fix.

  • Hans - Sonos Level 1 (0 points)
    The specific problem with the MacMini file sharing is that it does not authenticate passwords properly (possibly an error in the opendirectory password database backend.

    The solution: make a public share that does not require a username and password. This is the only way I know of at this point to fix the problem until Apple publishes a fix. As long as your computer is behind a router this fix should be completely safe (I have made the folder read only and non-browsable for increased security).

    1) Open terminal from Finder -> Applications -> Utlities
    2) Type the command: sudo pico smb.conf
    3) Enter your password at the prompt
    4) Edit the file as follows (pico works pretty much like notepad)

    Add the following to the [global] section

    security = share

    Add the following section to the end of the file for the actual share – note that the path must point to the actual path of the shared folder on the Mac hard drive and paths on Unix are case sensitive (as are most things in Unix – so observe the case carefully). The text between the [brackets] is the name of the share (in this case, music).


    path = /Users/usersname/Music
    public = yes
    only guest = no
    writable = no
    printable = no
    browsable = no

    In Pico:

    Use Control-O to write the file
    Use Control-X to exit

    To access the share from Sonos, be sure to set option 3 (files on my network) when adding it and enter the UNC path to the share \\macname\music or \\macipaddy\music. The username and password should be left blank.

    To access the share from Windows simply enter the UNC path \\macname\music or \\macipaddy\music in the address bar of internet explorer.

    By switching to share level security and making the folder public and read only, anyone can access the share without authenticating.

    If you are a Sonos user and have encountered this problem I recommend contacting Sonos technical support and they can help you with a fix.

    Intel Mac Mini   Mac OS X (10.4.5)  
  • MystaWright Level 1 (0 points)
    I have been having the same problem and that worked for me. Thank you. There is a program that does the same thing but with less work.
    I found the link on
    After I followed the steps I used this program and I realized it does the same thing.
  • DennisCo Level 1 (25 points)
    Thanks to you both for the workaround. I'll give it a shot later tonite.

  • Hans - Sonos Level 1 (0 points)
    I skipped a step in my original post. You have to cd to the /etc directory prior to typing the command

    1) Open terminal from Finder -> Applications -> Utlities
    2) Type the command: cd /etc
    3) Type the command: sudo pico smb.conf
    4) Enter your password at the prompt
    5) Edit the file as follows (pico works pretty much like notepad)
  • Hans - Sonos Level 1 (0 points)
    Apple just released 10.4.6 and this appears to completely fix the Windows file sharing issue.

    Can anyone else with this issue verify this?
  • DennisCo Level 1 (25 points)
    Well, Wooooooooooooo hooooooooooooooooooooo

    i'll try it when i get home. if so, i'll give a confirmation on this forum later tonite.

    i sure hope it works.

  • SteveJK Level 1 (0 points)
    10.4.6 now allows me to log in to my share on my Intel Mac Mini but unfortunately allows access even after Windows Sharing is turned off on the Mac if the user account name is still "Enabled" on Windows Sharing panel. You need to disable the user account name then turn Windows Sharing off before it will turn access off. But......the "computer name" still shows up in the Windows network browser and can be opened, just with no shares available. The 10.4.6 version seems to still be somewhat broken.
  • DennisCo Level 1 (25 points)
    Well, I wish I could say that i've had luck tonite, but it's been pretty much a waste of my time.

    I installed 10.4.6 on the Mac Mini (which has the Lacie 250Gb drive containing all of my music in the iTunes Music folder, parent folder is on the Mac Mini drive in a folder alias called iTunes. also installed the PPC version of 10.4.6 on my dualproc G5.

    Started up the Sonos Desktop Controller on the G5 and again entered in the server name and share name (in this case, the itunes alias) and tried to connect...and got the good old "username / password not valid" stuff i've been getting.

    I am willing to admit that I'm doing something wrong... but I don't know what it is.

    to repeat my configuration, the Mac Mini has the 250gb external hard drive. in order to allow iTunes on that machine (and any other machine) to get to that external drive, i created an alias called iTunes on the mac mini. I also shared out this alias using the "sharing" dialog from iTunes. I checked "share my music/share entire library" and specified a name (i used "itunes"), no pw required.

    Going into Sonos, it's the same ol' dialog to set up a music library. specified that it's on a network drive, and then provided \\MacMini\itunes as the location, entered in my userID (have also tried it as blanks) and no pw. have also done this w/passwords just for fun; same result... that being told that my username / password is not valid.

    So, now what shall I try? Or, what dumb thing have I done?

    I have no idea what I've done wrong. will try to call sonos in the morning. too late tonite to call them or apple.

  • DennisCo Level 1 (25 points)
    I have had no luck tonite. Is it valid to share out an alias to a folder? I have my itunes music on a Lacie 250gb drive; the itunes "folder" on the main drive of the Mac Mini is an alias to the lacie folder.

    I am using the Sonos music server system; it uses Samba to connect to network drives. When i specify \\myminimac\itunes, i keep getting an error saying that my username/password are incorrect. i've tried no pw, no id, combinations.. nadda...

    help, please.

  • Hans - Sonos Level 1 (0 points)

    Did you migrate your accounts from a pre-exising mac (i.e clone another mac). If so, try creating a new administrator account and then try adding the share again.
Previous 1 2 Next