9 Replies Latest reply: May 9, 2012 1:18 PM by BDAqua
tomgossard Level 1 Level 1

I wiped my old PowerMac G4 so I could sell or give it away, but now I can't remember what password I put on it, and I can't get into it.  I think it was the old Leopard system.  Any ideas on how to bypass it or reset or locate it?

PowerMac, Mac OS X (10.5.8)
Reply by BDAqua on May 5, 2012 8:03 PM Helpful

Would definitely like to hear the cure, or at least the outcome!

All replies

  • John Galt Level 8 Level 8

    I'm not sure what you mean - if you erased its hard disk what is requiring a password...?


    To erase it boot from your original installation CD or DVD. With the disc in the drive start the computer while holding the C key. From the Utilities menu launch Disk Utility. Erase the disk. Install OS X.


    Be sure to include the installation DVD when you sell or donate the PowerMac. It is essential for many tasks.

  • tomgossard Level 1 Level 1

    I guess I didn't include enough information.  I had an old hard drive that was smaller, that I'd taken out of it, so I re-installed that one and put just the system software on it.  Then I wiped the other one completely so none of my personal information would be on it.  Now it starts up with a "Mac OS X" logo, but gets to the login window and says "unknown" and wants a password.  I must have used some simple password so I could show someone how it worked, but that was a couple of months ago, and now I can't remember it at all.


    It's an old chrome-door Power Mac G4, and I've tried starting it up with the "C" key, but it just defaults to the hard drive, and I can't remember how to get the CD door to open manually, either.  So, I have the CDs but can't get them in there, and I just keep staring at the "Mac OS X" login window.  I have a neighbor now who was interested in it, but I can't get it running, so I just look like an idiot.  "Give me a call if you remember the password, haha!"

  • tomgossard Level 1 Level 1

    Also, just took another look at the installation DVD, and it's version 10.6, so it's not even going to work on that machine.  This machine sat in a closet for a couple of years, and I'm thinking that's when I got rid of any old software disks I wasn't using, which was a lot.

  • BDAqua Level 10 Level 10

    Reset OS X Password Without an OS X CD...




    Admin Hack...




    Starts up like the first time you buy a new Mac, but after filling in all that info again, you should have access to the computer and the other Users & files will still be there... give the new User a different name than an existing one.

  • John Galt Level 8 Level 8

    That's one of several reasons you need your original system installation disc which should accompany the computer for the duration of its life.


    ...boot from your original installation CD or DVD.


    You can try to obtain one from Apple - you will need to pay a nominal fee.

  • tomgossard Level 1 Level 1

    Thanks for trying to help, folks, but even the 4-fold PRAM reset didn't do the trick.  I followed that "Admin Hack" link and tried it that way, 'cause the stubborn thing just kept bringing me back to that logon screen, but even after changing the amount of RAM and doing the cmd-option-p-r thing 4 times, it still wouldn't come up in single-user mode.


    I got totally sick of looking at that logon screen, and in the end, I was pretty sure I had recalled the right password, and it still wouldn't accept it.  So, this afternoon I took it to a place in San Jose called Mac Pro, where they say they can wipe the hard drive and re-install OS 10.5x clean for just $25.  All I wanted to do was give this old Mac to a friend, so I think $25 is a fair price.


    If y'all are interested, I'll get back with you on Monday when I pick up the machine with whatever they say was wrong with it.  Two possible complications are:


    1.  It sat in a closet for over a year, and when I fired it up a few months ago, the battery had gone bad and it wouldn't keep time or settings.  When I replaced the battery, nothing changed, so I took it back to the store and they said the replacement battery was dead, too.  The third battery they put on a tester, so we verified that it was good before I brought it home.  Still, I was seeing that warning message whenever I'd start up the Mac, although it was apparently resetting the clock with the internet, as I had it on my Airport network.  So, I suspect that something may have been shorting out the batteries . . . or,


    2. I had wiped the personal data off my hard drive.  I had done this by adding a second, smaller-capacity hard drive that I had in a drawer, wiping it using disk utility, and then copying the system onto it and using it as my startup drive, while I erased the larger one.  At least, that's what I think I did.  It sat in the corner and didn't get used again for another 2 months (my friend never got back to me) until a neighbor expressed an interest.  That's when I turned it back on and couldn't get in.  So, perhaps I deleted some essential file having to do with the single-user settings . . . anyway,


    I took it in, and before I left I warned the technicians about the suspected battery problem, but they seemed to not be concerned.  We'll see what they say on Monday.  Again, thanks for your responses!

  • BDAqua Level 10 Level 10

    Would definitely like to hear the cure, or at least the outcome!

  • tomgossard Level 1 Level 1

    Well, I'm sorry but I don't really have any definitive answers on that one.  I picked it up late in the afternoon on Monday, and the tech just said, "Good as new," adding that he'd re-installed the system and "added a bunch of applications" like he'd promised.  When I asked if he noticed a problem with the internal battery, he said "no, there's no problem."


    But when I got home and plugged it in, the computer was once more saying that the clock was off (by 40 years), and the system they'd installed was actually OS 10.4.  Disappointing.  However, my neighbor was right at my door as I drove up, and barely paid attention to my cautions about the internal clock.  The computer did boot in single-user mode, however, so there was no need for a password.  He paid me the $25 that the shop had charged and ran off with it, so I'm just gonna let that one go.  Thanks for your help!

  • BDAqua Level 10 Level 10

    Thanks for the report.