8 Replies Latest reply: May 6, 2012 1:50 PM by Terence Devlin
beth768 Level 1 Level 1 (0 points)

I tried to open iPhoto and received a message that "You can't open the application because it may be damaged or incomplete.   Suggestions?


iMac (27-inch Mid 2011), Mac OS X (10.7.3)
  • 1. Re: iPhoto failure in OS X Lion
    LarryHN Level 9 Level 9 (56,645 points)

    Reinstall iPhoto

     

    LN

  • 2. Re: iPhoto failure in OS X Lion
    Terence Devlin Level 10 Level 10 (123,735 points)

    To re-install iPhoto

     

    1. Put the iPhoto.app in the trash (Drag it from your Applications Folder to the trash)

     

    2a: On 10.5:  Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name.

     

    2b: On 10.6: Those receipts may be found as follows:  In the Finder use the Go menu and select Go To Folder. In the resulting window type

     

    /var/db/receipts/

     

    2c: on 10.7 they're at

     

    /private/var/db/receipts

     

    A Finder Window will open at that location and you can remove the iPhoto pkg files.

     

    3. Re-install.

     

    If you purchased an iLife Disk, then iPhoto is on it.

     

    If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.

     

    If you purchased it on the App Store or have a Recent Mac you can find it in your Purchases List.

  • 3. Re: iPhoto failure in OS X Lion
    Kristi Montague Level 1 Level 1 (0 points)

    I'm having the same problem. I had iPhoto '09, but I haven't been able to get it to sync with my iPhone, so I can't download my photos. I figured upgrading to iPhoto '11 would fix that, so I bought it through the app store and installed it and got this error. I have tried everything (including your exact steps) 10 times, and no matter how many times I delete all of the files and reinstall it I get the same error. I am running OS 10.7.3 on a Macbook Pro and all of my software is up to date. I have also restarted multiple times, but nothing has helped. Any other solutions?

  • 4. Re: iPhoto failure in OS X Lion
    Terence Devlin Level 10 Level 10 (123,735 points)

    Create a new account (systempreferences -> accounts or Users & Groups on 10.7)  and see if the problem is repeated there.

     

    Regards

     

     

    TD

  • 5. Re: iPhoto failure in OS X Lion
    Kristi Montague Level 1 Level 1 (0 points)

    Tried that and it's giving me the same problem under the other username. It seems to install fine from the app store, it just won't open and gives me the same error screen everytime.

  • 6. Re: iPhoto failure in OS X Lion
    Terence Devlin Level 10 Level 10 (123,735 points)

    Post the first 50 lines only of the crash report

     

    Regards

     

     

    TD

  • 7. Re: iPhoto failure in OS X Lion
    Kristi Montague Level 1 Level 1 (0 points)

    iPhoto cannot be opened because of a problem.

     

    Check with the developer to make sure iPhoto works with this version of Mac OS X. You may need to reinstall the application. Be sure to install any available updates for the application and Mac OS X.

     

    Then this is under report:

     

    Process:         iPhoto [9987]

    Path:            /Applications/iPhoto.app/Contents/MacOS/iPhoto

    Identifier:      com.apple.iPhoto

    Version:         9.2.3 (9.2.3)

    Build Info:      iPhotoProject-629052000000000~2

    App Item ID:     408981381

    App External ID: 7243044

    Code Type:       X86 (Native)

    Parent Process:  launchd [8187]

     

     

    Date/Time:       2012-05-06 15:22:43.400 -0500

    OS Version:      Mac OS X 10.7.3 (11D50d)

    Report Version:  9

    Sleep/Wake UUID: A08985FA-BF7B-4E46-886F-FB3A1A3858CA

     

     

    Interval Since Last Report:          52514 sec

    Crashes Since Last Report:           5129

    Per-App Crashes Since Last Report:   12

    Anonymous UUID:                      7B209349-65DF-4384-839E-46C0316636C4

     

     

    Crashed Thread:  0

     

     

    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000

     

     

    Application Specific Information:

    dyld: launch, loading dependent libraries

     

     

    Dyld Error Message:

      Library not loaded: /Library/Frameworks/NyxAudioAnalysis.framework/Versions/A/NyxAudioAnalysis

      Referenced from: /Applications/iPhoto.app/Contents/Frameworks/iLifeSlideshow.framework/Versions/ A/Frameworks/iLifeSlideshowProducer.framework/Versions/A/iLifeSlideshowProducer

      Reason: image not found

  • 8. Re: iPhoto failure in OS X Lion
    Terence Devlin Level 10 Level 10 (123,735 points)

    You need to reinstall the OS.

     

    Regards

     

     

    TD