2 Replies Latest reply: May 5, 2012 7:03 AM by turingtest2
readerjj Level 1 Level 1 (0 points)

I have several ! in my music library and the songs will not play.  What should I do?

  • 1. Re: I have several ! in my music library and the songs will not play.  What should I do?
    diesel vdub Level 7 Level 7 (21,935 points)

    Try a search of the forums or google and I feel certain you'll find an answer.

  • 2. Re: I have several ! in my music library and the songs will not play.  What should I do?
    turingtest2 Level 8 Level 8 (46,625 points)

    This happens if the file is no longer where iTunes expects to find it. Possible causes are that you or some third party tool has moved, renamed or deleted the file, or that the drive it lives on has had a change of drive letter. It is also possible that iTunes has changed from expecting the files to be in the pre-iTunes 9 layout to post-iTunes 9 layout,or vice-versa, and so is looking in slightly the wrong place.

     

    Select a track with an exclamation mark, use Ctrl-I to get info, then cancel when asked to try to locate the track. Look on the summary tab for the location that iTunes thinks the file should be. Now take a look around your hard drive(s). Hopefully you can locate the track in question. If a section of your library has simply been moved, or a drive letter has changed, it should be possible to reverse the actions.

     

    Alternatively, as long as you can find a location holding the missing files, then you should be able to use my FindTracks script to reconnect them to iTunes .

     

    tt2