2 Replies Latest reply: May 7, 2012 1:56 PM by SMR
SMR Level 2 Level 2 (205 points)

Lion makes the sleep process take a while.  But after a short time my Mac Pro wakes from sleep and even though I have it set up to go back to sleep after five minutes of inactivity it never goes back to sleep.  This wasn't a problem with the first version of Lion.


Mac Pro, Mac OS X (10.7.3), DP 2.7GHz Early 2009
  • Linc Davis Level 10 Level 10 (173,220 points)

    Test after each of the following steps that you haven’t already tried:

     

    Step 1

     

    ▹ System Preferences ▹ Energy Saver ▹ Power Adapter ▹ Wake for network access: uncheck. You may need to unlock the preference pane by clicking the lock icon in the lower left corner and entering your administrator password.

     

    Step 2

     

    ▹ System Preferences ▹ Energy Saver ▹ Schedule… ▹ Start up or wake: uncheck

     

    Step 3

     

    ▹ System Preferences ▹ Print & Scan ▹ Open Print Queue...

    Check all printers for unfinished jobs. Deal with any you find.

     

    Step 4

     

    Disconnect all wired peripherals except keyboard, mouse or trackball, and monitor, if applicable.

     

    Step 5

     

    Launch the Activity Monitor application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ If you’re running Mac OS X 10.7 or later, open LaunchPad. Click Utilities, then Activity Monitor in the page that opens.

     

    Select All Processes from the menu in the toolbar, if not already selected. Enter “powerd” (without the quotes) in the "Filter" text field. Select the powerd process and click the Quit Process button in the toobar (stop-sign icon.) In the sheet that opens, click Force Quit. You’ll be prompted for your administrator password. The process will be relaunched immediately.

     

    Step 6

     

    Boot in safe mode and log in. The instructions provided by Apple are as follows:

     

    • Be sure your Mac is shut down.
    • Press the power button.
    • Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    • Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Note: If FileVault is enabled under Mac OS X 10.7 or later, you can’t boot in safe mode.

     

    Safe mode is much slower to boot and run than normal. Don’t launch any applications at first. If sleep still doesn’t work properly, back up all data and reinstall the Mac OS. After that, if you still have the issue, make a “Genius” appointment at an Apple Store to have the machine tested.

     

    If sleep now works as expected, go on to the next step.

     

    Step 7

     

    Still in safe mode, launch the usual set of applications that are running when you have the problem, including your login items, one at a time, testing after each one. Some applications may not work; skip them. You might be able to identify the cause of the problem this way.

     

    Step 8

     

    If sleep is still working after you’ve launched all the usual applications, reboot as usual (not in safe mode) and test again. If sleep still works, you’re done, at least for the moment.

     

    If you still have the sleep issue after booting out of safe mode, post again.

  • SMR Level 2 Level 2 (205 points)

    Linc, thanks for the information.

     

    This is so frustrating.  In order to make "Back to My Mac" and "Find My Mac" work you must have wake for LAN access enabled.  When I disable that option, the machine appears to stay asleep and it appears to be able to honor the sleep setting I have enabled in Energy Saver.  So, I decided to do some more testing...

     

    It seems that in order to have the full capability of the OS and all of it's parts that much of it's basic functionality must be disabled, which then contradicts the original point of making it all work in the first place.

     

    My machine doesn't even attempt to sleep when the wake on LAN is enabled, set to sleep after 15 minutes and it never does.  Monitoring my network traffic shows that WOL messages aren't getting to my machine and therefore aren't what are keeping it awake.  The option to allow WOL packets to wake my Mac is all that's keeping it from sleeping!  This is ridiculous!