3 Replies Latest reply: May 6, 2012 9:03 PM by Camelot
jpbwh Level 1 Level 1 (0 points)

Help! - I'm trying to setup mail on Lion Sever (7.3). The only way I can get it to accept incoming mail is to specify the whole FQDN of the server in the address.


For example the domain name is example.com and I have a user set up called john. Sending mail to john@server.example.com works. But sending mail to john@example.com (which is what I want) returns an error:


554 554 5.7.1 <john@example.com>: Relay access denied (state 13).


For internal DNS, I have:

example.com - primary zone

mail.expample.com - alias server.example.com

server.example.com -

www.johnbutzek.com - alias server.example.com


MX record server.johnbutzek.com


Any help would be appreciated. I see references here to problems in mail on 7.3 but not this specific problem.

Mac OS X (10.7.3)
  • gracoat Level 3 Level 3 (660 points)

    Change the Internal MX record to johnbutzek.com without server.johnbutzek.com

    I see that your external records show the same problem.  You'll need to change those too.



  • jpbwh Level 1 Level 1 (0 points)

    Thanks gracoat. Behavior changed but still not working, now I get: 


    451 All MX servers are unavailable for domain johnbutzek.com


    on the original MX record config I thought that since I had a CNAME record pointing mail.johnbutzek.com back to johnbutzek.com that would have worked.

  • Camelot Level 8 Level 8 (46,395 points)

    This is less about MX records than it is your mail server configuration.


    Quite simply, your mail server doesn't know that it's supposed to accept mail for johnbutzek.com, so when it sees such a message it assumes it's supposed to relay it to another server, or bounce it if the sender isn't authenticated/trusted.


    Changing the MX may be valid, but it's not going to fix the problem. If the MX record points to this server all you'll get are 'MX points back to me' errors in the postfix log.


    Instead, you need to tell postfix what domain(s) it is supposed to accept mail for. RIght now it sounds like you have it set for 'server.johnbutzek.com' and that's your problem. Change it to 'johnbutzek.com' and your problem should go away.