Skip navigation

Logic Express 8 missing virtual instruments except Garageband instuments

392 Views 0 Replies Latest reply: May 5, 2012 3:48 PM by taydavko RSS
taydavko Calculating status...
Currently Being Moderated
May 5, 2012 3:48 PM

I just purchased a new iMac (i7). iLife '11 came installed on the computer. I installed Logic Express 8 onto the hard drive. It worked totally fine for a week, then out of nowhere today, all of the Logic instruments and channel strip settings have disappeared (Garageband instruments are all available though). The wierd thing is that when I open older projects, it still plays the arrangement with the original instrument. However, no matter how hard I look, I can't f***ing find them. I don't know what is happening here, but it's extremely frustrating. I have deadlines to meet and I cannot afford to restart everything. I've also tried uninstalling Logic, and still no insturments. I've even tried redownloading JamPacks, but when I go through the installer it says my computer doesn't need the update. I'm very angry and have no idea what to do here...

 

Any help would be ridiculously appreciated. Thanks so much to those who answer!

 

-T

iMac, Mac OS X (10.7.3), Logic Express 8

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.