5 Replies Latest reply: May 7, 2012 1:52 AM by léonie
Jim Constant Level 1 (105 points)

I've looked at many of the discussion thread about this issue but none of them have provided an answer that has solved my problem.


I click on a loop and I get the message that says, "The Software Instrument or Apple Loop selected is not currently installed on your computer. Would you like to install the complete set of GarageBand instruments and loops?"


I've selected the Download Now option which causes Software update to run and then it tells me all of my software is up to date.


I've also tried to use the Download later option by selecting it, quitting GB, going to Software Update the check for them, but still nothing.


I've seen the link to the site that suggests selecting the option to Install from DVD. I see no option to install from DVD. I only have the Download Now and Download later options.


I've tried to use the DVD that came with my Macbook Pro using the 'Customize...' option. I can see that all the the iLife apps are already installed of course so the installer will only give me the option to install 'CPU Help Files'.


I've got plenty of hard drive space so I know that's not an issue.


Any help appreciated.



MacBook Pro, Mac OS X (10.7), 2.2 Ghz Intel Core i7
  • Jim Constant Level 1 (105 points)

    Should have said I'm running GarageBand '11 (ver 6.0.5) on Lion.

  • Jim Constant Level 1 (105 points)

    Well guess what I found - a folder called Apple Loops for Garageband...


    I was searching for all GarageBand related files in order to delete them and try to reinstall the app. I found this folder, opened it up, and lo and behold there are 1,699 .aif and .caf files. But it appears that the .aif loops are the ones that appear in the loop browser of GB but produce the message saying I need to download and install the complete set. The .caf loops on the other hand seem to be working as expected.


    So I guess my quesiton has changed a little. Does anybody know why the .caf files would be working while the .aif file wouldn't. Any idea how to get GB to recongize and use them?



  • léonie Level 10 (90,719 points)

    To make GarageBand recognize all installed loops, it may help to index the loops:


    drag the folder with the loops that to appear to be missing onto to the loop browser, then GarageBand should add them to the index.



  • Jim Constant Level 1 (105 points)

    Thanks for the suggestion leonieDF. I dragged all of the loops into the browser and GB did it's little process of indexing them. However, I now have a lot of duplicates - one of which plays and another which prompts me with the message, "The Software Instrument or Apple Loop selected is not currently installed on your computer. Would you like to install the complete set of GarageBand instruments and loops?"


    Here's what my loop browser looks like now:




    Do you happen to know how to get rid of duplicates?

  • léonie Level 10 (90,719 points)

    Sorry for that! Hopefully rebuilding your loop index will solve this.


    To create a new loop index, that does not contain the references to the missing loops, remove the contents of the old loop index from the Apple Loops Index folder and then again drag the loops to the loops browser.


    • Quit GarageBand if it is running.
    • Remove the contents of the folder /Library/Audio/Apple Loops Index/  to another folder on your Desktop.
    • Relaunch GarageBand - now the Loop Browser should appear completely empty.
    • Drag all folders with loops onto the Loop Browser in GarageBand. This will reindex the Loops. After this, only loops installed on your machine should appear in the Browser.





    P.S. if still broken references appear, you may have more than one loop index folder in your library. Then you need to search your library with Spotlight for all instances; see here: