8 Replies Latest reply: May 6, 2012 2:24 PM by John Galt
KDCS iBook Level 1 Level 1 (0 points)

I think I have a virus - my hard disk is full allthough I only have about 20G of 60 used. I cant install a virus checker as I have lost my administrator rights (when I check in accounts, I am just a "standard" user. This means I cannot install any software as it will not let me run the installer program - says incorrect username / password


iBook G4, Mac OS X (10.4.11)
  • John Galt Level 8 Level 8 (42,325 points)

    You may have a corrupted disk but you do not have a virus. Boot using your original system installation DVD and run Disk Utility. Repair the disk.

    If you have no Administrator accounts at all, follow this procedure to create a new, temporary Administrator account from which you can fix your normal one.

     

    • Power on or restart your Mac.
    • At the chime or grey screen, hold and S on your keyboard to enter single-user mode.
    • At the prompt, type

     

    fsck -fy

     

    and press Return.

     

    This is a simple check for file system integrity and is optional. It will take a moment or two to complete. Wait for it to finish before proceeding.

     

    • Type the following exactly as written, one line at a time, each line followed by the return key. There is a single space preceding the first "slash" ( / ) character in each line:

     

    mount -uw /

    rm /var/db/.AppleSetupDone

    shutdown -h now

     

    When you restart the machine, it will take you through the entire setup and registration process all over again. When you do so, create a brand new account with Admin privileges. Give it a simple and disposable name since you will delete it later. Do not choose the option to transfer or migrate information to the Mac.

     

    When it completes, log in under that new account, change your previous account back to Admin, and log out.

     

    Log in using your old account, which will now have its Admin privileges restored. Delete the throwaway account you just created.

  • KDCS iBook Level 1 Level 1 (0 points)

    Hello John, thanks for the very detailed advice. Regarding the first point, I think whatever corruption I have has corrupted my combo drive also - when I put the installation DVD in, it just comes straight back out and when I look in disk utility, the drive is not there (just shows my hard disk).

    In any case, I decided to follow the secont part of your advice and set up a new administrator as then I may be able to run the repair disk from the disk utility as an administrator. This whole process worked fine but the new user was set up as "standard" and not administrator.

    Is there any way I can configure the combo drive during the boot up or any other way I can run the repair disk?

    Thanks, Keith

  • Ronda Wilson Level 8 Level 8 (41,085 points)

    When you create the new user account, you have to choose to give it administrative privileges (make it an Admin account).

     

    Here is Michael Conniff's User Tip on this problem:

     

    https://discussions.apple.com/docs/DOC-1902

  • John Galt Level 8 Level 8 (42,325 points)

    Hi, Keith,

     

    To boot from the installation DVD, first shut down the computer. Then, start the computer and immediately insert the DVD. Hold the C key as soon as the DVD is drawn in. The computer will then load the operating system from the DVD and not the internal hard disk. If you hear a lot of optical drive activity and it is taking a long time to start then it is proceeding normally.

     

    Disk Utility will not show the Combo drive until there is a disc inserted.

     

    If you followed the "new user" technique above, no choice to administer the account is provided. It should have created a new Administrator user by default.


    Do you have an Open Firmware password set?

  • KDCS iBook Level 1 Level 1 (0 points)

    Thanks again John. I managed to boot from the DVD, ran the repair disk in the disk utility and it reported back that no repairs were necessary. I then rebooted and went though the second part of your original response again to create another administrator. Still no change, hard disk is full and the new account is standard.

    Any other ideas?

    Thanks

     

    Keith

  • John Galt Level 8 Level 8 (42,325 points)

    OK, now that you can boot from the installation DVD let's restore your Admin privileges.

     

    Start up from the Tiger installation DVD. When you get to the "Welcome to the Mac OS X Installer" screen, choose "Reset Password" from the Utilities menu. Follow this procedure (from Mac OS X 10.5: Administrator user changes to standard and applies equally well to OS X 10.4.11):

     

    1. Select your startup disk (usually this is called Macintosh HD)
    2. From the dropdown menu "Select a user of this volume..." select "System Administrator (root)"
    3. Enter a password in the fields that appear and click Save. Remember the password.
    4. Quit Reset Password.
    5. Quit Installer: select your startup disk which ought to be "Mac OS X, 10.4.11 on Macintosh HD" and click Restart.
    6. When the login window appears, select "Other..." and log in as the root user using the password that was created above. 
      • Note: If Mac OS X automatically logs in, choose Log Out (name) from the Apple menu to get to the login window.
    7. Go to System Preferences > Accounts, select your normal account, and check the box "Allow user to administer this computer".
    8. Quit System Preferences.
    9. From the Apple menu, choose Log Out root....
    10. Log in under your normal account.

     

    Your account should now have administrator access.

     

    Lastly, use Directory Utility to disable the root user via Directory Utility's Edit menu. You may need to click the lock icon first.

     

    If you get stuck on any of the above steps let me know which one.

  • KDCS iBook Level 1 Level 1 (0 points)

    I think there are some serious gremlins in my operating system!

    I did as you suggested - booted from the install disk, went to reset password but then the only disk in the "Select disk" window was the install disk - my hard disk (Macintosh HD) was not there so I could not get to the "System Administrator (root)" for my startup disk.

    I think I may have to resort to reinstallingthe operating system??

    Any other suggestions before I resort to reinstalling?

    Thanks

    K

  • John Galt Level 8 Level 8 (42,325 points)

    That's bizarre, but not unexpected since the earlier technique should have worked.

     

    I agree something is corrupted, unfortunately I do not know what else to do other than to reinstall Tiger. It won't erase your data, but I strongly recommend backing up your system to an external drive to be certain. The only concern is your free hard disk capacity, but that is not to be believed given the potential corruption.

     

    Don't install a virus checker. Such utilities will only cause the very problems you are experiencing.