Previous 1 2 Next 15 Replies Latest reply: May 28, 2012 2:36 PM by BDAqua
DMDUK2012 Level 1 Level 1 (0 points)



I have a Mac Mini running OS 10.6.8. 


Suddenly the networking functionality has stopped working and the diagnostics fails to fix it.  It shows all green lights apart from Internet and Server which both show as FAILED.


My router is operational and does assign the Mac Mini the correct IP address (confirmed by the Mac Mini and the Router).  All other devices on the network work and can access the internet as usual. 


I have tried everything that I can think of but just can't get it working again.


The same symptoms occur for both the wired ethernet and the wireless connection with the build-in airport.


Help please!  I don't know what other information you may need - please ask.


Thanks in advance.




Mac mini, Mac OS X (10.6.8)
  • BDAqua Level 10 Level 10 (120,915 points)

    Hello David,


    10.5.x/10.6.x/10.7.x instructions...


    System Preferences>Network, click on the little gear at the bottom next to the + & - icons, (unlock lock first if locked), choose Set Service Order.


    The interface that connects to the Internet should be dragged to the top of the list.


    With Airport... Instead of joining it from the list, click the WiFi icon at the top, and click join other network. Fill in everything as needed.


    Make a New Location, Using network locations in Mac OS X ...



    Have you restarted your Router?

  • DMDUK2012 Level 1 Level 1 (0 points)

    Thanks for the quick reply BDAqua.


    Unfortunately that didn't help - I'd tried that previously.


    The problem exists with both wifi and wired/ethernet connections.  The Mac Mini does get an IP address from the router but then doesn't go any further.


    I have tried flushing the DNS cache and that hasn't helped either.


    The router has been restarted numerous times to attempt to clear this issue.



  • BDAqua Level 10 Level 10 (120,915 points)

    OK, if it get's a good IP, try putting this in the URL bar of your browser...



    If that gets you to Apple...


    Then... Try putting these numbers in Network>TCP/IP>DNS Servers, for the Interface you connect with...



    Then Apply. For 10.5/10.6 Network, highlight Interface>Advanced button>DNS tab>little + icon.


    DNS Servers are a bit like Phone books where you look up a name and it gives you the phone number, in our case, you put in and it comes back with behind the scenes.  


    These Servers have been patched to guard against DNS poisoning, and are faster/more reliable than most ISP's DNS Servers.

  • DMDUK2012 Level 1 Level 1 (0 points)

    Thanks for your time and effort.


    Unfortunately that's a no-go too.



    I typed the IP address in the Safari address bar and it correctly resolves to but Safari error page updates to say " is unavailble" (or words to that effect).


    So this appears to suggest that there isn't a DNS error.




  • BDAqua Level 10 Level 10 (120,915 points)

    Could there be something else connected to the Router that is interfering?


    Is there any Port Forwarding or DMZ setup in the Router?


    Wait, you got one page at Apple to display, but then got that error? Or did it not display anything but that error?


    Open Network Utility>Traceroute tab, traceroute & both, how far do they get?


    On the Ping tab try... does that get responses?

  • DMDUK2012 Level 1 Level 1 (0 points)



    I tried again and it didn't resolve the IP address to  No, it didn't display the website, but the Safari error page.


    There have been no changes to the router.  The Mac Mini has operated with the router and all attached devices for the past few years without any issues.


    Just tried the TraceRoute and Ping utilities.  It'll ping/trace to the NAS-device on the network but it will NOT ping/trace to an external web address.



  • DMDUK2012 Level 1 Level 1 (0 points)

    I have now updated my Router to force DNS servers on all devices connected to the LAN.  They now all use Google's DNS.  All devices continue to operate correctly apart from the Mac Mini - this continues to have the same problem.


    The Mac Mini is now showing the two Google DNS IP addresses in its DNS preferance pane.


    However, there remains no Internet connectivity nor connectivity to the AFP drives on the NAS.


    Another thing to note: this is happening on wireless and wired so that's connecting to the router via two different MAC addresses from the Mac Mini.  This, to me, suggests that it there's something wrong with the Mac Mini and not the router nor the Mac Mini's method of connection.  Very strange.


    Message was edited by: DMDUK2012 (More details provided)

  • BDAqua Level 10 Level 10 (120,915 points)

    Hmmmm, pings not getting to an outside IP!???


    Have you disabled the Firewall, or in Security prefs... Allow all incoming connections?

  • DMDUK2012 Level 1 Level 1 (0 points)

    The Mac firewall is not running.  I've even turned it on and then off again (read that might help elsewhere here) but no change.


    I've created new 'Locations' and moved and deleted connections and priorities.  Nothing.


    I've tried reseting the SCM.  Nothing.


    All other devices continue to operate on the network correctly.

  • BDAqua Level 10 Level 10 (120,915 points)

    Can you try Internet Sharing on another computer & connect this Mac to it for a test?

  • DMDUK2012 Level 1 Level 1 (0 points)

    Okay, update as of 17th May:

    Had Apple Support on the telephone last night for over an hour trying to sort this out (paid for single event support).  No success.  Basically did everything you had already advised/said.  The tech guy was raising it up a level in the support team and they 'were' supposed to call back tonight but they haven't. 


    Have now had to put another support call request in for tomorrow.


    Frustrating that Apple failed to honour their commitment to call back tonight.





  • BDAqua Level 10 Level 10 (120,915 points)

    Oh man, sorry to hear it's even more of a problem now!

  • DMDUK2012 Level 1 Level 1 (0 points)

    Two calls from Apple Support today - one on-time which I scheduled via the website, and one which *may* have been the one the first Advisor had arranged (or put me into a queue for).


    No resolution yet.  I've been advised to reinstall the OS.  Unfortunately I cannot find my installation disc so Apple are kindly sending me a new one in the post. 


    I'll advise on progress to ensure that anyone else with a similar problem will have something to follow...



  • DMDUK2012 Level 1 Level 1 (0 points)

    Apple were true to their word and sent me a replacement OS X disc via TNT.  I reinstalled the OS (without erasing or reformating the drive) and the reinstall appears to have fixed the problem!


    I now have access to the Internet and things appear to be working as normal.  I'm happy.


    So, the fix: reinstall the OS.


    Thanks BDAqua for your help too.

Previous 1 2 Next