3 Replies Latest reply: May 8, 2012 10:31 AM by krstep
krstep Level 1 Level 1 (0 points)

I have got an old iBook G4 from a friend how can't fix this problem, and unfortunatly I can't either.

I know this problem is posted here milions of times but I tried everything possible, I just can't fix it.

I don't have an Mac DVD so I can't boot from DVD to repair/reinstall.

 

I have tried:

  • Booting in safe mode - same problem, it's impossible to use the computer
  • Booting in a single user mode - I can use the command line only, but when I but it's still the same problem
  • Clearing NVRAM

 

I can't do anything so I don't know what's installed. I have made a video to describe excatly what's happening - but in short the iBook boots fine, Finder lauches and crashes imidieatly - you can't do anything, it's just stuck in a loop.

Here's the video (skip to 0:55 for the problem):

http://www.youtube.com/watch?v=9niwiVSVyBo

 

Any solutions?


iBook, Mac OS X (10.4.7)
  • Graham.R Level 1 Level 1 (0 points)

    Ideally, you need an install disc. Try looking on eBay.

     

    It is possible to get into Disk Utility from the dock (the dock is a completely separate application from Finder), but that will only allow you to fix permissions on the startup disk; it won't let you repair anything that's been corrupted.

     

    It may also be possible to trash your Finder prefs, either via the dock or the command line. I'm no Terminal expert, but I believe the command is 'rm' to remove a file.

     

    A quick scan of my system shows Finder prefs located at:

    Users/your-username/Library/Preferences/apple.com.finder.plist

    Users/your-username/Library/Preferences/com.apple.finder.plist

    System/Library/LaunchAgents/com.apple.finder.plist

     

    Removing a prefs file forces OSX to create a new one, although I'd proceed with caution when deleting anything inside the System.

  • Graham.R Level 1 Level 1 (0 points)

    System/Library/LaunchAgents/com.apple.Finder.plist

     

    (Finder, not finder... in this particular instance)

  • krstep Level 1 Level 1 (0 points)

    I tried with deleting the plist file but the problem still persits.

    Well If there is nothing else to try, I guess an installation disk will be my only option