1 2 3 Previous Next 97 Replies Latest reply: Nov 16, 2012 7:11 AM by tuckermanfromwanstey
Tom Roehl Level 1 Level 1 (0 points)

I'm having a very frustrating problem with my Apple TV.

 

Here is the setup:  I have an Apple TV in my bedroom that I use to connect to my iTunes library that is set up with Home Sharing on an iMac in my living room. The actual iTunes library is stored on an external drive connected to the iMac. Everything is connected directly via ethernet so there is no WiFi in this setup. The Mac/iTunes/Apple TV have all the latest updates and patches installed.

 

The problem: When everything is working, everything is fine. The problem arises if I try to connect to my library on the Apple TV after the mac has gone to sleep. The Apple TV will see my library but every attempt to connect to it hangs on the 'Loading xxx libray' message and times out. It's not a network problem because I can still access things like trailers or YouTube. If I go out to the living room and wake the mac and/or restart iTunes everything works fine again.

 

Fixes?: I'm assuming it's a problem with the Apple TV not being able to wake up the remote mac and/or possibly a problem that the hard drive containing the iTunes library has gone to sleep and spun down. I've tried chaning the Mac system settings to prevent the cpmputer from going to sleep and turned on wake for network acces but that does not seem to work. I haven't played with Put the hard disk(s) to sleep when possible yet but I don't like the idea of having all my disks running 24/7 if they're not being accessed.

 

Has anyone else had this same problem? What setting worked for you?

  • 1. Re: Apple TV can't load iTunes library that has gone to sleep
    Alley_Cat Level 6 Level 6 (17,035 points)

    I think you've tried most options - Macs should be able to wake on LAN but you say you've configured not to sleep.

     

    Some external drives take a while to wake when they sleep to power save and OS settings may not affect that.  I've not personally had problems with this with externals on a Mini (WD Elements drives usually), but have seen some posts of this nature before.

     

    If the process times out have you tried again - this may allow enough time for all components to be active.

     

    AC

  • 2. Re: Apple TV can't load iTunes library that has gone to sleep
    Tom Roehl Level 1 Level 1 (0 points)

    I initially thought it might have been the drive being slow to spin up but it continues to fail to connect even after I try repeatedly to connect.

  • 3. Re: Apple TV can't load iTunes library that has gone to sleep
    will13b Level 1 Level 1 (0 points)

    i've had the same issue happen to me... from both my apple TV's. both 720p and 1080p versions having similar issues as u describe. never had this issue before. just started happening recently. if i wake my comp and close and reopen itunes, everything goes back to norm and i can access my library. i hope there is a fix soon for this. just wanted to let u know that ur no the only one experiencing this problem...

  • 4. Re: Apple TV can't load iTunes library that has gone to sleep
    HACKINT0SH Level 5 Level 5 (5,755 points)

    I have my iMac set to wake on connections, but seems it's a random hit & miss feature when using the ATV.

  • 5. Re: Apple TV can't load iTunes library that has gone to sleep
    Tom Roehl Level 1 Level 1 (0 points)

    I was hoping that the latest Apple TV update would help but it seems like nothing has changed. The network is fine and even if the Mac is woken up fully it still won't load the library. Everything else works fine, even the iOS Remote App so it's not like it's a Bonjour thing. Restarting the Apple TV doesn't help nor does turning Home Sharing on the ATV off and on. The only thing that gets things working again is to restart iTunes.

  • 6. Re: Apple TV can't load iTunes library that has gone to sleep
    Joseph Benevides Level 1 Level 1 (0 points)

    I have experienced a similar problem ever since I installed most recent OS Lion Update in combination with the Apple TV Update. I am unable to connect to my iTunes Library at all. I have full network access to the Internet, the apple Store, Netflix etc. Airplay is on, Home sharing is on, but I can't log into my Mac via any of the Bootable drives running Lion.

     

    Fortunately, I kept "Snow Leopard" on the Internal Hard Drive. I still run a few versions of programs with PowerPC code using Rosetta Stone. When I boot via this OS version, Airplay and Home Sharing work approriately. However, when watching Movies on my media hard drive streamed via iTunes, the Home sharing connection typically drops after an hour or so of viewing. My guess is that this too is a software bug that Apple needs to put a bit of energy into fixing.

     

    Joe Benevides

    New Jersey

  • 7. Re: Apple TV can't load iTunes library that has gone to sleep
    HACKINT0SH Level 5 Level 5 (5,755 points)

    The only thing that gets things working again is to restart iTunes.

    Unfortuantely, I have this on my windows machine. And have seen the same issue many times over on other systems running Windows as well.

  • 8. Re: Apple TV can't load iTunes library that has gone to sleep
    Lectoid1 Level 1 Level 1 (0 points)

    I'm having this problem as well. My Mac Mini only has the display turn off, it's set to never sleep the HD. Here is an interesting coincident. I run VNC server on this same Mac Mini, and I can't remote in to my Mac when the display is off. Both of these issues started at the same time about a week ago.

     

    Also look at the bug report here. I'm thinking with this last Lion update, it did something affecting network connections when the mac is sleeping, or even the display is off.

  • 9. Re: Apple TV can't load iTunes library that has gone to sleep
    jowik Level 1 Level 1 (0 points)

    I have the same problem.  I have to restart iTunes in order for the connection to resume.  I noticed the same thing also with the VNC connection, if my display is asleep, I can no longer connect to the machine.  Quite annoying actually, and this problem only started after I updated my Mac OSX to 10.7.4.

  • 10. Re: Apple TV can't load iTunes library that has gone to sleep
    Mardan Level 1 Level 1 (0 points)

    I am also having this problem with both of my ATV, second and third generation, just started recently.  Its a real pain - go to mac and turn off itunes and restart.  I am pretty it only happens when my mac falls asleep.  I will monitor it more closely and keep an eye on this thread

  • 11. Re: Apple TV can't load iTunes library that has gone to sleep
    Jon007 Level 1 Level 1 (0 points)

    I too am having this issue, it seemed to start after the previous software update (not the recent one, the one before that a few months ago).  My Mac is set to never sleep, and iTunes stays open permanently.  I can fix the issue by quitting and relaunching iTunes.

  • 12. Re: Apple TV can't load iTunes library that has gone to sleep
    Mardan Level 1 Level 1 (0 points)

    I would like to add that I am not sure what causes this, I thought it was when my mac goes to sleep but that is not the case.  As Jon007 said, the only way to fix the issue is to quit and relaunch iTunes.

  • 13. Re: Apple TV can't load iTunes library that has gone to sleep
    tghodge Level 1 Level 1 (10 points)

    I am pretty sure this issue is with the new iTunes upgrade (10.6.3).  My reasoning is that I am losing connections with not only ATV 2 and ATV3, but also my (3) 1st generation ones.  They are experncing the same issues (cant fine library) and there hasnt been a software update for them in over a year or more?  My 5 atv system has been bullet proof for a few years now and now all of a sudden I have to restart iTunes multiple times per day...has to be a iTunes issue...

  • 14. Re: Apple TV can't load iTunes library that has gone to sleep
    asdln Level 1 Level 1 (0 points)

    I too have been plagued by this problem and tried a number of fixes.  Running Mac mini with Lion, Ethernet connection to airport extreme, 3rd gen ATV also hard wired to base station, and 2nd gen ATV wireless in bedroom.  Itunes library is on external drive plugged in usb to the mini. 

     

    My latest troubleshoot was to install iTunes 10.6.1 and alas, no solution to the problem.  Can anyone pinpoint the version of iTunes that actually worked?   I have never actually had this configuration work properly as I just bought the Mac mini recently for the sole purpose of functioning as an iTunes server.  It is headless and the only way to access is via screen share.  Once accessed, it functions as it should.  Wake on LAN, Caffeine, even tried to set an iTunes alarm program to play once an hour to keep the thing ready for action.  No dice on any of those. 

     

    I do wonder if there's a configuration on the base station that would solve the issue.  Tweaking network settings is beyond my expertise though.  

1 2 3 Previous Next