3 Replies Latest reply: Nov 16, 2013 4:14 AM by MatthewWriter
clgatorfan Level 1 Level 1 (0 points)

I am trying to access my exchange server for work. The autodiscover sets the exchange server to the wrong site (whether this is a Mail issue or a server issue, I'm not sure...); I am trying to disable autodiscover so that I can manually set the exchange server in a permanent way. Is this possible?

 

When I contacted IT at work, this was their response:

 

"Mac users are pointed to a different server address due to incompatibilities with the Mac applications that handle mail (Entourage, Macmail). The issue is that an auto-discover feature within the application causes the software to connect to the incorrect address automatically, therefore you must change it each time. Unfortunately Macmail and Entourage cannot disable this function and we recommend using Outlook 2011 for Mac. There is a script file available to disable autodiscovery in Outlook 2011 and it will retain the proper mail server settings."

 

I prefer not to use Outlook...Thanks for any help!


MacBook Pro, Mac OS X (10.6.8), Mail 4.5
  • Adam Wenocur Level 2 Level 2 (285 points)

    I'm also frustrated looking for a solution to this probem.  Is there a flag that can be set in defaults, or should this be posted in a bug report?

  • G-Tech1 Level 1 Level 1 (0 points)

    I have the same problem (autodiscover information provided by the exchange server is incorrect and prevents Mail from connecting properly), and I already tried several things in Mail's accounts.plist file to avoid any "automatic" changes in server configuration - without success.

     

    However, there's one solution which is certainly not a very "clean" one but finally worked for me: Try setting your E-Mail adress' domain to something different from the right one. E.g. when your email is "first.last@company.com", try "first.last@company1.com". This will cause Mail to search autodiscovery settings at "https://autodiscover.company1.com". Mail will thus not be able to access the wrong autodiscovery settings any more and keep the server configuration you manually set. And don't worry: the e-mail adress in Mail's settings is only used for autodiscovery! When you send an email, the exchange server will use the correct sender adress (first.last@company.com) so that your recepients won't see the "fake" adresse you configured in Mail.

     

    The only drawback I faced is that all messages I have sent stay in server's Drafts Mailbox, although they have been successfully sent (don't know why). I thus configured Mail to keep drafts locally. However, sometimes sent messages occur in server's draft mailbox in spite of that, so that I have to delete them from time to time.

     

    On the other hand, Apple really should spend more efforts in making the Exchange connection working properly.

     

    Hope that helps.

  • MatthewWriter Level 1 Level 1 (0 points)

    The solution I use is to disable SSL. The problem with this, (apart from passwords being sent unencrypted), is that Mail refuses to keep the setting 'un-set' unless you also opt to use a manual port. For me, using the standard port 25 works and the pesky messages are vanquished.

     

    This is not ideal, (in case some at Apple reads this). My mail servers are using valid SSL certificates, and I don't care that Mail can't verify this, and I should be able to tell Mail to stop pestering me every time it connects to the server to check for email.