13 Replies Latest reply: May 27, 2012 12:02 AM by Matthias46
anyhelp Level 1 Level 1

Upgraded to 5.1.1 on my 4S and iPad 2 and now find my mail connection to my hosted exchange account takes about 5 minutes to check mail or fails to check at all. Just keeps "checking for mail". Yes I have killed the app, rebooted the devices and synced. Exhibiting same behaviour on both devices. Hosted exchange account with Godaddy.

  • Rojmer Level 4 Level 4

    I have upgraded my iPhone 4S, my husband's iPhone 4, my iPad 2 and my husband's iPad 3 to 5.1.1 and so far the mail app in all of them is working as usual.

     

    Perhaps you should check that all the mail settings are as they should be, or it could be a problem with Godaddy.  Deleting the account and setting it up again could possibly correct the issue.

  • HarmzwItser Level 1 Level 1

    I'm having this same problem on my 4S after upgrading to 5.1.1.

    I did not upgrade my iPod, no problems there. Same settings for the mail accounts.

  • bbfc Level 3 Level 3

    Working perfectly here on my GSM iPhone 4.

  • anyhelp Level 1 Level 1

    Removed the exchange account on 4S and added it again but same problem. Very slow to check mail, display new emails. I did not upgrade my iPod and it works fine.

  • Speedsync Level 1 Level 1

    Ihave the same issues with the added annoyance that it says

    my address or password is wrong, over and over even though they are both right and so are all my settings. Didn't t upgrade my iPad and it is still fine. THIS IS A MAJOR DRAG!!

  • Cowie12 Level 1 Level 1

    I am also having this problem with my exchange. I can't sync mail, contacts, or calendar. I've deleted the account, re-installed it, reset network settings, done a full shut down of iPhone (home key and off button) and nothing works!! My gmail is syncing everything fine though. I'd love some advice--can't find any info about how to resolve this!

  • Rojmer Level 4 Level 4

    See if you can find help here

     

    http://support.apple.com/kb/TS3398

  • Cowie12 Level 1 Level 1

    thanks for the suggestion but that doesn't seem to be the solution either. I do not have the profile on my phone...

  • Sully215 Level 1 Level 1

    I have the same error message on my Iphone4. Been like this since the installation of the update two days ago. Very peeved at this point that Apple has not addressed this. It tells me my Comcast username and password is incorrect. The settings are the same exact way as before the update. I've deleted the account, synced the phone, re-did the account and still, same error messages.

     

    Email works fine via Comcast.net site, however, no luck on the Iphone. I now know why people call it "crapple".

  • Sully215 Level 1 Level 1

    fixed it, did everything all over again, ensured the password was correct and blam! donzo. got it.

  • littlestacorn Level 1 Level 1

    Same problem, have tried resetting, nothing works, it's got to be 5.1.1. Apple really blew it on this one.

  • Bartelomeus Level 1 Level 1

    Had the same problem on my iPhone en iPad after the update. I solved the problem on both devices the same way:

    1. Quit Mail on iOS

    2. Retype passwords in system preferences

    3. Done

     

    Hope this work for you.

     

    Greetings from iPad,

    Bart

  • Matthias46 Level 1 Level 1

    Shame on me...i upgraded today my iPad 3 and 4S to 5.1.1 and like you my Gmail Box configured as Exchange for Push, is completely broken :|

     

    I can't read my calendars, can't update my contact list and also my email are not downloaded.

     

    This is completely ridicuolous because i also tried to remove the account and restore the devices...nothing worked