Previous 1 2 3 Next 32 Replies Latest reply: Sep 17, 2012 2:56 PM by daddyrod
usbp456 Level 1 Level 1 (0 points)

Ever since updating my iPhone 4s to the new 5.1.1 my home WiFi won't work on my iPhone. 

 

I go to the Airport Utility App and it says that the Internet is not connected but a Windows laptop and Android phone can connect to the network but NOT my iPhone.

 

I have a new 2TB Time Capsule that I purchased about 2 weeks ago.  So when I tried to go online on my phone and it uses the 3G network NOT WiFi, so I thought maybe it was my actual internet so I called Cox Communications (Internet Provider) they reset my modem and then had me reset my TC and still nothing.  The COX representative stated that everything looked good on her end.  So now that everything except my iPhone is able to connect to the WiFi and Cox saying everything is good, I have come to the conclusion that the problem  is my iPhone and the new update to 5.1.1.

 

After hanging up with with Cox I did "Forget the network" in my phone, restarted by phone and still nothing.  I click on my network and it just sits and spins and spins and nothing. 

 

 

 



iPhone 4S, iOS 5.1
  • darrenfrombayswater north Level 1 Level 1 (0 points)

    I have a similar issue that has arisen today.

     

    Both my iPhone 4S and iPad 2 (now running 5.1.1) wont use the wifi data. In Settings>Wifi is says that its connected to the wifi (on both devices) but there is no wifi icon on the home screen and it is browsing at 3G connection speed on both devices.

     

    I just set the iPhone up on 1 wifi and the iPad on a 2nd wifi and its same issue.  This is a bug with 5.1.1 and not my 2 wifi's that have been running fine.

     

    Other Android devices and Windows devises seem to have no issues at all.

  • Ocean20 Level 6 Level 6 (13,525 points)

    interesting.  I upgraded my 3GS and ipad 2 to 5.1.1 and everything worked fine for me.  I wonder what th eissue is. I will watch this thread as I am puzzled

  • darrenfrombayswater north Level 1 Level 1 (0 points)

    I am on the phone with Apple support and they are just as lost as me!

     

    Its intermiten, it's connects for a minute or 2 and then dropps off

  • Craig1981 Level 1 Level 1 (0 points)

    i have update my iphone 4S today and the Wifi is picking up the network

    the network bars show on my homescreen

    but the wire is not working

    i have tried "forget this network" restarting the phone and selecting the network again

    with no luck

    i have noticed something very strange  my 3G is turned off my every time i restart the phone

    my 3g automatically turns it self on like its set to default

    will try a restore later is any one else having the same issues

  • Craig1981 Level 1 Level 1 (0 points)

    i have just "RESET NETWORK SETTINGS"

    And this seems to have worked

    hope this helps others

  • AutoLink Level 1 Level 1 (0 points)

    "RESET NETWORK SETTINGS" didn't work for me. I still don't have a solution. Has anyone tried a restore yet?

  • sanjayfromcoimbatore Level 2 Level 2 (300 points)

    change the DNS number in your phone wifi settings to 8.8.8.8 . it may work.

  • perziken Level 1 Level 1 (35 points)

    I would reccomend reset network settings as the previous poster advised (settings > general > reset)

     

    I would also reccomend power cycling your router before trying to reconnect to the network (unplug from power source for 10 seconds)

     

    If this does not work, try connecting to another wifi network (like a public network or at a friend's house)

     

    If it connects to another network, then your router settings may need to be adjusted.

  • eeemitch Level 1 Level 1 (0 points)

    Im Having The Same Problem With My IPhone 4. I Wasnt aving Any Problems With My Wifi Before IOS5.1.1 But When I Updated If Im Not In The Same Room As My Router My Iphone Fails To Pick It Up . My Router Is In My Living Room If I Walk 10 Feet To My Room It Will Stop Working . I Cannot Find A Solution And If I Have To Wait Untill A New Update I Might Aswell Sell The Iphone

  • AutoLink Level 1 Level 1 (0 points)

    After updating my iPhone 4 to 5.1.1, both WiFi and 3G were essentially nonfunctional. I've had to restore my iPhone and set it up as a new phone (restoring from backup didn't work.) All appears to be well, but now I've got to organize all of my apps and adjust their settings. I'm being punished for doing the 5.1.1 update over WiFi. Don't let anyone tell you that iOS devices are completely independent of computers.

  • jlalk61 Level 1 Level 1 (0 points)

    Here is my fix. I spent a hour or so with applecare. I'll list the steps to see if this will work for you too.

    1.Turn off security for your wifi.make sure that the lock next to your wifi (what ever your network is named) on your iphone is not there.

    2.Reboot your router, do no do a reset, turn it off for at least one minute, then  turn it back on

    3.Again, check your phone to make sure the the little lock is not next to your wifi name on your phone.

    4.Reset all network connections on your phone.

    5.do a hard reset on phone,

    6.turn on wifi on phone, and open a app that uses wifi. Does it work???

    7.if it works, its fixed, be sure to go back to your router and turn all security back on.

    8.Don't forget when you get back on your phone, you will have to log back in to your network.

     

    Apple care walked me through this, and like I said, it worked for me. They where unable to tell my why phone would not connect to my home network, but would connect to any wifi outside my own. I think it had something to do with me updating the 5.1.1 over wifi on my phone, but its all good now.

  • MikeColo Level 1 Level 1 (0 points)

    I am having the same issue after upgrading to 5.1.1 with my iphone 4s, haven't tried ipad yet.

     

    I did something very similar (but not as long) and it worked for me.

    Turned off security for my wifi (little lock icon went away)

    Connected with my iphone

    Turned the security on my wifi again

    Connected on my iphone and typed passcode

    Seems to be working now.

  • KiwiSimon Level 1 Level 1 (0 points)

    Having the same problem as some others. Unfortunatly we have 6 wireless access points at work and asking the IT department to turn security off on them all whilst to connect my iPhone would result in me being chased from the building.

     

    Hopefully Apple Support will come out with a statement soon and an fix.

     

    UPDATE - Just did the network reset on the phone and I am connected again.

  • GiggLaneGuy Level 1 Level 1 (0 points)

    Also having wi fi problems with iphone4 since 5.1.1 update. Can connect to my home wi fi without any problem, but cannot use a lot of my apps with wi fi and have to resort to 3G to connect. Cannot connect with wi fi to the itunes store, Sky Go and a specific radio app will not pick up any stations. Apps that require content update, ie newspaper apps or news apps will not update via wi fi and have to be done via 3G. Pointless using SkyGo on 3G as it eats data and will cost a fortune. Battery life is also abysmal since the update. Definitely the update that is the problem as it is the same on my wifes iphone4 and is just the same problem on both phones using a neighbours wi fi ( with permission of course )

    Come on Apple, updates are supposed to be for our benefit, and not to turn the iphone into a useless brick, get a fix for this ASAP!!!!!!!!!!!!!!!!!!!!

     

    P.S. have tried all the suggestions on the different forums for a quick fix and nothing works!!!!

Previous 1 2 3 Next