Previous 1 2 Next 15 Replies Latest reply: Sep 25, 2012 7:47 AM by Mark Ryan1
ACable Level 1 (10 points)

After puchasing my iphone 4s last Sunday, the very first thing I noticed out of the box was that I needed to reconnect to my "home" wifi network constantly.  After browsing the infinite amount of discussions regarding this issue, I realized this is not an isolated issue with my hardware.  Monday, I attempted a connect to my "work" wifi network, and had absolutly no problems all day long.  I determined that the only difference between wifi networks relating to my iphone was the wireless security setting.  My home wifi was originally setup as WEP, my work wifi is currently setup as WPA2. 


Tuesday, I accessed my wifi router settings (Linksys wrt54g)> udpated wireless security settings from WEP to WPA2.  Problem solved.


Since I was not able to track down any easy solutions to this problem within all of the ongoing discussions, I wanted to share this info.  Hopefully this information helps anyone with this nuisance.

iPhone 4S, iOS 5.1
  • Adrian Campbell Level 1 (0 points)

    I am having the same problem when not connected to a WIFI network, i.e. using 3G.  Is anyone else having the same issue and if so have you been able to get a resolution?  Apple changed the phone 3 times then suggested it was the simcard, so i changed this and still the issue persists.  REALLY THINKING ABOUT GOING TO A WINDOWS PHONE!!!!!!!!!!!!!!!!!!!!!!!!!!

  • Defiled Level 2 (385 points)

    Apples support article Even states that its reccomended for WPA2 Wireless security setting.


    Which makes sense, and is a good thing for 2 reasons


    1. WEP is a older type of security its not as secure as WPA2, WEP can be cracked as low as 5 minutes.


    2. WPA2 Is more compatible with mobile devices.


    So keeps your information more secure, and your  net work is more compatible, whats wrong with that?

  • ccushway Level 1 (0 points)

    I am having the same problem since updating my phone ( iPhone 4s ). Everything was fine before the update and now as soon as the phone sleeps it drops the network. I have tried restoring the phone, forgeting the network and re-adding it. Nothing works. It just will not stay connected now. I connect to serveral different wifi networks and the resaults are the same so it is not tied to my home router but all kinds of wifi hardware.


    Maybe I should roll back the OS... I have not tried that yet

  • streptile Level 1 (0 points)

    Sorry to ask such a dumb question, but you said you "accessed my wifi router settings (Linksys wrt54g)> udpated wireless security settings from WEP to WPA2."


    How do you do this? On your computer? On the router? Through your internet company on the phone?


    Thanks for any help for someone who's not tech savvy. I don't even know what router I have, or which is the router and which is the modem (there are two boxes).


    I am on a new-ish iMac.

  • ACable Level 1 (10 points)

    I updated this on my computer.  You can either be connected to your router via an Ethernet cable, or connected wirelessly to do this.



    Here is a google search for setting up wireless security on a Linksys wireless router.


    Really all I did was type the IP address > enter PW "admin"  > click Wireless  > click Wireless Security  >  select WPA2  > click save settings.  Done


    If you using WIFI to connect to your router, your computer will immediately disconnect after clicking SAVE.  Just search for your network and enter your password, and your done.


    Hope this helps.  I worked for me and I have not had any issues connecting my Macbook, iPhone, iPad....

  • streptile Level 1 (0 points)

    Many thanks for your reply.


    Yes, it worked!


    I really appreciate that you took the time to help me.

  • sujinfrommukilteo Level 1 (0 points)

    Ok, never had a problem with the wifi...until today.


    I had set up a new wireless network for my dad.  Signal to the iphone 4 was weak (whereas my dads pc was strong)  So I chalked it up to being my iphone.  Read that I needed to reset the network settings.  So which I did.  Signal was still weak so I figured it was just the router.  Fast forward to my place.  I come home and re-connect to my home wireless settings.  It wouldn't.  It kept telling me that it was unable to connect to the network....even though I am sitting in front of the router.  So I tried power cycling the router, the modem, the iphone.  Still didn't help.  So I tried "forgetting this network".....8 times.  Still didn't work.  So I tried power cycling the other things couple of more times.  Still didn't work.  I went into the router (and even though the settings hadn't changed since my last usage) and reconfigured everything.  Dropped the speed (Netgear N300) from 300 to 54....didn't work.  Tried dropping the security keys......didn't work.  Switch from auto channel to a specific one.....didn't work.


    So I am at a loss for words (although my paragraph is a bit run-on sentence-y)


  • Ocean20 Level 6 (13,570 points)

    Doesn't surprise me. When I upgraded from Windows Vista to Win7 I had to change security on my router from WEP to WPA2 as Win7 did not support Wep

  • streptile Level 1 (0 points)

    Hi Sujin,


    I am no tech wizard, but I followed the instructions to change my wireless security settings (not "reset network settings") to WPA2.


    I can't quite tell from your post if you've tried this solution. If not, I would try this as the very next thing, since it did fix my identical problem, and seems to have helped others as well.

  • sujinfrommukilteo Level 1 (0 points)

    Hey Strep,



    thanks for the suggestion but I have already done no avail. Got a genius bar appt tomorrow but I am dreading the "it operates within normal parameters" speech.

  • Mark Ryan1 Level 1 (15 points)

    Hi all, I had the same issue with my new out of the box iPhone 4s. What was really p'ing me off was that I still had my 3s and that worked fine.


    So after reading loads I changed the channel from auto to a fixed number, in my case 10. My router is a netgear / virigan media super Hub.


    I did this at 9am today and it's now 3pm and its all still working as it should.


    I'll let you know if anything changes..


    Good luck

  • benny-j Level 1 (0 points)

    Just advising also, the same applies with WAP (aka WAP-1)... the iOS6 update no longer will connect to a WAP WiFi - you must also change your router security to WAP2.  I had been using WAP because my TiVo would previously not connect with WAP2, but (thankfully) TiVo have updated their software so it also works with WAP2.

  • StavrosKats Level 1 (0 points)

    I have the same problem. Recently I have changed my wireless security setting from Wep to Wap2 because I found an intruter to my network from the neiboughot. Since the change my iPhone 4s does not connect. the iPad itnis ok and reconnects! Any advice please? The iPhone is 4S and running Version 5.1.1 please help!!! Thanks

Previous 1 2 Next