Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: NVIDIA GeForce GT 130 Kernel Panics/Freezes in Lion & late Snow Leopard

I've found some other reports of these freezes scattered about the forums, but usually other people come in and post something about unrelated video cards. So this thread is specific to NVIDIA GeForce GT 130 running OS X Lion (10.7-10.7.3), to avoid confusion and cross-polination of different issues.


Hardware Overview:


Model Name: iMac

Model Identifier: iMac9,1

Processor Name: Intel Core 2 Duo

Processor Speed: 3.06 GHz

Number of Processors: 1

Total Number of Cores: 2

L2 Cache: 6 MB

Memory: 8 GB

Bus Speed: 1.07 GHz

Boot ROM Version: IM91.008D.B08

SMC Version (system): 1.37f3


NVIDIA GeForce GT 130:


Chipset Model: NVIDIA GeForce GT 130

Type: GPU

Bus: PCIe

PCIe Lane Width: x16

VRAM (Total): 512 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x062e

Revision ID: 0x00a1

ROM Revision: 3370



Since upgrading to Lion I have had many issues with crashes and kernel panics characterized by the following symptoms, listed here in detail so that people can find them when they search:


  • Pixellation - colored pixels appear in different areas of the screen, in seemingly random bunches.
  • Mosaics - squares appear redrawn in the wrong part of the screen. Sometimes these squares are large, other times tiny.
  • Recovery - sometimes the system recovers once it starts doing these. Other times it just keeps going until it freezes/panics.
  • Kernel Panics - I've only had the "grey screen" appear once or twice. Usually there is a complete system lockup before this can happen, and I have to reboot the system manually.


Some solutions/attempts to solve:


  • Turn off Energy Saving - This is horrible for the monitor and can lead to burn-in, but I found that many of my crashes occured when the system was trying to recover from "screen sleep". So now I run a screen saver instead, which doesn't seem to trigger it as much.
  • Screen Saver - Sometimes I can "refresh" the system by turning on the screen saver and then coming back. Other times, this doesn't work and the pixellation/mosaic remains. Sometimes I can't even initialize the screen saver at all (in which case a total freeze usually occurs right after).
  • Rebooting - seems to clear things up for a while, but inevitably, the problem resurfaces.
  • Running Windows - Not really a solution, but I have had absolutely no issues with this behavior while running Windows 7 on this same machine (under Bootcamp).
  • Downgrading to Snow Leopard - I have not attempted this, but I've read others say that their crashes went away when they did. I would like some more concrete evidence on this if anyone has it.


My diagnosis so far:


OS X Lion's NVIDIA driver kernel extensions (kexts) seem to be faulty with this GPU. The Windows drivers for this GPU work better on Apple's own hardware than OS X Lion's. Anectodal evidence indicates that Snow Leopard's drivers (at least up to 10.6.3 – more confirmation needed) do not display this issue. I can confirm that this never occurred in Snow Leopard until Lion was released and I upgraded to it.


My request for help and information:


  • If you are running this GPU (GeForce GT 130) and OS X Lion, please contribute to this thread offering any solutions you may have or, at the very least, listing your hardware and GPU profile.
  • If you can, post crash logs so that we can compare common issues (NVDA Resman seems to be a huge recurring kext in the crash logs, for instance).
  • Post screen shots or pictures taken of the pixellation (colored pixels) and mosaic (squares drawn in the wrong place) phenomenon, so we can build a body of evidence regarding this issue. I will continue to update this thread with the same.


I feel Apple has ignored these issues for far too long, and required too many people to simply purchase new computers and new GPUs. If we can build a solid body of evidence regarding this specific issue, it will be a thread that Apple Support can be referred to.

iMac, Mac OS X (10.7.3), 3.06 Ghz (Early 2009 – iMac9,1)

Posted on

Reply
Question marked as Helpful

Jun 13, 2013 11:54 PM in response to David Portela In response to David Portela

Well, I'm back with a report on what happened. After a few news sites linked to this thread, I was contacted by email by an Apple representative, who offered to help. First he requested I run a system diagnostic following specific instructions, the results of which were sent to him. After a couple of days he wrote back and said he would like to offer to fix the issue. Since I'm in Brazil, we coordinated through someone in Apple Brazil to find the nearest authorized service provider.


When I took the machine in, the ASP was puzzled at first (it's out of warranty? And Apple's going to fix it?) but upon checking their system they saw that there was already a work order there with the iMac's serial number, so they took it in. A week and a half later they let me know it was ready to pick up. When I did so, I made sure to ask what had been done, so that I might have a clue what the problem was. The lady said that the video card and screen had both been replaced. This seems to be the case as the screen seemed brighter when I turned it on, later.


I have since passed on the iMac to another member of our team who also does graphically intensive work, and have been checking in with him regularly. He has reported no crashes since the fix. The first thing I did when I got the machine back was to zero the hard drive and put a fresh install of Mountain Lion on it, before prepping it with the software my teammate would use. It didn't crash or pixelate at all during any of those steps. If the issue happens again, I will definitely be reporting back.


I would like to thank Apple for fixing this issue on our iMac. I do feel this is a recurring hardware issue in these iMac models and that the other cases that have been reported here should be scrutinized by Apple to see if their issues stem from the same cause. These are expensive machines (especially outside of the US) and it can be tremendously discouraging to find out your $5000 computer has become little more than an oversized paperweight...so I can definitely understand the frustration some people have expressed. I would urge those who have this iMac model and are experiencing this issue to contact Apple and point them at this thread and this post, specifically. Hopefully they will deal with your broken iMac with the same grace, responsibility and integrity that they displayed in my case. Best of luck to all.

There’s more to the conversation

Read all replies

Page content loaded

May 9, 2012 8:37 AM in response to David Portela In response to David Portela

Changed title to increase range to later Snow Leopard updates, which also seem to have updated the NVIDIA kexts and thus, to cause this issue.

May 9, 2012 8:37 AM

Reply Helpful

May 9, 2012 4:58 PM in response to David Portela In response to David Portela

I have the exact same iMac9,1, only with 4gb less memory than you do, and the exact same problems. I've been trying to identify the issue but no discussion seemed to match the specific symptoms I'm seeing, until I saw your thread.


I started getting the lockup when I had the pre-Lion up-to-date release of Snow Leopard, I thought it was an issue with Silverlight/Flash as it only seemed to happen when I was watching video. I installed Lion in hopes of remedying the problem, but it has made no difference. When I start seeing the mosaic/artifacts on my screen I know that a lockup is coming and I usually restart before I have to hard restart. I don't get a kernal panic screen I don't get anything, one moment the mouse is moving on the screen, the next it's not. On occasion if I am watching video, the sound will continue to play for a short time but everything else is locked down my only recourse being a hard reset. My uptime is terrible.


I also have Windows 7 dual booted, and also have no issues when in the Windows environment.


I just started turning off my computer whenever not in use because I was tired of it freezing up when coming out of a sleep screen.


Prior to Lion's release I ran the hardware test (I believe the option was removed with Lion) and everything showed up as okay. I've verified disk and permissions, and nothing indicates a problem. I have pretty much done everything you've tried and still have the problem. I'd love to see some feedback on our problem as it is very, very aggravating and I'm not yet in a position to upgrade computers. Is this at least a problem that will be addressed by Mountain Lion?

May 9, 2012 4:58 PM

Reply Helpful

May 9, 2012 11:52 PM in response to David Portela In response to David Portela

Crashed again, this time while running screen saver. Here's the log:


Interval Since Last Panic Report: 258975 sec

Panics Since Last Report: 1

Anonymous UUID: 8A9BDB66-541D-4132-8BDD-D171D358B321



Thu May 10 03:48:23 2012

panic(cpu 1 caller 0xffffff7f8092a907): NVRM[0/2:0:0]: Read Error 0x0061002c: CFG 0x00000000 0x00000000 0x00000000, BAR0 0xd2000000 0xffffff80f3175000 0x094700a1, D0, P3/4

Backtrace (CPU 1), Frame : Return Address

0xffffff80f179bc80 : 0xffffff8000220702

0xffffff80f179bd00 : 0xffffff7f8092a907

0xffffff80f179bd90 : 0xffffff7f80a1aa64

0xffffff80f179bde0 : 0xffffff7f80c1e4dc

0xffffff80f179be00 : 0xffffff7f809e3673

0xffffff80f179be20 : 0xffffff7f80a8ba0a

0xffffff80f179be90 : 0xffffff7f809177d6

0xffffff80f179bf40 : 0xffffff7f808d143e

0xffffff80f179bf70 : 0xffffff800023db2c

0xffffff80f179bfb0 : 0xffffff8000820057

Kernel Extensions in backtrace:

com.apple.NVDAResman(7.1.8)[94BA87BA-B128-3310-9860-98EC67AB7FAF]@0xffffff7f808 ca000->0xffffff7f80ba3fff

dependency: com.apple.iokit.IOPCIFamily(2.6.8)[F63D4ABE-42DA-33EF-BADD-3415B0CB0179]@0xffff ff7f80846000

dependency: com.apple.iokit.IONDRVSupport(2.3.2)[4B3F84DC-18B3-3897-BC56-4E3940878047]@0xff ffff7f808b8000

dependency: com.apple.iokit.IOGraphicsFamily(2.3.2)[FE536983-1897-3D6B-965E-24B5A67080DA]@0 xffffff7f80880000

com.apple.nvidia.nv50hal(7.1.8)[7596DB8C-AE9D-3C87-B11A-0ED8F940CAF8]@0xffffff7 f80ba4000->0xffffff7f80ec5fff

dependency: com.apple.NVDAResman(7.1.8)[94BA87BA-B128-3310-9860-98EC67AB7FAF]@0xffffff7f808 ca000



BSD process name corresponding to current thread: kernel_task



Mac OS version:

11D50b



Kernel version:

Darwin Kernel Version 11.3.0: Thu Jan 12 18:47:41 PST 2012; root:xnu-1699.24.23~1/RELEASE_X86_64

Kernel UUID: 7B6546C7-70E8-3ED8-A6C3-C927E4D3D0D6

System model name: iMac9,1 (Mac-F2218FC8)



System uptime in nanoseconds: 137075074753775

last loaded kext at 39719236478: com.apple.driver.AppleHWSensor 1.9.4d0 (addr 0xffffff7f81e72000, size 28672)

loaded kexts:

com.rogueamoeba.HermesAudio 3.0.2

com.orderedbytes.driver.ControllerMateFamily 4.4.3

com.attotech.driver.ATTOiSCSI 3.4.1b1

com.orderedbytes.driver.CMUSBDevices 4.4.3

com.TrustedData.driver.VendorSpecificType00 1.5.0

at.obdev.nke.LittleSnitch 2.4.0

com.apple.driver.AppleHWSensor 1.9.4d0

com.apple.filesystems.autofs 3.0

com.apple.filesystems.ntfs 3.10

com.apple.driver.AppleMikeyHIDDriver 122

com.apple.driver.AppleUpstreamUserClient 3.5.9

com.apple.driver.AppleMCCSControl 1.0.26

com.apple.driver.AppleTyMCEDriver 1.0.2d2

com.apple.driver.AppleHDA 2.1.7f9

com.apple.driver.AppleMikeyDriver 2.1.7f9

com.apple.driver.AudioAUUC 1.59

com.apple.driver.AGPM 100.12.42

com.apple.GeForce 7.1.8

com.apple.iokit.IOUserEthernet 1.0.0d1

com.apple.Dont_Steal_Mac_OS_X 7.0.0

com.apple.driver.AudioIPCDriver 1.2.2

com.apple.driver.ACPI_SMC_PlatformPlugin 4.7.5d4

com.apple.driver.AppleMuxControl 3.0.16

com.apple.driver.AppleBacklight 170.1.9

com.apple.driver.AppleLPC 1.5.3

com.apple.driver.AppleIRController 312

com.apple.driver.AppleFireWireStorage 3.0.1

com.apple.driver.initioFWBridge 3.0.1

com.apple.driver.IOFireWireSerialBusProtocolSansPhysicalUnit 3.0.1

com.apple.driver.LSI_FW_500 3.0.1

com.apple.driver.Oxford_Semi 3.0.1

com.apple.driver.StorageLynx 3.0.1

com.apple.iokit.SCSITaskUserClient 3.0.3

com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1

com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1

com.apple.BootCache 33

com.apple.iokit.IOAHCIBlockStorage 2.0.1

com.apple.driver.AppleAHCIPort 2.2.0

com.apple.driver.AppleFWOHCI 4.8.9

com.apple.driver.AirPort.Brcm4331 513.20.19

com.apple.driver.AppleRTC 1.4

com.apple.driver.AppleEFINVRAM 1.5.0

com.apple.driver.AppleUSBHub 4.5.0

com.apple.nvenet 2.0.17

com.apple.driver.AppleUSBEHCI 4.5.8

com.apple.driver.AppleUSBOHCI 4.4.5

com.apple.driver.AppleHPET 1.6

com.apple.driver.AppleACPIButtons 1.4

com.apple.driver.AppleSMBIOS 1.7

com.apple.driver.AppleACPIEC 1.4

com.apple.driver.AppleAPIC 1.5

com.apple.driver.AppleIntelCPUPowerManagementClient 167.3.0

com.apple.nke.applicationfirewall 3.2.30

com.apple.security.quarantine 1.1

com.apple.driver.AppleIntelCPUPowerManagement 167.3.0

com.apple.kext.triggers 1.0

com.apple.driver.AppleHDAHardwareConfigDriver 2.1.7f9

com.apple.driver.DspFuncLib 2.1.7f9

com.apple.driver.AppleSMBusController 1.0.10d0

com.apple.nvidia.nv50hal 7.1.8

com.apple.NVDAResman 7.1.8

com.apple.iokit.IOFireWireIP 2.2.4

com.apple.driver.AppleUSBAudio 2.8.2f5

com.apple.iokit.IOSurface 80.0

com.apple.iokit.IOBluetoothSerialManager 4.0.3f12

com.apple.iokit.IOSerialFamily 10.0.5

com.apple.iokit.IOAVBFamily 1.0.0d22

com.apple.iokit.IOEthernetAVBController 1.0.0d5

com.apple.iokit.IOAudioFamily 1.8.6fc6

com.apple.kext.OSvKernDSPLib 1.3

com.apple.driver.ApplePolicyControl 3.0.16

com.apple.driver.IOPlatformPluginFamily 4.7.5d4

com.apple.driver.AppleHDAController 2.1.7f9

com.apple.iokit.IOHDAFamily 2.1.7f9

com.apple.driver.AppleSMC 3.1.1d8

com.apple.driver.AppleSMBusPCI 1.0.10d0

com.apple.driver.AppleGraphicsControl 3.0.16

com.apple.driver.AppleBacklightExpert 1.0.3

com.apple.iokit.IONDRVSupport 2.3.2

com.apple.iokit.IOGraphicsFamily 2.3.2

com.apple.driver.AppleFileSystemDriver 13

com.apple.driver.BroadcomUSBBluetoothHCIController 4.0.3f12

com.apple.driver.AppleUSBBluetoothHCIController 4.0.3f12

com.apple.iokit.IOBluetoothFamily 4.0.3f12

com.apple.iokit.IOUSBHIDDriver 4.4.5

com.apple.driver.AppleUSBMergeNub 4.5.3

com.apple.iokit.IOSCSIBlockCommandsDevice 3.0.3

com.apple.iokit.IOFireWireSerialBusProtocolTransport 2.1.0

com.apple.iokit.IOFireWireSBP2 4.2.0

com.apple.iokit.IOUSBMassStorageClass 3.0.1

com.apple.driver.AppleUSBComposite 4.5.8

com.apple.iokit.IOSCSIMultimediaCommandsDevice 3.0.3

com.apple.iokit.IOBDStorageFamily 1.6

com.apple.iokit.IODVDStorageFamily 1.7

com.apple.iokit.IOCDStorageFamily 1.7

com.apple.iokit.IOAHCISerialATAPI 2.0.1

com.apple.iokit.IOSCSIArchitectureModelFamily 3.0.3

com.apple.driver.XsanFilter 403

com.apple.iokit.IOAHCIFamily 2.0.7

com.apple.iokit.IOFireWireFamily 4.4.5

com.apple.iokit.IO80211Family 412.2

com.apple.iokit.IOUSBUserClient 4.5.8

com.apple.iokit.IONetworkingFamily 2.0

com.apple.iokit.IOUSBFamily 4.5.8

com.apple.driver.NVSMU 2.2.9

com.apple.driver.AppleEFIRuntime 1.5.0

com.apple.iokit.IOHIDFamily 1.7.1

com.apple.iokit.IOSMBusFamily 1.1

com.apple.security.sandbox 177.3

com.apple.kext.AppleMatch 1.0.0d1

com.apple.security.TMSafetyNet 7

com.apple.driver.DiskImages 331.3

com.apple.iokit.IOStorageFamily 1.7

com.apple.driver.AppleKeyStore 28.18

com.apple.driver.AppleACPIPlatform 1.4

com.apple.iokit.IOPCIFamily 2.6.8

com.apple.iokit.IOACPIFamily 1.4

May 9, 2012 11:52 PM

Reply Helpful

May 10, 2012 9:57 AM in response to David Portela In response to David Portela

After updating to 10.7.4, the issue still continues. In fact, here is a screen shot showing pixellation a few minutes after the 10.7.4 installation rebooted the machine (click the image to see the pixellation better):


User uploaded file


Am I wrong or does this make it clear that this is a software issue? If it was a hardware issue, the system would be telling it to display one thing, and the hardware would be displaying another. So a screenshot should (theoretically) show what the hardware was being told to display. In this case, the screenshot also shows the pixellation, meaning the hardware is simply displaying what it's being told to. The bug is in Apple's NVIDIA driver.


Message was edited by: David Portela - added instructions to click image.

May 10, 2012 9:57 AM

Reply Helpful

May 10, 2012 11:20 AM in response to David Portela In response to David Portela

Those are exactly the same artifacts I get. I downloaded the combo update of 10.7.4 and haven't had any problems as of this writing, but I also haven't used the computer much as I've been away. I left the computer on all night and will be working today so I should be getting something soon...

May 10, 2012 11:20 AM

Reply Helpful

May 10, 2012 4:25 PM in response to Quasimoto In response to Quasimoto

...and here we go. After being away from my computer for a bit I got this weird computer glitch which I screengrabbed while in mission control. While opening said picture of mission control in photoshop, after a restart I might add, I got an entirely new set of weird screen gobbeldygook, including the multicolored artifacts that you had pictured.


User uploaded file

May 10, 2012 4:25 PM

Reply Helpful

May 10, 2012 7:08 PM in response to David Portela In response to David Portela

More lovely behavior this evening. I clicked my Applications folder to start up an app...instead of the App menu listing all the apps, Lion presented me with this pearl instead (poor screenshot because I was using Screens on the iPad to connect when this happened):


User uploaded file


Notice how the menu is wrongly redrawn on either side of the actual menu. Now notice what is behind the menu...it is being redrawn sideways, and multiple times, superimposed over and over and over.


When I got to the iMac I could still move the mouse around. I took a screen shot and the screen shot sound triggered, but after a startup, no screen shot was found. However, before I restarted, I tried clicking around for a bit to see whether I could get the system to respond again. After about 20 seconds this is what I got:


http://youtu.be/x6nckVGlsxU


After that I restarted and got no "Your computer was shut down due to a problem..." dialog, so supposedly it still hadn't actually kernel panicked, but was locked up anyway.

May 10, 2012 7:08 PM

Reply Helpful

May 10, 2012 10:10 PM in response to David Portela In response to David Portela

I get exactly all these issues on 10.7 to 10.7.4 with my 3.06Ghz NVIDIA GT130 iMac setup. The tiny patches of purple and blue pixels, the stuck blocks, the purple blocks and even the flickering described in the video above.


Gah! Just waiting for the new iMacs and will send this one back to Apple for testing. I just can't do without my daily machine at this point to send it in, even after phone calls from Apple themselves.


Just wanted to add to the thread to reassure people it's not just them.

May 10, 2012 10:10 PM

Reply Helpful

May 11, 2012 9:16 AM in response to David Portela In response to David Portela

I'm "suffering" the same issue with my iMac9,1, but mine has NVIDIA GeForce GT 120. It is really frustrating...

Has someone tried to run lion in 32 bits mode and see if this issue happens also in that case? I've not tried yet, but perhaps it's worth a try...

May 11, 2012 9:16 AM

Reply Helpful

May 11, 2012 2:49 PM in response to David Portela In response to David Portela

Another crash tonight, while editing video (this happens often). First the video looked really weird, with bright pixels in surrounding the edges of the speaker as he moved. I tried a screen saver reset and it appeared to work, however as I continued editing, I noticed more strangeness...the last thumb in iMovie had three horizontal strips displayed across it, each of which was zoomed into a specific part of the actual video (you can see the zoom-in on the tie, in the middle). I hit Shift-Command-3 and the screen shout sound started, but the computer froze completely at that point (and no screen shot was saved – I checked after rebooting). So I took a photo with my iPhone instead:


User uploaded file


No prompt at startup. And pixellation began right again after opening iMovie, but has thankfully not crashed again yet. Hoping to make it through export without another crash...

May 11, 2012 2:49 PM

Reply Helpful

May 11, 2012 6:31 PM in response to Quasimoto In response to Quasimoto

This is the longest I've run without pixellation and/or artifacts in a long time. I'm still not willing to call this workaround a permanent solution though, until I've run a few more tests and had the machine on for a few days. However, here are some instructions on how to boot using the 32-bit kernel and how to set your boot disk to do that permanently: https://discussions.apple.com/message/15700043#15700043


Anke and Zahori, could you try this on your machines to see if it fixes (or reduces) the problems you're seeing?

May 11, 2012 6:31 PM

Reply Helpful
User profile for user: David Portela

Question: NVIDIA GeForce GT 130 Kernel Panics/Freezes in Lion & late Snow Leopard