10 Replies Latest reply: Nov 28, 2014 3:16 PM by deroo
deroo Level 1 (10 points)

Hello, hope someone can help.


I'm having trouble updating to v5.1.1 on my iPad 2. The update has downloaded but it fails to install, the error is 'unable to install update - an error occurred while installing iOS 5.5.1'


I've had this before, and changing the DNS server sorted it. This time around its a little mor complicated. I've looked through the usage and diagnostics logs and found lots to OTAUpdate entries. For now I'll keep the log brief and only paste the last 5 lines:



apticket_path=/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/amai/apti cket.der

00281000 : boot partition (required/actual): 24507290 / 52428800 

00281000 : failed to create boot partition for update

00281000 : failed to prepare boot environment for update OS

00281000 : API failed



Failing to create a boot partition, that's not good. Makes me wonder whether I'll always have issues with future updates. Can anyone help try and sort this issue without having to restore?



iPad 2, iOS 5.1
  • linuxubuntufan Level 2 (420 points)

    1. Well, you might have to restore. But, if you create an iTunes backup (or if you have all your stuff on your computer), you won't have to lose data. After restore, the update should be cleared/deleted, and you should be able to re-download it. But, update BEFORE replacing all your data, or else you will be back to where you started.


    2. You can try just syncing to your computer and updating it that way.


    3. If that doesn't work, wait for the next update. Download that update when you have a strong internet connection (preferably wi-fi), and update your iPad when it's at full charge.


    4. If 2 and 3 didn't work, go to Step 1.

  • deroo Level 1 (10 points)

    Thanks pal, you're right I'll probably just have to restore. The iPad regularly backs up to iCloud, so guess I'll just have to erase all settings then restore from the cloud. Thanks for your suggestions, I'll give it a go when I got some spare time.



  • deroo Level 1 (10 points)

    Haven't restored yet, but I thought I'd paste the full log in case anyone can see something here...




    3f4f9d98 : Cleaning up unused prepared updates

    3f4f9d98 : Suspended update at /var/MobileSoftwareUpdate/softwareupdate.113

    00281000 : Thread starting: 

    00281000 : Closest marketing capacity entry for padding was 16GB however this device is 1GB, this might not be optimal


    00281000 : Thread exiting

    3f4f9d98 : Cleaning up unused prepared updates

    3f4f9d98 : Suspended update at /var/MobileSoftwareUpdate/softwareupdate.113

    3f4f9d98 : Cleaning up unused prepared updates

    3f4f9d98 : Suspended update at /var/MobileSoftwareUpdate/softwareupdate.113

    2fffc000 : Thread starting: <CFBasicHash 0xfe59a90 [0x3fda6650]>{type = mutable dict, count = 1,

    entries =>

         2 : <CFString 0xfe59a50 [0x3fda6650]>{contents = "Command"} = <CFString 0xfe598d0 [0x3fda6650]>{contents = "ResumeUpdate"}



    2fffc000 : Update options: <CFBasicHash 0x15d140 [0x3fda6650]>{type = mutable dict, count = 2,

    entries =>

         9 : <CFString 0x15d280 [0x3fda6650]>{contents = "suspended-update-path"} = <CFString 0x15d430 [0x3fda6650]>{contents = "/var/MobileSoftwareUpdate/softwareupdate.113/"}

         12 : <CFString 0x15d1b0 [0x3fda6650]>{contents = "ignore-list"} = <CFArray 0x15d1d0 [0x3fda6650]>{type = mutable-small, count = 6, values = (

         0 : <CFString 0x15d1f0 [0x3fda6650]>{contents = "/restore.log"}

         1 : <CFString 0x15d230 [0x3fda6650]>{contents = "/System/Library/Caches/com.apple.kernelcaches/kernelcache"}

         2 : <CFString 0x15d210 [0x3fda6650]>{contents = "/private/etc/fstab"}

         3 : <CFString 0x15d2a0 [0x3fda6650]>{contents = "/usr/standalone/firmware/"}

         4 : <CFString 0x15d2d0 [0x3fda6650]>{contents = "/.fseventsd"}

         5 : <CFString 0x15d2f0 [0x3fda6650]>{contents = "/private/var/logs/Baseband"}




    2fffc000 : context initialized.

    2fffc000 : Checking the paths provided to the update tool

    2fffc000 : Package updates 9B176->9B206

    2fffc000 : Thread exiting

    2fffc000 : Thread starting: <CFBasicHash 0xfe59b80 [0x3fda6650]>{type = mutable dict, count = 2,

    entries =>

         1 : <CFString 0xfe59ab0 [0x3fda6650]>{contents = "SessionHandle"} = <CFNumber 0xfe59b30 [0x3fda6650]>{value = +269125120, type = kCFNumberSInt64Type}

         2 : <CFString 0xfe59af0 [0x3fda6650]>{contents = "Command"} = <CFString 0xfe59b40 [0x3fda6650]>{contents = "ApplyUpdate"}



    2fffc000 : Baseband activation disabled

    2fffc000 : ApNonce: <CFData 0xfe59f10 [0x3fda6650]>{length = 20, capacity = 20, bytes = 0x<<<<<<<<<<<<<<<<<<UDID>>>>>>>>>>>>>>>>>>}

    2fffc000 : BasebandNonce: <CFData 0xfe59960 [0x3fda6650]>{length = 20, capacity = 20, bytes = 0x<<<<<<<<<<<<<<<<<<UDID>>>>>>>>>>>>>>>>>>}

    2fffc000 : BasebandKeyHashInfo: (null)

    2fffc000 : User-authlisting enabled.

    2fffc000 : Signing server: https://gs.apple.com:443

    2fffc000 : entriesToPersonalize=<CFArray 0xfe5f890 [0x3fda6650]>{type = immutable, count = 7, values = (

         0 : <CFString 0x3e9c9770 [0x3fda6650]>{contents = "RestoreLogo"}

         1 : <CFString 0x3e9c9790 [0x3fda6650]>{contents = "RestoreDeviceTree"}

         2 : <CFString 0x3e9c9940 [0x3fda6650]>{contents = "RestoreKernelCache"}

         3 : <CFString 0x3e9c97b0 [0x3fda6650]>{contents = "RestoreRamDisk"}

         4 : <CFString 0x3e9c97c0 [0x3fda6650]>{contents = "iBEC"}

         5 : <CFString 0x3e9c97a0 [0x3fda6650]>{contents = "KernelCache"}

         6 : <CFString 0x3e9c9950 [0x3fda6650]>{contents = "BasebandFirmware"}


    2fffc000 : entriesToLink=<CFArray 0xfe5f870 [0x3fda6650]>{type = immutable, count = 0, values = ()}

    2fffc000 : auto-selecting variant "Customer Software Update".

    2fffc000 : variant=Customer Software Update

    2fffc000 : _AMAuthInstallBundleSetBasebandKeyHashes: setting (from build manifest): BbProvisioningManifestKeyHash = <CFData 0x164200 [0x3fda6650]>{length = 20, capacity = 20, bytes = 0x<<<<<<<<<<<<<<<<<<UDID>>>>>>>>>>>>>>>>>>}

    2fffc000 : _AMAuthInstallBundleCreateServerRequestDictionary: nothing to be done

    2fffc000 : Preparing update OS

    2fffc000 : boardConfig=k94ap

    2fffc000 : variant=Customer Software Update

    2fffc000 : Using spi path '/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/amai/apticket.der'

    2fffc000 : Using manifested path '/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/Firmware/all_flash/al l_flash.k94ap.production/applelogo.s5l8940x.img3'

    2fffc000 : Using manifested path '/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/Firmware/all_flash/al l_flash.k94ap.production/DeviceTree.k94ap.img3'

    2fffc000 : Using manifested path '/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/kernelcache.release.k 94'

    2fffc000 : Using manifested path '/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/038-4344-017.dmg'

    2fffc000 : Using manifested path '/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/Firmware/dfu/iBEC.k94 ap.RELEASE.dfu'

    2fffc000 : applelogo_path=/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/Firmwar e/all_flash/all_flash.k94ap.production/applelogo.s5l8940x.img3

    2fffc000 : devicetree_path=/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/Firmwa re/all_flash/all_flash.k94ap.production/DeviceTree.k94ap.img3

    2fffc000 : kernelcache_path=/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/kerne lcache.release.k94

    2fffc000 : ramdisk_path=/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/038-4344- 017.dmg

    2fffc000 : ibec_path=/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/Firmware/dfu /iBEC.k94ap.RELEASE.dfu

    2fffc000 : apticket_path=/var/MobileSoftwareUpdate/softwareupdate.113/target/boot/amai/apt icket.der

    2fffc000 : boot partition (required/actual): 24507290 / 52428800 

    2fffc000 : failed to create boot partition for update

    2fffc000 : failed to prepare boot environment for update OS

    2fffc000 : API failed

  • deroo Level 1 (10 points)

    Just wanted to update this thread. I've sorted the issue for now, I plated the software from iTunes, which basically downloads the entire iOS as I'm sure you all know, but I thought that in doing so it would remove any failed updates.


    The next time there's an update, I'll try an OTA update and hopefully I won't have this issue again. Definitely quicker then restoring though.

  • deroo Level 1 (10 points)

    That should say... Updated the software, not plated...  

  • Moha.F Level 1 (0 points)










  • linuxubuntufan Level 2 (420 points)

    Please don't use All Caps as this indicates shouting, which is rude.

  • deroo Level 1 (10 points)

    UPDATE Since iOS 6


    Tried to update to iOS 6 last night on the iPad, downloaded the file just fine and when it tried to verify I got the same error as above.


    I then decided to reset the iPad - lose all settings and data. Once it restored, I tried to install the update again - same thing. The update did not need to re-download, I was just prompted to install it.


    I have now booked a Genius Bar appointment to let them sort it. I could keep trying stuff but as I only have 3 months left of warranty I'd rather Apple sorted the issue. I could go and try restore mode, but the unit isn't working as it should so I think it's better they fix it.


    I'm surprised no one else has found similar issues, makes me think this issue is quite rare. iPhone updated just fine, so I know it's not my network. I'll post back after I've been to the geniuses.

  • stephjais Level 1 (0 points)


    I'm having the exact same issue.


    Did Apple provide a solution for this ?


    Sincerely yours.

  • deroo Level 1 (10 points)

    Hi, probably no use to you now as you would have sorted your issue. If anyone else comes across this issue... yes, Apple did just replace my iPad at the time. The head techie had never seen the issue and was surprised I came in and did all the troubleshooting for him. No questions asked, just gave me a new iPad as it was still under warranty.