2 Replies Latest reply: Jun 6, 2012 5:56 PM by BDAqua
moneyCuz Level 1 Level 1 (0 points)

I have an iMac OS X 10.7.3 (purchased in late 2010) with all updates current. I use AirPort to connect to my Linksys router with a WPA2 password.


Nearly everytime I wake my computer from sleep, my wireless router is disconnected, even when I have set my settings and clicked on the lock to prevent further changes. My router always shows on the list of available connections with full strength, but it is more often than not extremely difficult to get it connected again. It says "Could not join "myRouter". A connection time out occured."  I usually have to use the assistant and go through the steps, which usually includes re-typing my password four to five times before it agrees that I know my own password (which is fairly simple to type, I can't possibly be entering it incorrectly that many times).


I downloaded and installed an update (found here: http://support.apple.com/kb/DL1501) that quote: "resolves an issue that may cause an iMac to not automatically connect to a known Wi-Fi network after waking from sleep. It is recommended for all iMac (Late 2009 or newer) users running 10.7.3."

 

Upon a suggestion found in a thread, I tried setting a new location, and set the DHCP setting under TCP/IP to be manual. I was successful in connecting to the internet that time, and locked the settings to prevent further changes, yet the first time my computer woke from a sleep, the lock was unchecked and the settings were changed back to automatic. And I was disconnected yet again.

 

This has been going on for months, but in the last couple weeks I have found I am now unable to lock the lock to prevent changes, no matter if my Location is set to automatic or one that I have created. Really looking for resolution as this is wasting so much time, I am on and off the computer multiple times a day.

 

Thanks in advance for any help!


iMac, Mac OS X (10.4.11)
  • moneyCuz Level 1 Level 1 (0 points)

    I am still having this problem!! It is still driving me crazy!!!

  • BDAqua Level 10 Level 10 (119,850 points)

    Hello,

     

    The lock thing makes me think trying this first...

     

    Safe Boot from the HD, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions...

     

    /Users/YourUserName/Library/Preferences/com.apple.systempreferences.plist

     

    REboot.

     

    Instead of joining it from the list, click the WiFi icon at the top, and click join other network. Fill in everything as needed.

     

    It sounds like you may have more than one entry in Kechain for this Router...

     

    Go to System Preferences

     

    Click Network

     

    Highlight AirPort and click Advanced>Airport tab...

     

    Under "Preferred networks”, highlight any there, click the little minus icon

     

    Select your access point and Remove your access point with the minus minus.gif button.

     

    Launch your keychain access in Utilities and delete your access point keychain entry.

     

    Go back to the “By default, join:” page and click the plus plus.gif this time to add your access point. Enter the correct password, save, reboot.

     

    Open Keychain Access in Utilities, use Keychain First Aid under the Keychain Menu item, then either check the Password under that item, change it, or delete it and start over.

     

    Make a New Location, Using network locations in Mac OS X ...

     

    http://support.apple.com/kb/HT2712

     

    See if this helps...

     

    Open Keychain Access in Utilities, use Keychain First Aid under the Keychain Menu item, then either check the Password under that item, change it, or delete it and start over.

     

    Resetting your keychain in Mac OS X...

     

    >If Keychain First Aid finds an issue that it cannot repair, or if you do not know your keychain password, you may need to reset your keychain.

     

    http://support.apple.com/kb/TS1544