10 Replies Latest reply: Jan 7, 2013 3:26 PM by Dibzie
Belinda J Level 1 Level 1 (0 points)

I am a teacher and at the moment the only way my students can add photos to Pages is to go into my Photos app, copy a photo and then paste it into Pages.  This is tricky for my five year olds to do.  I have tried clicking on the '+' but the media tab says it can't access photos or videos and need to go to the Settings app and Location Services to turn the Pages switch to on.

IMG_0087.jpg

 

When I go to the Settings app and Location Services there is no Pages switch to turn on and in fact all the options are faded and can't be changed (other than Find My iPad).

IMG_0088.jpg

 

Does anyone know what I'm doing wrong please?

 

Thanks

Belinda


iPad 2, iOS 5.1
  • 1. Re: Why can't I add photos to Pages?
    bwfromspring hill Level 4 Level 4 (1,470 points)

    Belinda,

     

    You certainly are doing the right things to get your media browser to bring in photos - but for some reason your Locations settings is missing the Pages switch. This might be a good time to do some basic iOS actions to perhaps properly connect your iPad with Pages. What I would do is the following:

     

    Turn OFF all active apps on your iPad - Double Click your Home Button to expose the active apps > tap and HOLD on the first app icon until it jiggles and displays a "-" then tap each "-" until all apps are gone

     

    Power down your iPad and restart it - Click and HOLD BOTH Home and Sleep buttons on the iPad until the shutdown slider appears > slide to shut down > wait a minute or so then Restart your iPad

     

    Connect your iPad to iTunes and allow iTunes to synch again with your iPad - Apple just released an iOS update to 5.1 and iTunes may reload your apps

     

    Go to Settings > Locations Services and see if your Pages Switch has now been added - as a teacher, I imagine you also have Keynote and Numbers - they too should have Location Services Switches which are missing from your screenshot, so with any luck, they should be restored as well.

     

    Good Luck.

  • 2. Re: Why can't I add photos to Pages?
    Belinda J Level 1 Level 1 (0 points)

    Thanks so much for your reply which was very detailed and easy to follow.  I did as you suggested and the iOS is up-to-date (5.1.1) but unfortunately there is no chnage in what is available under Location Services.  There is no switch for Pages, Keynote, iMovie etc.  I'm at a loss and any suggestions would be appreciated.

     

    Many thanks

    Belinda

  • 3. Re: Why can't I add photos to Pages?
    bwfromspring hill Level 4 Level 4 (1,470 points)

    Belinda,

     

    You've done everything I can think of to fix the problem.

     

    There is a 90-day technical support and a limited 1-year warrantee on your iPad. You may be able to get help here:

     

    http://www.apple.com/support/ipad/contact/

     

    If you are beyond that period, the folks at the nearest Apple Retail Store Genius Bar may be able to help. To make an appointment (recommended) to visit a genius bar:

     

    http://www.apple.com/retail/geniusbar/

     

    Hope you find a fix.

  • 4. Re: Why can't I add photos to Pages?
    Mortarm Level 1 Level 1 (0 points)

    I have the exact same problem.  Followed BW's suggestion and got the exact same result.

     

    I have an original iPad with iOS 5.1.1 and 1.6 versions of Pages and Numbers.  Since it is an original iPad, it's out of warrenty and there's no Apple store within my reach.

     

    So I guess it's "No photos for you!"

  • 5. Re: Why can't I add photos to Pages?
    Dibzie Level 1 Level 1 (0 points)

    I had the same problem, but figured out how to fix it.

     

    The reason your Location Services are greyed out is because you have them set under Restrictions to NOT allow changes. Just go into Restrictions change Location Services to "allow changes". Then open the Pages app, open a document, tap the "+" button on the top right of the tool bar. The box will come up asking you to allow location services--choose yes. All your photos should now show up and the Pages app now shows in the Locations Services list. You can now go back into Restrictions and reset the "do not allow changes" to Location Services if you want.

     

    :-)

  • 6. Re: Why can't I add photos to Pages?
    mrmorgan Level 1 Level 1 (0 points)

    I found this on another post thread and it worked for me to reset Preferences. Everything listed above did not work. Here is what I found:

     

    Reset location services in Setting>General>Reset>Reset Location and Privacy and that fixed the problem.

     

    The next time you launch into Keynote it will ask if you want to allow access to photos, click yes/okay and you will have access to pictures in the camera roll.

     

    Hope it helps,

    David

  • 7. Re: Why can't I add photos to Pages?
    Mortar Level 1 Level 1 (0 points)

    Don't have Reset Location and Privacy.  Just Reset Location Warnings.  And since I have first-gen iPad, I don't have Camera Roll.  So I guess I'm just screwed all around.

  • 8. Re: Why can't I add photos to Pages?
    DigitalDavo Level 1 Level 1 (10 points)

    I just tried it on an iPad 1 and it worked by reseting "Reset Location Warnings." You will have to have picturesin your camera roll. We are running iOS 5.1.1.

     

    Does that work?

     

    David

  • 9. Re: Why can't I add photos to Pages?
    Belinda J Level 1 Level 1 (0 points)

    Thanks so much for this - brilliant!

  • 10. Re: Why can't I add photos to Pages?
    Dibzie Level 1 Level 1 (0 points)

    I'm glad you got it working, but the reset location warnings didn't work for me.  As I posted above, I had to turn off the restrictions on locations then after reopening the Pages app it worked.  Different solutions work for different people I guess!