Previous 1 2 3 Next 43 Replies Latest reply: Nov 14, 2012 6:31 PM by TransAtlanticDan Go to original post Branched to a new discussion.
  • keg55 Level 5 (7,748 points)

    I can confirm you are correct.

     

    I just ran a test. I have iStat Menus 3 installed. So, I uninstalled it and rebooted. The string of SMC error messages in Console were no longer there. I reinstalled iStat Menus 3 and rebooted. Console showed the string of SMC errors after iStat Menus loaded. I'm not concerned as 10.7.4 is working just fine here.

     

    Thanks for the explanation.

  • François Mottaz Level 1 (5 points)

    This is not the whole story, however. I just tested my late 2011 MBA in Safe Mode. The messages are still there although Safe Mode is supposed to disable all third party software processes running at startup ?

  • paddyiyer Level 1 (0 points)

    I am using iSTAT pro and hence the errors. I will update the thread after uninstalling it and retry the 10.7.4 combo update.

  • Laris Level 1 (10 points)

    No unstable system here! ApplesSMC replacement works perfect !

  • Laris Level 1 (10 points)

    Also, if new Applesmc not work, you get a message "SMC::smcReadKeyAction ERROR....".....AND.....

    "fall back to old SMC mode"... This means that Apple used the old AppleSMC.kext from 10.7.3 too... You CAN use old AppleSMC.kext from 10.7.3...No harm for your system at all !

  • Stingray88 Level 1 (0 points)

    I went with Laris' suggestion and it works like a charm. No more error messages in console!

  • Laris Level 1 (10 points)

    Like I said ....

  • KrisCoady Level 1 (0 points)

    Same errors here. Loads of them, too.

  • Alfonso Garcia Level 1 (0 points)

    I've been having same problems with that strange kernel error. I repaired permissions and it didn't work, so I uninstall iStat Pro Wiget, FanControl and I deleted the "FanControl Daemon" folder from \Library\StartupItems

    and now I don't have any problems!

     

    Hope my experience helps all of you!

  • Tom Collignon Level 1 (0 points)

    Same problem here.  Closing xscan solved my problem.  No more error logs.

  • keg55 Level 5 (7,748 points)

    Those log errors do not mean you're having a problem.

     

    See below quotes from vladalexa:

     

    All those errors you pasted are just the result of some application asking the kernel for a SMC sensor that does not exist, e.g.: on the first line you pasted is asked for the IN0C sensor.

     

    Previously the kernel did not log errors when asked about SMC sensors it does not have, this is what changed in 10.7.4

     

    I'm still using iStat Menus 3 eventhough I get the SMC log errors and the app along with OS X are working fine.

  • djh.me Level 1 (0 points)

    I had similar errors reported in the console logs since updating to 10.7.4 and my iMac wouldn't go to sleep in idle either.

     

    11/05/2012 21:30:30.000 kernel: SMC::smcReadKeyAction ERROR TC0D kSMCBadArgumentError(0x89) fKeyHashTable=0x0xffffff800ce0c000

     

    I tracked down the rogue application, which in my case was CPULed. Once I killed that app the problems stopped.

  • paddyiyer Level 1 (0 points)

    This seems to be a benign error. It only appears if I use the istat app. I am not to break my head anymore on this. Thanks everyone for chiming in and providing the possible solutions.

  • budsimrin Level 1 (10 points)

    Same problem here. I went to Activity Monitor and quit smcFanControl and the problem immediately stopped. From the rest of this thread, it sounds like Apple must have changed the fan control interface in OS 10.7.4 and just about any app that reads the fan gets this error.

  • gravedigger1202 Level 1 (0 points)

    I got the same Problem here. But after the Replacement, the Ambilight Sensor did not work. Changing back, the Sensor works correct .