Previous 1 2 3 Next 43 Replies Latest reply: Nov 14, 2012 6:31 PM by TransAtlanticDan Go to original post Branched to a new discussion.
  • tod1212 Level 1 Level 1

    just a short feedback on my side:

    i finally fixed my chrashing problems with a clean reinstall of lion using hd recovery (quite handy by the way).

    restored using a backup from my time capsule.

    all is fine now.


    just to let you all know:

    i just got a very friendly call directly from "the mothership" in california (on a sunday).

    (for your info: i'm living in germany!)

    some nice apple employee asked some questions about my problems.

    i had to tell him that all was fine since reinstall.

    anyway, he told my about a programm called "FIPS" which might be causing problems with 10.7.4 (i did not use it).

    so: apple DOES monitor this forums

  • Mojo66 Level 1 Level 1

    budsimrin wrote:


    Same problem here. I went to Activity Monitor and quit smcFanControl and the problem immediately stopped. From the rest of this thread, it sounds like Apple must have changed the fan control interface in OS 10.7.4 and just about any app that reads the fan gets this error.

    I'm getting the same error message, every 3 seconds, really annoying and totally useless in my opinion, who cares about logging access to a sensor that doesn't exist?? Anyway, I've dropped a note at the devoper's home page maybe you can, too.

  • digitalidea Level 1 Level 1

    In my case CPUled app was the root cause; after stopping it the message was gone

  • frankbullitt Level 1 Level 1

    I updated to 10.7.4 on Sunday and yesterday my MBP froze (it didn' actually froze, I could move the cursor but it looked weird an I couldn'd do anything), so I forced it to shutdown. Then it got stucked at the grey screen, with the wheel spinning until it stopped and nothing else. Then I was able to boot in safe mode, but this was my screen when i did it.



    I tried to restart but it was impossible to boot up again, even in safe or recovery mode. Today, during an inconclusive safe boot I've got this

    Previous Shutdohn Cause: 3

    SMC::smcInitHelper ERROR: MMIO regMap == NULL - fall back to old SMC mode

    NVDANV50HAL loaded and registered.

    SMC::smcHandleInterruptEvent WARNING status=0x0 (0x40 not set) notif=0x0

    NVDANV50HAL loaded and registered.

    SMC::smcReadKeyAction ERROR: smcReadData8 failed for key MOTP (kSMCKeyNotFound)

    DSMOS has arrived

    SMC::smcReadKeyAction ERROR: smcReadData8 failed for key BEMB (kSMCKeyNotFound)

    macx_swapon SUCCESS

    infunc createVirtualInterface ifRole =1 Created virtif 0xffffff800bb7100 p2p0

    Airport: Link Down on en1. Reason 8 (Disassociated because station leaving).

    I've done the PRAM and NVRAM reset and then I've been able to boot in recovery mode. I did nothing else, just restart normally and it worked. Now my fear is if i'm going to have these boot and graphic errors again. ¿Are these the same errors you've been experiencing? ¿Should I try replacing the AppleSMC.kext?



  • Laris Level 1 Level 1

    I have replaced and works very well! No problem! Good luck.

  • lsbee100 Level 1 Level 1

    Thank you.  Relacing the 10.7.4 file with the 10.7.3 file eliminated all console errors.  This was driving me nuts!

  • Laris Level 1 Level 1

    You are Welcome Glad to help !

  • iambrainz Level 1 Level 1

    frankbullitt did you manage to fix it? I ave a somewhat similar experience./___sbsstatic___/migration-images/188/18820682-1.png

    This happened after it was frozen and restarted..

  • frankbullitt Level 1 Level 1

    Yeah, I kinda fixed it, I´m sorry I didn't post anything after I did it and thanks to Laris and everyone else.


    The thing is, it works but, my mac at least, still does strange things. Let me explain. After I replaced the kext, I booted in safe mode, it worked, so I shut down and restarted in normal mode. It worked again. Next day, normal boot, it hanged again at the spinning wheel. Safe boot, it works, restart, normal boot, It works, magic. For some days it was impossible to do a normal boot without doing a safe boot previously, I didn't understand it. One day I forgot to press shift key at boot screen and I thought it was going to hang up... but it didn't. Magic. After that, it takes lke a year and a half to start up, it used to take only a year before. Maybe this is only happening to me, I don't know. Now I have some time i'm going to make a clean OS X install, maybe 10.7.3, maybe going back to 10.6, I'm not sure.


    That's my story, I hope it helps you (but I don't think it's going to).

  • Mojo66 Level 1 Level 1

    Just for the record: the problem with smcfancontrol flooding the console with errors is gone in 10.8.

  • Laris Level 1 Level 1

    Yes, i confirm that !

  • Martin Whittaker Level 1 Level 1

    DO NOT manually downgrade the kernel extension just because the new version exposed a bug in one of the applications using it


    100% agree with this.  The problem in my case was a combination of Fan Control and iStat.  I removed iStat from the dashboard, and removed Fan Control as documented elsewhere in this thread.  Problem gone.


    Just as an experiment I re-installed the iStat widget.  There was a flurry of SMC errors when it installed, but after that all was clear.  I assume it disables checking for any SMC calls that return errors when it is first installed.  So I can still have the useful iStat widget, and no SMC errors in the log.  Nice.

  • TKRWH Level 1 Level 1

    Well I followed Alfonso Garcia's comment below and it fixed my error instantly.


    I've been having same problems with that strange kernel error. I repaired permissions and it didn't work, so I uninstall iStat Pro Wiget, FanControl and I deleted the "FanControl Daemon" folder from \Library\StartupItems

    and now I don't have any problems!


    Hope my experience helps all of you!

  • TransAtlanticDan Level 1 Level 1

    I didn't even know I had the /Library/StartupItems/FanControlDaemon until I looked!  This was the problem.  It was from 2007.  Deleted, rebooted and the error messages are gone!

Previous 1 2 3 Next