Previous 1 13 14 15 16 17 Next 245 Replies Latest reply: Jul 22, 2013 8:01 PM by Haych-AU Go to original post
  • daniel Azuelos Level 2 Level 2

    chemychemy wrote:


    Do you know if 10.7.5 Solves also the issue?

    The tests I did so far give the following results with the use of an

    Internet Sharing Connection on the wireless network:

    Mac model
    iMac mid 2010
    iMac mid 2011


    To reply to the point:

    10.7.5 doesn't fix the bug within IO80211Family.kext .

  • mj.montoya Level 1 Level 1

    Mid 2011 iMac

    Mac OS Mountain Lion 10.8.2 completely up to date

    Apple TV 3rd Gen 5.1

    iPhone 4s iOS 6


    I have experienced this same problem. I originally ran OS X Lion 10.7.4, activated Internet Sharing from ethernet to  WIFI, using WPA 2. This was at a totally different home with different internet connection sending to the iMac's ethernet port. I had 2 iPhones, original running 3.1.2 and iPhone 4s running 5.1.1. These devices would consistently lose their internet connection. They would show connected to the network being broadcast by the iMac, but would not connect to the internet. My roommate had a Windows laptop which experienced the same issue.


    I moved into a new house, changed internet connection, updated to Mountain Lion 10.8.2. I also added an Apple TV to this mix, and a 2006 MacBook. My iphones seemed to consistently connect, but the MacBook experienced problems. The biggest problem became the Apple TV. The Apple TV would connect to the network just fine. It would hold a stable connection... until I attempted to use AirPlay mirroring. If I connected the Apple TV to the Wifi the iMac was broadcasing, it would allow me to do AirPlay Mirroring for a good period of time. If I left it connected it would disconnect, or if I disconnected, I would not be able to reconnect it. If I attempted to reconnect enable AirPlay Mirroring from my iMac for a second time, I would get the spinning color wheel, and the AirPlay Mirroring icon would disappear (note: restarting the Apple TV or the iMac, either device, would allow me to reconnect for a while). Additionally, AirPlay Mirroring was not available on my iPhone 4s at any point, despite the fact botht the iPhone and Apple TV are compatible and connected to this same wireless network (provided by the iMac).


    For quite a while, I believed this to be a problem with the individual devices. I thought for sure it was not an issue with the internet signal broadcast by the iMac.. until.. I decided to try this on a network created by a separate wireless router. I connected the iMac to the router via ethernet and the Apple TV and iPhone 4s to the router Wifi signal, lo and behold, all problems were solved. I was able to activate and deactivate AirPlay Mirroring on my iMac, the Apple TV stayed connected to the network with no issues, AirPlay Mirroring functions worked between my iPhone and Apple TV, and other devices were able to hold a stable connection to the wireless network.


    The only thing that changed was the source of the wireless network from the Internet Sharing on my iMac to a different wireless router.


    I was unable to find anything on that discussed the compatibility of using AirPlay functions over a network shared by a Mac. I would be surprised if this is not supported. So based on what I have read, this is a supported configuration.


    Am I missing something? Shouldn't this work consistently? Shouldn't the AirPlay Mirroring functions be available on the iMac brodcast Wifi signal? Should devices stay connected to the iMac broadcast Wifi signal?


    I believe I have eliminated the possibility of this being anything other than an issue caused by the Mac (specifically the OS or iMac). Furthermore, I have a separate FireWire drive with a fresh installation of Lion 10.7.4 and Mountain Lion 10.8.2. I have booted from both of those partitions, and the problem still occurs. They are fresh installations; thus, reinstalling the OS will not resolve this.


    -The possibility of the issue being related to each connected device and/or the devices' OS has been eliminated, as I have attempted to connected the iPhone 1st gen, iPhone 4s, Apple TV, MacBook (running Leopard 10.5.8), and a Windows Laptop running Windows 7.

    -The possibility of the issue being related to the environment has been eliminated as I have completely changed locations

    -the possiblity of being the OS, instance of the OS installation, specific to 10.7.5 or 10.8.2 has been eliminated as I have booted from each


    After all, I am thoroughly convinced this is a bug in the OS specifically related to the Mid 2011 iMac. If I am missing something, please let me know. I require a set up when sharing my internet connection from my iMac because of a VPN connection from work (although the VPN is not a factor in this troubleshooting).



  • makdogan Level 1 Level 1

    Mac OS X Lion 10.7.5


    Before i used to connect to my internet sharing with my ipod. Now like everyone it doesnt work at all. However, the interesting thing I am using a Blackberry and it can connect to internet sharing and works perfectly.


    Btw: internet sharing for ethernet to wifi


    Isn't is strange about blackberry ?



  • pianoteacher00 Level 1 Level 1

    Just adding my frustration with losing file sharing and wi-fi.  I am confused on how to fix with so many posts.  What a disaster and I am very disappointed with Apple.  It worked beautifully until I upgraded.

  • JPHP Level 1 Level 1

    An odd thing happened to me the other day. I have been running Mountain Lion 10.8.2 for a couple of months and didn't think any more about this problem since it was fixed. But then one of my kids accidentally clicked on a dodgy game website from one of my old pre-Intel Macs (running Leopard 10.5.8) and sent my firewall app (Intego Virusbarrier 6) into a panic at the same time as my main machine was trying to do a backup. This caused a full-on crash which required a power button restart, and afterwards the internet and file sharing to both the Leopard machines were totally dead - but that to my iPhone and iPod Touch only intermittently so. I tried re-setting everything I could think of and even deleted the network and created a new one, but the problem remained. After a couple of hours of head scratching I decided to do a full restore from Time Machine to the one before the failed backup, and all is fine again.


    It is very strange, since I would have assumed it would affect all connected devices equally, but it doesn't seem to. At first I thought the iOS devices were not affected at all, although the connections started dropping out after a few minutes. I have no idea if this is any help at all in solving the mystery!

  • daniel Azuelos Level 2 Level 2

    daniel Azuelos wrote:



    To reply to the point:

    10.7.5 doesn't fix the bug within IO80211Family.kext .

    Here is an upgraded table of the tests I was able to run (on Gbyte transfers on an Internet Sharing connection at 32 Mbit/s):

    Mac model
    iMac mid 2010
    iMac mid 2011


    10.8.2 fixes the IO80211Family.kext bug introduced with the 10.7.4 upgrade.


    Beware of deception: on 10.7.4 & 10.7.5, at first the wireless network side seems to work.

    For example a short time ping (a standard Unix command to be run in a Terminal)

    fired from a wireless client will be able to access the iMac sharing its

    Ethernet connection. But on a huge file transfer, the connection fall pretty quickly.

  • CelborneZ Level 1 Level 1

    Hi. I did a search and this has been a solution for me on OSX 10.8.3 on MBP 2011.


    The internet connection is shared through my MBP on WPA2 - 8 characters to my Windows 7 laptop. The windows 7 connection security is specified to be WPA Personal - 8 characters password.


    On your MBP you will need to obtain your IP address for your DNS server:


    1) System Preference > Network > Ethernet* > Advance > DNS > Note down the IP address of your DNS servers.


    *I assume you are sharing connection from your Ethernet.



    On the device that you want to connect to (in this case the step listed is for Windows 7):


    2) Right Click on your wireless icon on the bottom right of your task bar > Open Network & Sharing Centre.

    3) Click "Connections: Wireless Network Connection(whatever name you specified your network to be), a wireless network status should pop up.

    4) Click Properties

    5) Go to IPv4 and click Properties (Not IPv6)

    6) Manually input your DNS server as specified in Step 1.


    If it is on other devices, please Google the steps to get into the necessary DNS page to manually key in the DNS.



    Conclusion: Seems that Mountain Lion do not automatically settle the DNS assigning.

    Credit do not go to me as I have plugged this out from member CHFeatherzone from Macrumours forum. Hope this helps.

  • Haych-AU Level 1 Level 1

    Thanks Celbornez, this is exaclty the issue I had.


    I was using a 4G dongle though on my main device, not ethernet. So I used the Google Public DNS addresses (details here) instead because the DNS server details changed everytime I re-connected the dongle.


    Thanks again.

Previous 1 13 14 15 16 17 Next