11 Replies Latest reply: May 14, 2012 2:58 PM by Terence Devlin
Michael Bryan Level 1 Level 1 (65 points)

I am running IPhoto Ver 9.2.3.  ("Iphoto-11") on an Intel Imac Core i5 currently empowered by Mac OS Version 10.6.8.

 

 

Suddenly  ,my  Iphoto will no longer run slideshows.  

 

None of the commands and buttons available in various IPhoto "views" will work tostart a slideshow and they all produce the same result:  a brief dimming or flashing of the screen and then - nothing:  absolutely no slide show .

 

I have tried turning off the screensaver slide show hoit corner, in case it was interfering but this has made no difference.

 

Iphoto's Slide Show has simply decided to suddenly no longer work .

 

What is the fix for this particular bug, weakness or susceptibility in the software ?  Anyone know ?

 

I can think of nothing I might have done to cause this failure. 


iMac, Mac OS X (10.6.6), iMac 2.7 GHz core i5
  • Old Toad Level 10 Level 10 (123,365 points)

    Try this:  launch iPhoto with the Option key held down and create a new, test library.  Import some photos and check to see if the same problem persists. If it does not then your current library is damaged.  If that's the case try the following:  make a temporary, backup copy (select the library and type Command+D) and apply the two fixes below in order as needed:

     

    Fix #1

     

    Launch iPhoto with the Command+Option keys held down and rebuild the library.

     

     

    Select the options identified in the screenshot

     

    Fix #2

     

    Using iPhoto Library Manager  to Rebuild Your iPhoto Library

     

      1. Download iPhoto Library Manager and launch.
      2. Click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.
      3. Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option
      4. In the next  window name the new library and select the location you want it to be placed.
      5. Click on the Create button.

     

    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments but not books, calendars or slideshows. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.


     

     

    OT

  • Michael Bryan Level 1 Level 1 (65 points)

    "Old Toad:" 

     

     

    I suspect the problem may NOT be a corrupted library - since when I log into my wife's account on the same computer using the same Iphoto installation I find HER slideshows don't work either.  that suggests the app itself is corrupt or incompatible with the current OS version or something.  

     

     

    Is there a way to reinstall the original version of IPhoto 11 off the Ilife DVD without damaging or losing one's photo library, events, titles etc etc ??

     

    That said, I am going to try righty now the above fixes you suggested for rebuiilding a damaged library just to positively rule that out. 

     

    THANK YOU very much for your help so far !!!!

  • Terence Devlin Level 10 Level 10 (131,640 points)

    Back up first.

     

     

    To re-install iPhoto

     

    1. Put the iPhoto.app in the trash (Drag it from your Applications Folder to the trash)

     

    2a: On 10.5:  Go to HD/Library/Receipts and remove any pkg file there with iPhoto in the name.

     

    2b: On 10.6: Those receipts may be found as follows:  In the Finder use the Go menu and select Go To Folder. In the resulting window type

     

    /var/db/receipts/

     

    2c: on 10.7 they're at

     

    /private/var/db/receipts

     

    A Finder Window will open at that location and you can remove the iPhoto pkg files.

     

    3. Re-install.

     

    If you purchased an iLife Disk, then iPhoto is on it.

     

    If iPhoto was installed on your Mac when you go it then it’s on the System Restore disks that came with your Mac. Insert the first one and opt to ‘Install Bundled Applications Only.

     

    If you purchased it on the App Store or have a Recent Mac you can find it in your Purchases List.

  • Michael Bryan Level 1 Level 1 (65 points)

    Removed  and reinstalled and then re-updated  IPhoto

    Back up to Ver 9.2.3.

     

    Still no slide show will run from the arrow icon in any of the main windows.

     

    Screensaver slide show using IPhoto created folders

    WILL run from a hot corner but some other app, extension, or process clearly

    Seems to be preventing slide shows  from within events or photos windows from starting.

     

    Now how to go about finding the culprit ?

  • Terence Devlin Level 10 Level 10 (131,640 points)

    Try boot into Safe Mode and try again.

  • Michael Bryan Level 1 Level 1 (65 points)

    Tried Safe Mode boot-up.  No difference.

    Freshly reinstalled and updated IPhoto 9.2.1.  STILL (!!)

    Won't run slide shows on my Mac OS System 10.6.8.

     

    Am now convinced this is an issue or a failure susceptibility Apple

    Must fix.

     

    Wonder if it would go away if I updated to 10.7 Lion ???

  • Michael Bryan Level 1 Level 1 (65 points)

    Thx to all for helpful suggestions rec'd do far !!!

  • Terence Devlin Level 10 Level 10 (131,640 points)

    Launch the Console, try run a slideshow and see if anything gets written to it.

  • Michael Bryan Level 1 Level 1 (65 points)

    Great idea !  I'll try and report back.  Thx agn.

     

      - - mike

  • Michael Bryan Level 1 Level 1 (65 points)

    Launched Iphoto and tried to launch the slideshow in the main browser window - the one that shows all my events.

     

    Used the arrow button at centre bottom of the main window.

     

     

    The following message was written to Console as the screen flashed to black for a half seconbd and then as usual notning else happoened (No slide show)

     

    CONSOLE:

     

    12-05-14 5:25:03 PMiPhoto[1306]iLife Slideshow: No Styles Found

     

    hmmmmmmmmm   ???????

  • Terence Devlin Level 10 Level 10 (131,640 points)

    You need to re-install the OS.

     

    Regards

     

     

    TD