1 5 6 7 8 9 Previous Next 126 Replies Latest reply: Apr 22, 2014 8:42 AM by phearce Go to original post
  • 90. Re: Invalid Certificate on every secured website
    Arkady Level 1 Level 1 (0 points)

    Nope, it not helps as long as you are behind authentication proxy.

    It seems that there are at least two issues with certificatesd in OS X Lion, both with similar symptoms.

     

    If you are connected directly to the interrnet, you can solve it by repairing crl and ocsp caches as described in your blog. Enterprise users using proxy are doomed, no fix at the moment (except disabling CRL and OSCP checks complete thus render entire concept of certificate trust useless)

  • 91. Re: Invalid Certificate on every secured website
    Appleguy514 Level 1 Level 1 (25 points)

    This worked for me.  It's ingenious since there was some kind of bug with the 10.7.4 update and it caused certain certificates to change their trust values or not register them properly in Keychain Access.  This method below has you change a certificate's trust value, save it, then change all the certificate's trust values back to default as it should be.  This solved my problem and my father can use his banking websites on Safari again.  However, it does take some time to enter and re-enter the admin password again and again for over 20 certificates.  Good luck and thank you for the advice.

     

    Details: The problem was on a 2.2 GHz Intel Core 2 Duo, 13-inch Late 2007 MacBook (the black - Santa Rosa model - I believe).  I even updated everything to the newest software and Safari to 6.0 and it didn't fix the problem until I tried the method below.  Apple, get on this.

    quickSti wrote:

     

    I solved this on my wife's computer by resetting the security certificate settings.  This might help others:

    Close all windows.

     

    Keychain Access ->  click on System Roots on the left, and then click on Certifcates on the bottom left.

     

    Check to see if any of the certificates on the right have the blue "+" symbol - this means they have custom trust settings.

     

    There is a bug in changing the policies, so you'll have to change them via the method below.  Changing them just by changing the access to "system defaults" doesn't seem to save.  The method below worked for me.

     

    Double-click on each certificate with the custom setting (blue "+"), expand the section labled "trust".  Change the "Secure Sockets Layer (SSL)" setting to "no value specified".  Close window - you should be prompted for the password.  Double-click on the certificate again, expand trust, change the "When using this certificate" setting to "Use System Defaults".  Close window, and re-enter password.

     

    If you didn't re-enter your password upon closing the window, the setting didn't take.  The blue "+" should disappear after a few seconds when it's set back to default.  Once all of the certificates are changed back to default, restart Safari.

     

    This solved all of the problems for my wife's computer with these issues and OSX 10.7.4

  • 92. Re: Invalid Certificate on every secured website
    dhemp Level 1 Level 1 (0 points)

    Yes...this is the solution that worked for me. I'd been encountering problems accessing AppStore ever since updating to Safari 6. But once I was able to clear up the Keychain Access issues as described by quickSti, I immediately regained access to AppStore so that I could begin the Mountain Lion upgrade process. Thanks for a great solution!!

  • 93. Re: Invalid Certificate on every secured website
    SoloNerfherder Level 1 Level 1 (0 points)

    Thanks arthurlockman, after quite a few hours smacking my head against a brick wall, the instructions in that blog seemed to have fixed both my Safari certificate problem (Twitter and Apple finally work, at least) and my Mac App Store "connection failed" when trying to log in problem.

  • 94. Re: Invalid Certificate on every secured website
    caj001 Level 1 Level 1 (0 points)

    I'm glad it work for some. Unfortunately for me it doesn't work. I have no "blue" icons next to any of my trusted roots, just two red expired ones that I can't delete. I'm really surprised that the geniuses at Apple are unable to tell us how to fix it.

  • 95. Re: Invalid Certificate on every secured website
    fnankivell Level 1 Level 1 (0 points)

    Same here, tried everything suggested on this thread (and more from other sites) to no avail. Being behind a corporate proxy seals your fate from the start. App Store won't connect to my account because of this, can't download and upgrade to Mountain Lion to fix the issue. Completely stuck in a loop...

  • 96. Re: Invalid Certificate on every secured website
    Steffen_R. Level 1 Level 1 (20 points)

    fnankivell,

    i have the same problems... it seems we have to wait, what happened... and maybe there will be a security update soon - patching the system to fix this issue.

    For some reason it seems that some systems seem to respond well to the given ideas, like ocspd and certificate changes, other systems seem to be simply ignore those tries to get connection to the "mother ship" Apple...

     

    So... if someone has a good working idea, please, please post it here

  • 97. Re: Invalid Certificate on every secured website
    sdaniel5 Level 1 Level 1 (10 points)

    Firefox.  I have been unable to use Paypal since all this nonsense began.  I've had to use Firefox to get to it.  I too see all these discussions.  This is an Apple-generated problem and it looks as though they are unwilling to fix it.  So I'm moving everything over to Firefox.  Also moving my Mail accounts over to Postbox, to eliminate the Apple-generated snafus (apparently) caused by going from dot mac to mobileme to iCloud ('Just let us do that for you, it's so easy' -- and then when things screw up we have to fix them on the forum.  Without the tools they already have in house that they could very well use to fix the bugs.)  I think Apple's obsession with the iPod and iPad and iPhone has taken away from their attention to the computers.  It's not, we know, a lack of cash.  --  I am also watching the interesting reports about Mountain Lion!  Running Lion now, will just keep watching.

  • 98. Re: Invalid Certificate on every secured website
    sébastienfromquebec Level 1 Level 1 (0 points)

    ML running quite well out there but I have a minor problem with the corporate proxy. It's not related with certificates but with Crashing issue in Safari while 1password extension is enabled..

  • 99. Re: Invalid Certificate on every secured website
    Fred-OO Level 1 Level 1 (0 points)

    Running Mountain Lion and have the same problems with invalid cirtificates.  I tried all the above fixes with no luck.  Now you have to use the App store to get software updates, but guess what?  I can't log into the App store because of invalid certificate!  I can log into iTunes App store, but not the App store application.

  • 100. Re: Invalid Certificate on every secured website
    hammy.patel Level 1 Level 1 (0 points)

    have you tried a clean instal?

     

    Fred-OO wrote:

     

    Running Mountain Lion and have the same problems with invalid cirtificates.  I tried all the above fixes with no luck.  Now you have to use the App store to get software updates, but guess what?  I can't log into the App store because of invalid certificate!  I can log into iTunes App store, but not the App store application.

  • 101. Re: Invalid Certificate on every secured website
    Fred-OO Level 1 Level 1 (0 points)

    Hi, just did a clean install; erased HD then installed full Mountain Lion, then used Migration Assistant and restored User, Apps, Files etc.  Still cannot log into App store. Tried more than App store account and all attempts get Connection Error.  Can use Safari, iTunes etc OK.  iTunes login works OK.  App store is locked up???

  • 102. Re: Invalid Certificate on every secured website
    Fred-OO Level 1 Level 1 (0 points)

    Well, I finally got this to work.  My symptoms were; after Mountain Lion install, I cannot log into iMessage, FaceTime or the App Store.   Getting many certificate errors from websites using Safari.  Console log shows various certificate error messages such as Failed to get client cert and Certificate not yet generated each time an Appleid login was attempted.

     

    After carefully following these instructions, step by step fixing cirtificates in the System Root Folder of Keychain, it finally started working.  The first time I used these instructions I was apparently in the wrong Keychain Folder.

    http://b.rthr.me/wp/?p=356

    Cheers

  • 103. Re: Invalid Certificate on every secured website
    fnankivell Level 1 Level 1 (0 points)

    This issue is infuriating me, *absolutely* nothing works. I don't have any blue dots on my certificates, I've deleted all caches and prefs and .plist suggested everywhere, still nothing...

     

    And now I'm reading that the only hope I had, upgrading to ML, is not helping as people still have the same issue after the upgrade. GRRRRR   Anyway, I wouldn't be able to upgrade anyway because I'm still denied access to my account on the App Store.

     

    What the heck happened Apple? I wish I could downgrade to 10.7.3 and put this nightmare behind me...

  • 104. Re: Invalid Certificate on every secured website
    Fred-OO Level 1 Level 1 (0 points)

    Sorry to hear that.  I also thought none of the certificates had the BLUE + sign, but when I very carefully followed step 2 in the link http://b.rthr.me/wp/?p=356 I found one, and then had to unlock the Keychain window and follow step 3.     I too spent 2 days trying all the other solutions and then going back and doing this one more time.  The rest of Mountain Lion works fine!   If you have another Mac, you can transfer the Mountain Lion installer image to a bootable 8GB thumb drive to use for your installation.  (ref Macworld)

1 5 6 7 8 9 Previous Next