14 Replies Latest reply: Jun 6, 2012 7:40 PM by moondancer2
jdotmattinson Level 1 (0 points)

I am somewhat new to Mac but I haven't had to post on this forum yet so I will try to be as clear about the issue as I can be.


I have an iMac (21.5 inch Mid 2011) and I am running 10.7.3 right now.


Software update informed there was an update available to Lion (10.7.4) so I tried to let it do it's thing and update it for me.  The update downloads, then informs me that it has to restart to complete the installation.  The progress bar after the restart shows it is working, and at the "Cleaning Up" stage, I am prompted with this message and only have the option to "Restart":  The update "Mac OS X Update" can't be installed.  The update could not be expanded, and may have been corrupted during downloading.  The update will be downloaded and checked again the next time that Software Update runs.


I tried that method about 5 times, and kept getting the same thing.  I read that I should try to download the .dmg files directly from Apple's site which I did.  I downloaded the Combo client version and just the regular client version but when I try to open both .dmg files, I get "invalid checksum".


I did a disk utlity scan which came back to say that things were OK.


What can I do?

iMac (21.5-inch Mid 2011), Mac OS X (10.7.3)
  • Mr.GAMA Level 1 (0 points)

    I have had the EXACT same problem and done the EXACT same things as you man. Only I use a MacBook Pro. I am thinking that we should wait a bit until the servers and Mac people have fixed the problem... But if anyone can help out then that would be awesome.

  • jdotmattinson Level 1 (0 points)

    To add to the confusion, I tried to update to iOS 5.1.1 through iTunes as well, and THAT file was corrupted.  I managed to update my iPhone OTA since I already had iOS 5.1, so that is fine now, but that really is just a work around.


    I decided to tether my internet from my iPhone to my iMac to try that, and skip my Eastlink router, to isolate the problem.  Doing so actually allowed me to download the 10.7.4 update and install it successfully.


    So now I have isolated the problem to the router.  I checked the settings on the router but I honestly know very little about networking and had no idea what I was looking at.  To make matters worse, I don't know how to test it if I do change anything, because the two things I couldn't update are now updated.


    Not sure where to go from here.  Maybe the problem isn't going to occur again, but to Mr.GAMA, if you have another source of internet (should be easier for you than it was for me since you at least have a laptop and can move it to another source), then try using that to do you download, and see if that works.


    Thanks for replying.

  • zerimar3 Level 1 (0 points)

    I'm having the same issues on my MacBook Pro. I've been trying to download this update for the last two days. I'll give it a shot again today and hopefully the servers are clear and the files don't turn up with the "corrupt" notice.

  • Addictedtomacs007 Level 1 (5 points)

    jdotmattinson is correct! I have the same issue.


    It is a router/ISP issue.  Tried the software update drop down for 10.7.4, failed.  Tried to download 10.7.4 Combo Client update, invalid checksum.  Tried to download 10.7.3 Combo client update, invalid checksum.


    Went over to Win7 Dell laptop, downloaded 10.7.4 Combo update, transferred to MacMini via USB drive. Invalid checksum.  WHICH led me to diagnose it wasn't my Mac, but Apple's servers or my ISP/Router.


    Went to work, downloaded on XP, put on USB drive, brought it home, copied, installed just fine!


    Did a hard factory reset on Motorola Surfboard SBG5560, invalid checksum again.


    Going to buy a new router tonight and test it again with dowloading 10.7.4 Combo update.  Will keep you posted to see if that fixes it.


    Btw, if a new one doesn't fix it then it's my Comcast ISP service that is messing it up. Which is going to make me cry....check out this link... be afraid, be VERY afraid if this is the problem/solution.


  • sebdub Level 1 (5 points)

    Same problem here, but I have a mac mini.


    The fault is on "Software Update" & Safari, not on your router, ISP or whatever...


    Try to download it from here :


    I used the combo update, and I did it trough Firefox with DownThemAll! add-on and I added the SHA1 checksum.


    Now it should be okay for you.


    Good luck!

  • jdotmattinson Level 1 (0 points)

    I can't download it again to test it out because I've already done the update.  The reason I feel that you can't be correct about this is because when I tethered my iPhone and used my cell data to download it from "Software Update" and it worked first try.


    Using my wifi through my ISP I tried several times from several sources and they all failed multiple times.  I didn't actually try it with my ISP and another browser.


    Now I am trying to download an update to an app through iTunes and I corrupts each time.

  • zerimar3 Level 1 (0 points)

    sebdub thanks for the tip. Worked for me!

  • Addictedtomacs007 Level 1 (5 points)

    Great to hear zerimar3 that sebdub solution fixed your problem!


    BUT sebdub, if you actually read the OP's issue you'd realize that is not his problem and that solution won't fix it.


    I think jdotmattinson is understanding his issue better, which is either the router or his ISP. Since he was able to download via 3G it worked, which bypassed his home internet connection.


    jdotmattinson, which modem do you have?  Is it a Motorola SurfBoard Gateway Wireless SBG6580?


    I went to best buy and bought another one along with a different modem.  This is what I found and how I fixed the issue.

    I installed a new SBG6580, provisioned it with Comcast and let it push the firmware over from Comcast.

    Sure enough it failed again.  Installed a different router Motorola SurBoard SB6121 (which uses a very different firmware) and it installed just fine!


    Motorola pushed a new 3.3.1 (I think...) firmware in mid FEB 2012 over to Comcast and to all SBG6580 modems which is causing the issue.  It will fail with all large DMG's that require a checksum.


    For other folks reading this, either wait for Comcast/Motorola to fix the issue and install large updates on another network and copy them over, or just get rid of that piece of junk router and get another one.  That's what I did.  Motorola SurfBoard SB6121 with Cisco Linksys EA2700 and all is fine now!

  • sebdub Level 1 (5 points)

    Addictedtomacs007, as I work in IT, I know a little bit what I'm talking about, what you seems not.


    The problem, as I had the exact same error, is fixed by doing a checksum (hash check) after the download, what a good download manager should do, and it seems that Safari and the Software Update does not well since I tried to do it 4 times. And when I did it with DownThemAll! it worked first time. It is not the first time it happens to me, and it's not by happenstance that Apple provides a SHA1 checksum, don't you agree?


    Now if you want to spend money everytime you've got a problem, I'm sure Motorola or Cisco will be happy!

    If you're router works for everything else, except this update, do not put the fault on the router (or firmware).


    I'm happy my solution works for people, it's why I posted, not to be argued because you think I'm wrong, so if you have another solution, just post it and do not debate. Thanks.

  • Addictedtomacs007 Level 1 (5 points)

    "....seems that Safari and the Software Update does not well since I tried to do it 4 times."


    Sebdub, what router are you using?  Have you checked with another router or contacted your ISP?  Let me know, as I was able to fix the issue with Software Update by using another router. Post your logs, that would help too.

  • Addictedtomacs007 Level 1 (5 points)

    Thanks you two for your responses!


    I finally got an answer from Comcast, which was that the firmware (given from Motorola and which they just "push" through to the modem) in some instances causes issues with the router/wireless network packets. This was proven when enabling RG PassThrough which bypasses the router/wireless gateway and makes the SBG6580 act as a pure cable modem only. When the tech and I did that no checksum errors or software (Transmission app) port UPnP errors occured.


    I was advised to keep with my new Motorola SB6121 cable modem and Cisco Linksys EA2700 wireless router combo, until Motorola fixed the issue.





    Not sure if this helps the OP with his issues, but thought I would share.

  • demonscars Level 1 (10 points)

    Having the same problem.  Have Time Warner's Wideband, not Comcast but this is the second thing I've had a similar problem with. I downloaded a large dmg the other day and it wouldn't open because it was corrupt.  It seems like sedub's solution works here, but what about files from the App Store or sites that don't provide a hash? It's a pretty major problem.

  • kumarvk Level 1 (0 points)

    Thanks, sebdub,


    DownloadThemAll really solved my problem on Mac 17"

  • moondancer2 Level 1 (0 points)

    Re: can't update my iMac to 10.7 anything!  2011 iMac; New iPad; 2008 MacBook

    Spokane, WA


    Downloaded 7.4, 7.2, 7.1 and could not find 7.0.  I want to get iCloud but am not thinking not in this lifetime.  I am not as computer literate as all the earlier responders on this issue.  All I want is my computer to be able to get OS updates and not just the routine software updates.  Please help!  Moondancer 2