1 Reply Latest reply: May 11, 2012 11:25 AM by lllaass
natateas Level 1 Level 1 (0 points)

took my opod from storage...  need  upgrade from ver 2.2.1   to later ver  3.1 or higher


iPod touch, iOS 2.x