6 Replies Latest reply: May 22, 2012 7:40 PM by jkahunas Branched to a new discussion.
tloebs Level 1 Level 1 (0 points)

I updated my phone to iOS 5.1.1 and now my battery dies extremely fast. Is there anything I can do to fix it?


iPhone 4, iOS 5.1.1
  • 1. Re: iOS 5.1.1 battery problem
    gdgmacguy Level 6 Level 6 (19,155 points)

    How about a forum search?

  • 2. Re: iOS 5.1.1 battery problem
    Knickers1974 Level 1 Level 1 (10 points)

    I have had the same problem but I seem to be getting somewhere to fixing it!!! My battery was going down at 20% an an hour now its 10% with constant use and 5 in standby !!! So improvement all round

    First I did a restore then I drained the battery i started to charge it and when it came on I turned the phone off completely and let it charge to 100% I then left it for a couple of hours on charge at 100. I saw no improvement after 1st drain so I repeated the drain battery and charge steps again with the phone turned off when charging and have seen a very big improvement. I am going to do it again tonight and hopefully problem solved!!!!

    The next issue is iMessage as that's playing up and wifi drop out

    Good luck

  • 3. Re: iOS 5.1.1 battery problem
    billpleasanton Level 1 Level 1 (0 points)

    Had same problem. Was working fine until 5.1.1 update, then battery losing 1% every 100 seconds or so. Tried checking the microSim card, stopped all running apps, tried draining and re-charging, and did a hard reset, nothing worked. What DID work was to connect the iPhone 4S to iTunes and do the full 5.1.1 update via the computer, rather than over the air. When I loaded the full update, battery went back to normal.  I did have to re-load a bunch of applications (for some strange reason)..  FYI when I was having the battery drain problem using "airplane mode" fixed it, so that might help temporarily, of course you won't get any calls or data or texts... It appeared to me to be related to some of the radio's running full-out, not programs.

     

    From what I've read the "over the air" update is much smaller than the full update via iTunes, so I'm wondering what they "don't" update over the air.  Anyway try that, see if it helps, worked for me.

  • 4. Re: iOS 5.1.1 battery problem
    jkahunas Level 1 Level 1 (0 points)

    I went through a number of gyrations to solve the same problem on my iPhone 4.

    It finally got solved when I plugged into iTunes and did a complete device restore.  I was able to reload the phone settings from a backup after.

    It did not work with any restores or resets initiated from the phone itself.

    Good luck,

    - Joe

  • 5. Re: iOS 5.1.1 battery problem
    pujan choksi Level 1 Level 1 (0 points)

    guys looking at all ur problms .. i m pretty scared with the 5.1.1 update.. i have i ph 4s and its working well..

    should i update my phone ??

  • 6. Re: iOS 5.1.1 battery problem
    jkahunas Level 1 Level 1 (0 points)

    No!!!! Don't do the 5.1.1 update