5 Replies Latest reply: May 13, 2012 4:49 AM by ClaremontBob
ClaremontBob Level 1 Level 1

Attempted to upgrade iPhone 3GS to 5.1.1. via iTunes v10.6.1. iTunes crashed and report sent to Apple, however, iPhone now completely inoperable and will not restore via iTunes. Only screen available is the plug in to iTunes. MacBook Pro, running OSX 10.7.4.

When connected to iTunes, an advice pane is displayed indicating that iTunes has detected an iPhone in recovery mode and that the iphone must be restored before it can be used with iTunes.

Following the restoration via iTunes, a further advice is received saying that the iPhone could not be restored and that an unknown error occurred (29).

Have attempted to restore about 10 to 12 times with the same result. Have attempted to reboot the iPhone with no success. Have disabled security apps and changed USB connection.

Anyone experiencing similar and if so, what is the solution? Seems that the iPhone is now junk!

iPhone 3GS, iOS 5.1.1, MacBook Pro, OSX 10.7.4
  • ckuan Level 7 Level 7

    Can this of help

    Error 23, 28, 29: These errors may indicate a hardware issue with your device. Follow the steps in this article. Also attempt to restore while connected with the white USB Dock Connector cable that shipped with your device, on a known good computer and network to isolate this issue to the device. The MAC address being missing or the IMEI being the default value, (00 499901 064000 0), can also confirm a hardware issue. Out-of-date or incorrectly configured security software can also cause these errors.

  • ClaremontBob Level 1 Level 1

    Have checked out [without success] most of the issues identified under these error numbers, except MAC address reference that appears to relate to WiFi networks, etc. No luck there!

  • ckuan Level 7 Level 7

    Bring it to the Apple Store and let them evaluate.

  • ROOST3R Level 1 Level 1

    I had the same and was getting repeated failed restores with a variety of different error codes.


    This is my fix:


    This only worked using a different PC other than my normal sync, (glad I have 4 in the house). I dont know why this is the case, could be many issues from usb drivers to plugins but I dont care why it works, it just did.


    I got a failed update from the itunes update, then failed restores for 5.1.1 through itunes.


    I tried to restore from direct download file as well, many system reboots, service restarts, recovery mode phone reboots, etc.


    I then attempted to restore 5.1 from the download at http://gdeluxe.com/ios-firmware-ipsw-download-links/ but that too failed.


    So I was going to wait until my express lane apointment came up and figured I should charge up the phone so it was maxed out...but...frustration got the better of me.


    I jumped on one of the other PC's which hasnt even been sync'd and hasnt had an itunes update either. It still has version installed. Held down power + home button for reset and plugged the phone in


    So I transfer over the install file to the new PC (file name I used is "iPhone4,1_5.1_9B179_Restore.ipsw" from the Download iOS 5.1.0 iPhone 4S link above) plugged in the phone, itunes starts up and asks to update the software, I deny it.


    Then the popup for "Iphone in recovery mode...must be restored...yadda yadda" comes up, clicked OK.


    Now shift clicked the restore button and, just as I was about to try 5.1.1 I figured I would just go with  5.1 version instead.


    It installed without issue, my Iphone is now alive again and not just a drink coaster.


    Took it back to my normal sync terminal, resotred my backup file and yay...no more 5.1.1 woes


    Hope this helps others to repair their iCoasters.


    Perhaps rolling itunes back to earlier version and installing the 5.1 can save some others from the 5 hours of iRage i suffered.


    Repeated across other threads for those who are having trouble

  • ClaremontBob Level 1 Level 1

    Thanks. Tried your approach with iOS 5.1 on another computer [OSX 10.6] without success. Maybe due to iTunes on that machine already upgraded to 10.6.1?

    Still have my iCoaster! Have appointment with local Apple Genius tomorrow - not very hopeful!