Skip navigation

Apple TV is Downloading movie rentals very slowly

61919 Views 105 Replies Latest reply: Jan 6, 2014 8:38 AM by LeeT73 RSS
1 2 3 ... 8 Previous Next
xuamox Level 1 Level 1 (0 points)
Currently Being Moderated
May 13, 2012 12:24 AM

I rented Mission Impossible tonight, but Apple TV said it would be ready in 52 hours and 10 minutes.  I checked my connection, and it's all good, I did a speed test and got 22Mbps download speed, so I can't figure out what the problem is.


I have been having more and more issues with my Apple TV lately. Rentals are taking longer, or the movies play to a certain point and then we have to wait for the streaming to catch up to a point and then the movie will start again.

 

Has anyone else experienced any problems like this, and have you found a solution?  It makes for a very frustrating user experience, and everytime it happens I get a bit more turned off by the Apple TV product.

Mac 24", Mac OS X (10.0.x)
  • Alley_Cat Level 6 Level 6 (16,625 points)
    Currently Being Moderated
    May 13, 2012 1:42 AM (in response to xuamox)

    This really doesn't sound right.

     

    Might be worth mentioning your Country as sometimes problems can be country specific.

     

    Always worth unpowering the unit and restarting if it's misbehaving.

     

    Have you tried steraming content from iTunes locally recently - if that's ok then it's not LAN slowness, and given your 22 Mbps internet connection it's not likely to be that.

     

    Could be Apple's servers in your region, your ISP throttling connections to Apple (unlikely) or a variety of nebulous networking factors.

     

    Are you using your ISPs recommended DNS servers - some others apparently really slow access to Apple's media servers for some reason.

     

    AC

  • Alley_Cat Level 6 Level 6 (16,625 points)
    Currently Being Moderated
    May 13, 2012 8:03 AM (in response to xuamox)

    Netflix works differently, altering quality for the worse if the connection is slow.

     

    The Apple TV receives a fixed size file as a stream - if the internet speed is slower than required to give that real time rate it has to buffer.

     

    Even 1080p HD would get by on 8 Mbps so your 22 Mbps should work fine.

     

    Check your ISP throttling rules and also your DNS erver setup (I think OpenDNS caused problems and Google's DNS).

     

    AC

  • Alley_Cat Level 6 Level 6 (16,625 points)
    Currently Being Moderated
    May 13, 2012 12:14 PM (in response to xuamox)

    Somewhere in settings ther's an internet connection test - don't think I've ever tried it but I don't think it gives anyuser feedback.

     

    If local content (including HD?) plays fine from iTunes then you would have to assume the internet is the issue, though not on your side.

     

    AC

  • PSGB Calculating status...
    Currently Being Moderated
    Jun 27, 2012 5:12 PM (in response to xuamox)

    Same problem here in Toronto for myself and the only other person I know who uses Apple TV(second gen) exclusively for movie rentals.

    The last month or so my downloads have been painfully slow.

    My Internet speed is insanely fast and all of my other devices work fine.

    I found another thread from users in New Zealand complaining of the same issue.

    Could this be a country specific problem?

    Apple TV, fix yourself or I will smash you against the wall and kill Steve Jobs... Wait... That's not right...

  • Hotshotdick Calculating status...
    Currently Being Moderated
    Jun 28, 2012 3:01 AM (in response to xuamox)

    I'm in the UK with an Apple TV Gen 2 (9Mb/s broadband speed checked) and have conclusively failed to rent one single movie since I bought this a year ago. Every time I try all I get is "connection error please try later" Playing movie trailers and everything else is fine.

    On saturday I tried again with the same error so figured I'd try and rent the movie direct from iTunes Store on my laptop, hey presto, 2 mins later I'm watching my film via my Macbook Pro hooked up to my TV.

     

    So the big question is: Why can not Apple TV stream a movie like the iTunes Store can?

     

    Anyone got any ideas?

    Thanks.

  • VancrMarko Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 2, 2012 6:08 PM (in response to xuamox)

    Same deal here in Vancouver, BC, Canada.  I had an Apple TV 2 and the downloads were ready to watch within seconds.  As soon as I switched to Apple TV 3 my download speed for movies slowed to a crawl.  Even lowering the resolution to 720p doesn't help (much).  Downloading a movie still takes over an hour whereas with ATV 2 it was ready to watch in under a minute.

     

    Curiously, for about 3 days several months ago my downloads speeded up and movies were ready to watch in seconds again.  Then things went back to the usual slowmo.  I use my ISP domain name and have no throttling (Shaw too) and my wifi speed never falls below 16 Mbps.

     

    Lots of calls to Apple Care with no resolution.

     

    Very, very frustrated.

  • ccrevecoeur Calculating status...
    Currently Being Moderated
    Jul 2, 2012 6:18 PM (in response to xuamox)

    Same thing as well. I'm really ******

  • LordofCupertino Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 3, 2012 9:45 PM (in response to xuamox)

    Same thing, again in Vancouver BC.   7 hours plus to load a movie.  

  • brigfromql Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 3, 2012 9:54 PM (in response to PSGB)

    yes looks like Australia is an other one to ad to the list... I bought AppleTV to rent movies

    when bored..... but after waiting 5 hrs to upload ??? well I will have to give that a miss now...

    looking forward to some answers !

    brig

  • synaptech Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 4, 2012 11:01 AM (in response to xuamox)

    Hamilton, Ontario.  Same issues here.  Recently upgraded to 22 Mbps and now my appleTV-2 is virtually unusable.  I have been blaming ISP as it coincided with the speed change.  Curious if we have more than the appleTV in common.  Perhaps the hardware to connect to the internet?  I'm running a CellPiPe 7130  firmware v1.0.4.4R3WH.  Not using CellPipe wireless.  The CellPipe is wired to my Airport Time Capsule in bridge mode.  AppleTV2 is wirelessly connected to the Airport.  Local itunes content streams fine wirelessly.  Radio streams across appleTV2 no problem.  Seems to be specific to movies and movie trailers.

     

    Message was edited by: synaptech

  • synaptech Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 4, 2012 11:11 AM (in response to synaptech)

    Does anyone know the server address(es) that Apple streams movies from for Canada?  Perhaps we could also compare traceroutes and pings?

1 2 3 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.