Previous 1 2 3 Next 44 Replies Latest reply: Aug 27, 2012 5:19 PM by apple support user Go to original post
  • dbmoore Level 1 (105 points)

    Thanks for checking it out.  Im glad and sorry that you verifed the results, kinda hoping that my computer was missing something.  Im not crazy!  Its been around for a year and I feel that is too long for such an important part of Aperture to fail.  This must be involving Colorsync and the OSx CM and  must effect other Pro applications in someway other wise it surely would of been fixed before now.  Now that I know High level experts know maybe I can sit back a wait for AP4  Thanks again  dbm

  • Klahane Level 1 (0 points)

    I just wanted to add a note that Digital Camera Raw Compatibility Upd 3.13 does not bring back the green-tint problem.

  • PNC79 Level 1 (0 points)

    Hey guys, it's my first message here in the hope to find help. So a big HELLOW to the community!


    My Lumix also shows up some unwanted layer over my RAW shots when put into Aperture but not on Jpeg. So I'm here to find a nice soul who could explain me where exactly I have to copy and paste the text stated above???!


    Someone please discibe the steps to find the "terminal" as I haven't got a clue what you are talking about, sorry for being such a novice... It seems clear to everyone but me!!!

  • Adamalicious Level 1 (15 points)

    Hit Cmd+Space.


    Type "T E R"


    Hit enter.

  • léonie Level 10 (90,569 points)

    The terminal is an Utility Application, and you find it in the folder "Utilities" inside the "Applications" folder. DOuble click to launch it - you also can launch by typing "Terminal" into the Spotlight search field.


    Once launched, type

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -R /System/Library/CoreServices/CoreTypes.bundle/Contents/Library


    into the Terminal window and hit return.

  • PNC79 Level 1 (0 points)

    Thanks LeoniDF, I tried but nothing changed.... When  I import my Raw files I don't have a greenish layer but more a greyish one. All my RAW fotos have this problem. When they charge they have the right color, then when it finishes charging, the image gets darker get a haze effect and looses it's intensity. Then when I ask to see the Master image it shows me the image with the luminosity of the picture while it was charging. So an effect has been added to them without me wanting so.


    My import setting are set so that no effect should be added. What could I be doing wrong?



  • Klahane Level 1 (0 points)

    I notice that as a RAW image from my Lumix FZ 150 loads, it changes. In my case, what I notice is a slight color shift and a slight desharpening or denoising.

    I think what's happening is that the first image you see is the camera's jpeg (even if you don't have the camera set to shoot raw + jpeg), then the second is the RAW image after Aperture processes it.

    (The green problem is much more obvious, a profound green cast to the entire image.)

    You can click on a RAW image, then choose Adjustments in the Inspector panel, then add RAW Fine Tuning to the panel. Now you can adjust the fine tuning and, if you want, save your changes as a preset.


    I think there's a perception thing going on here. You see the first version long enough to get the color and the sharpness. Then the next version will look wrong--or at least different--whatever Aperture does to it. You can't do an A-B comparison. Similarly, the image you see on the monitor may look "right" to you and any inkjet print will look "wrong."

  • PNC79 Level 1 (0 points)

    Yes it was the RAW fine tuning!!!!! Thank you thank you thank you klahane!!!

  • David Cittadini Level 1 (5 points)

    Unfortunately none of the suggestions have fixed the problem of all my DNG files in Aperture having a green hue :-(

  • dbmoore Level 1 (105 points)

    Hi David


    Sorry for the redundancy here.  On the Green Image did you force a reprocessing of the image via menue "Photo"?  For a minor thought did you check the gear section to see if that project has a check on preserve previews?  If so uncheck it and try generating thumbnails then reprocess those images.  I had similar Previews and unsupported file formats this am and that help.  The other thing I was thinking of was exporting the two pojects to their own librarys  and getting them away from the good images so I coud further explore options. Atlas I think mine is ok.... but Ive thought that before.

  • David Cittadini Level 1 (5 points)

    Thanks.  I tried reprocessing the image, regenerating the thumnails, reprocessing the previews and generating the previews.   This made no change, all the thumbnails are green and when you click on the image it is green.  Having done a Google search I see that Aperture has been having various "green" problems for years.  That worries me.  I love Aperture but I can't really continue much longer with not taking photos and having all my past photos as green images...I am going to have to be forced to go somewhere else and that makes me very sad :-(

  • léonie Level 10 (90,569 points)


    have you tried the Terminal command suggested by Alan Roseman?


    Re: Aperture 3 preview of raw file greenish


    This really fixed the problem in many cases, when images turned green after a system upgrade; it will help, if the system does not know that raw support for the camera is installed.





  • David Cittadini Level 1 (5 points)

    I think I have found the problem in my instance....there seems to be a problem with how Mountain Lion handles DNG files.  In particular, it is not handling the BayerGreenSplit attribute the same as Adobe does.  Therefore, all my DNG files will be 100% fine in Adobe, but will always have a green tinge in any Apple software.  So, until Apple handles BayerGreenSplit the same as Adobe it seems I will always have green files.  Hopefully there will be a fix soon :-)

  • Arnaud Séailles Level 1 (0 points)

    Got a similar problem yesterday (Lion, Aperture 3.3.2, Lumix LX5). Did the Terminal command suggested above, reboot, tried to regenerate previews, etc.. nothing worked.

    But suprisingly, I just tried the following :

    - copied the masters in.rw2 from Aperture Library from the Finder

    - deleted the greenish pictures in Aperture completly

    - reimported the masters from the Finder in Aperture

    Worked fine for me !

    Hope that helps

  • apple support user Level 1 (0 points)

    I have this problem with a 5D Mark II. I tried everything on this thread with no success.

Previous 1 2 3 Next