10 Replies Latest reply: Sep 10, 2013 5:29 AM by Bharath.k
Macaroni323 Level 1 Level 1 (0 points)

I am having problem with my entire MAC HD being shared to anyone on my home network and wanted to remove this access.  The following paths are approximate since I can't get into the machine.  I went to "Finder" and selected "Macintosh HD" and then "Get Info."  On sharing at the bottem it listed System, Wheel and Everyone as users.  System and Wheel had "Read & Write" privledges and "Everyone" has "Read only."  I thought this was for file sharing on the network but I know now that this is for ANY access to the Macintosh HD.  My system could not be shut down, no applications could be selected.  I could do nothing on the machine at all.  I shutdown hoping to get to the boot version of the "Disk Utility" and try to repair permissions but that is not accessable and the spinning timer is all that appears on boot.  Nothing else.  I can get into single user mode though.  Is there a way to recover or reset the "Everyone" user on the "Macintosh HD" (I assume that is the root of the drive).to "read only" privledges?


Mac mini, Mac OS X (10.7.4), 16GB Memory, Samsung 60" HDTV
  • captfred Level 7 Level 7 (26,270 points)

    Neil has a good user tip here:

     

    https://discussions.apple.com/docs/DOC-2240

  • Kappy Level 10 Level 10 (257,850 points)

    Repair the Hard Drive - Lion

     

    Boot from your Lion Recovery HD. When the recovery menu appears select Disk Utility. After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list.  In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive.  If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported then click on the Repair Permissions button. Wait for the process to complete, then quit DU and return to the main menu. Select Restart from the Apple menu.

     

    Boot to the Recovery HD:

     

    Restart the computer and after the chime press and hold down the COMMAND and R keys until the menu screen appears. Alternatively, restart the computer and after the chime press and hold down the OPTION key until the boot manager screen appears. Select the Recovery HD and click on the downward pointing arrow button.

     

    If you have to repair the permissions of all the data in the Home folder, then while still running from the Recovery HD above:

     

    select Terminal from the Utilities menu. Enter resetpassword at the prompt and press RETURN. Follow instructions in the dialog window that will appear. You can reset your admin password or reset the ownerships and ACLs for user accounts. It's the latter that you want to do.

  • Macaroni323 Level 1 Level 1 (0 points)

    Thanks guys for the help.  I'm answering from the affected MAC. 

     

    Kappy had some of the solution and CaptFred was leading to the solution that I thought I'd need.  Right after entering my plea for help, I booted to the recovery (Command-R) and did the verify disk and permissions repair.  This did not fix the problem.  Booting after the fixed permissions still resulted in the endless boot.  I again booted to the recovery and selected the online help were there was an excerpt from the manual about reinstalling the OS without losing any data.  I exited back to the main recovery and did just that.  It confirmed that I wanted to install the OS and I clicked continue.  Virtually no questions at all about how to install the OS and preserve the data.  This led to 7 hours of downloading (Mac OSX 10.7.3 is what ended up on the machine) and there were no further questions asked.  I started around 4PM, went out for dinner till 8PM when I checked and the machine was still downloading for 3 more hours.  I returned to the machine at 11:05PM and found the machine at the login prompt with all 4 original users.  I logged in (I'm the admin) and it appears that all is mostly back.  Don't seem to be missing any APPs and I can again run the machine.  I did find a window open showing the sharing of the "Macintosh HD" and it had replaced the "everyone" user back to "read only" permissions.  Also the "wheel" user is set to "read only."  Needless to say I immediately closed that window and WILL NOT click the setting freely again.    My sharing was automatically reduced to the 4 user's public folders and the 3 odd folders (Music, Movies, and a folder on an external HD) were removed from the share.  I am still checking for missing things but it looks good so far.

     

    Thanks again for the help!

  • pairochjulrat Level 1 Level 1 (0 points)

    Macaroni323, your solution has save my life

  • johnnymac5150 Level 1 Level 1 (0 points)

    Happend to me also.  I was foolin around with permissions on my Mac and gave "everyone" no access to the root of the system drive.  System would boot and just hang on startup.  I clicked on captfred's link and followed Neil's A1 tip and it worked!  20 seconds of typing and my system rebooted back to its old self.  Here is what I did copied from Neil's info (thanks Neil!):

     

    (From Neil)

    A1. If the disk in question is your Mac OS X startup disk and your computer stops starting up at the blue screen, restart with the Command and S keys held down, and enter the following commands:

     

    mount -uw /

    chown root /

    chmod 1775 /

    exit

  • mccoolpix Level 1 Level 1 (0 points)

    Thanks johnnymac5150 for Neil's info. This saved my rear.

     

  • Branbillapuzz Level 1 Level 1 (0 points)

    Hi when I repair my Macintosh, DU sais that one file cannot be repaired (Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAg ent" has been modified and will not be' repaired. ) and other differ (ex. Permissions differ on "System/... "; should be drwxr-xr-x ; they are lrwxr-xr-x. ") what's should I do?

  • noondaywitch Level 6 Level 6 (8,130 points)

    Totally ignore it - it isn't a problem.

     

    http://support.apple.com/kb/TS1448

  • Branbillapuzz Level 1 Level 1 (0 points)

    Thanks but when I restart my Mac the screen is white. I've repaired the Macintosh HD and it sais that it is ok and I've repaired the permissions even if there are errors as you know. Then I restart my Mac and a white screen appears. How can I fix it?

  • Bharath.k Level 1 Level 1 (0 points)

    Thanks, This worked for me