5 Replies Latest reply: May 14, 2012 3:16 PM by Harry Ninja
Harry Ninja Level 1 (0 points)

I just downloaded the latest iOS and did a full factory reset on my iTouch in hopes of getting it ready to go to a co-worker. I've been test-driving the device to see if we wanted to use Apple vs Android products for the applications we're developing for our research facility. Things were going fairly smoothly until I did this. Now, I no longer have access to any encrypted network (I have access to 2), which essentially has given me a nice paperweight I can give to my co-worker (we deal with HIPAA information that has to be encrypted). It does have access to guest networks, so I know it's a software problem (not a hardware problem). I tried calling Apple, but we're outside our 90-day limit. I thought they were known for their excellent support, but if I have to pay for fixing something their update broke (sounds like a great way to make money if you ask me), I won't be recommending it for our software development.

 

Anyone aware of any settings I need to dig-into to get this to work? (I feel like my hands are tied because I can't poke around in any of the directories to browse through files and settings; something I'm not afraid to do as a software developer.)


iPod touch
  • lllaass Level 10 (175,648 points)

    What encryptions have you tired?

    Try Settings>General>Reset>Reset Network Setting again.

  • Harry Ninja Level 1 (0 points)

    I've tried the following:

     

    * Settings | General | Reset | Reset Network Settings (Twice)

    * Settings | General | Reset | Reset All Settings (Once)

    * Plugging it in and doing a "Restore" through iTunes (that's how I downloaded iOS 5.1.1 in the first place)

     

    All the passcodes and restrictions are are turned off.

     

     

    When I first try to connect to the network, I'm prompted to enter my username and password (I've elected to "forget" the network a few times so I can get this screen again). If I enter it wrong, then I just get an error that I'm not connected. When I enter it right, I get a warning that the certificate is "not verified". When I click on "More Details", I can see all the information that got pulled from the network (Issuer Name, Signature Algorithm, Public Key Algorithm, Key Usage, etc.). When I choose to "Accept", I get the little icon indicating that it's trying to connect...this never goes away (I let it run for an hour).

     

    The encryption type on the main Wifi I'm trying to connect to says it's RSA (I'm guessing it's WEP though...I didn't set it up, our IT group did that).

  • lllaass Level 10 (175,648 points)

    Sorry bu I can't help. You are using an enterprise-type encryption since you have to enter both username and passward.

  • Harry Ninja Level 1 (0 points)

    Thanks for doing what you can. You've always been quick to respond and try to help me with my connection issues.

  • Harry Ninja Level 1 (0 points)

    I just got it working, and you'll never believe how I did it...

     

    After watching some YouTube clips, I decided to try something way-off in left-field. I put the iPod Touch on ice for about 10 min. (This was easy to do because I bring a cooler with me to keep some things cool at work. I just put it in with my lunch.) When I turned it on and went to the network settings (like I'd been doing all morning); cha-ching, it worked great! I wouldn't have believed it myself if I hadn't have seen it.