Previous 1 2 3 4 5 Next 70 Replies Latest reply: Dec 18, 2013 4:16 PM by rmisaac Go to original post
  • Niall Mallyon Level 1 (65 points)

    It's back.


    Enough said.

  • Mr Blond Qc Level 1 (0 points)

    Hey Niall Mallyon!


    I think I found a solution!!!

    So far It's good. It's been one week.




    I hope this could work for all of us.


    And the solution is not too complicated.


    I did not reimport all my media.

    Niall can you send me a screen shot of your iTunes music folder files?





  • Niall Mallyon Level 1 (65 points)

    Screen Shot 2013-02-01 at 19.04.29.png

    There you go...


    Not sure what use this will be.  I recovered my entire Mac from a Carbon Copy Cloner image a few days ago due to an unrelated issue but I haven't had an issue yet with iTunes, though it's only a matter of time I guess!!

  • Niall Mallyon Level 1 (65 points)

    Any more news?  I'm still problem free but then this has happened before.

  • eriksiebert Level 1 (5 points)

    On the edge of my seat over here.  Any update?

  • Niall Mallyon Level 1 (65 points)

    Nothing to add from me sorry.  Still waiting to hear from Mr Blond Qc after posting my screen shot.


    I've been problem free now since 29th January after my Carbon Cloner Copy recovery.  And I can't explain why.  Have just used iTunes as before then upgraded to 11.0.2 when it was released.


    Very strange but I'm not complaining(!)


    Maybe we'll get an udate soon from Mr Blond Qc.

  • Mr Blond Qc Level 1 (0 points)

    Sorry guys,


    I have been downing in a ocean of work recently. I want to post all what I found ASAP. This solution works for me and hopefully will work for you as well.



    As soon as I can I will post everything.



    Sorry for the suspense.

  • 666Zach666 Level 1 (0 points)

    Hey,Erik,and rest of you with this.tmp files problem.I think i got a solution.

    After almost 10 years of using iTunes as my "burner' to download  music and after almost 15,000 albums burned and converted to mp4 via iTunes,last of couple days i had a problem,like rest of you with this annoying .tmp files.I went on to investigate this issue and could not find any correct answer from anybody.Then,i did spot somebodies comment,saying that issues is with a AntiVirus software.And guess what,they were right.I being using AVG for a number of years and for some strange reason,all of sudden i have all this .tmp all around my iTunes music folder.Then,what i been doing last of couple hours, is that i been testing downloads with AVG on and AVG temporarily disable.And BINGO... With my AVG virus software being on,of course,i am getting .tmp files all over.But.. With AVG being temporarily disable,i didn't get any.So,my suggestion to you is,try to do what i did.Hopefully will work.Just i did not get to issue,yet, how to stop all that .tmp files while AVG being on all the time.Let me know if this helped you! Zach

  • ChelleK1991 Level 1 (0 points)

    Just want to say thank you to 666Zach666 for his advice, I have been using AVG for years and in the last two weeks this tmp file thing has been deleting my itl file and destroying my library. As soon as I disabled it I had no problems with downloading. YOU answered what 10 Senior Analysists could not solve, they told me that it shouldn't be a problem but clearly it was. I think I might switch to Avira or some other Anti-Virus and see if that fixes anything I'll let you know.

  • BillMcD Level 1 (0 points)

    I don't know. I get these .tmp files but have never used anti-virus software. Happy that it works for you, but not sure it's a solution for everyone.

  • Siddhi67 Level 1 (0 points)

    i have never used antivirus software.

    I think something other solution works.

    i have fixed the problem with shut down the snapshot of timemachine.its works for me....

  • broob Level 1 (0 points)

    I have used Siddhi67's potential solution. Shutting down the timemachine snapshot has definitely done "something" positive. In 2 days I haven't had a single temp file created. Normally I could just watch them stack up in my iTunes folder. Eventually several GB worth would fill up my hard drive. I previously reinstalled iTunes and did every single thing I could find here and on other sites. This "seems" to be working. You can find the Terminal commands to shut down this local timemachine storage by a simple search. If you've got a laptop (because this was instituted by Apple for portables by default) look at this. It might be a good thing to disable just for the space saving on your hard drive. The only explanation that I can come up with is that writing the updated library file to your local hard drive is interrupted by Time Machine. Thanks Siddhi67! (Even though I can't claim a solid cure quite yet.)

  • Siddhi67 Level 1 (0 points)

    Not only for me . I hope it will work... ....and Apple will fix this problem and more terribile things of itunes 11!!!!

  • Niall Mallyon Level 1 (65 points)

    29th January until 17th April.  That's how long it lasted.  All I did was the following yesterday and the problem returned.


    i) Ran an OSX update and updated iPhoto, Java, Safari and HP drivers.

    ii) Ran Disk Utility to repair disk permissions (Nothing needed doing)


    Problem came back.


    On the basis it might be to do with either i) or ii) above and that a system restore helped before, I have restored via Time Machine the .itl and .xml files from before the upgrades / repair yesterday and am keeping things crossed!


    Still no news from Mr Blonde Qc on their fix though.

  • broob Level 1 (0 points)

    I would suggest you try Siddhi67's solution. I've been running for 6 weeks now and not a single tmp file. AND I'd been having them come by the dozens with no solution until now. I was wondering why my HD was almost full! I

    am running iTunes 11. However this problem goes back to at least 10. I feel Time Machine local backups interrupt the writing of the library files. Disclaimer: if you aren't using a laptop you may not have the "snapshot" instituted and you have a different issue.