7 Replies Latest reply: Nov 15, 2012 8:19 AM by Columkil
cp_whaley Level 1 (0 points)

Somehow, I've lost the ability to make changes to anything in my address book desktop app. All edit options in the menu are greyed out, and there is no Edit button on each card like there used to be.

 

If I knew where the database was located, I might be able to check the permissions, but I don't.

 

Siggestions?

 

...Charles


G5 iMac, Mac OS X (10.6.5)
  • cp_whaley Level 1 (0 points)

    No suggestions after 2 weeks?  Pity, because the problem hasn't gone away.  Doesn't anyone know where the Address Book data is stored on my Mac by default? If so, I could check permissions with Get Info.

     

    Doesn't anyone know how I can reinstall Address Book without re-installing all of OS X Lion? 

     

    I can edit and add records to Address Book in iCloud, but my desktop version doesn't sync, so that's useless too.

  • mo'green Level 1 (10 points)

    Hi. I got the same issue, but I found this which solved my problem:

     

    Try rebuilding the database file Address Book uses.

     

    To do that, quit Address Book, then while in Finder hold down the Option key and click the Go menu - select Library from the list. That will open the hidden Library folder in your user home folder. In that folder, locate and open the Application Support folder, then the AddresBook folder. In that folder locate the file named AddressBook-v22.abcddb and throw it away.

     

    Then close all those windows and start up Address Book, then test.

     

    I think my problem initially began after migrating in 3D:

    - to a new computer via migration assistant,

    - from OS 10.6.7 to OS 10.7.4 and finally

    - from MobileMe to iCloud.

     

    I had some permission issues and some trouble with multiple iTunes accounts.

    Still bugging me though is, that my Mac says "no devices syncing" when I press the sync circular arrows in the menu line. Did the sync function stop working with iCloud??

     

    Anyway, hope this helps,

    ...... Mo'.

  • cp_whaley Level 1 (0 points)

    Thank you so much. That worked like a charm! 

     

    I can't account for how my problem started, but I have my Edit function back now!

     

    I'm not sure about Sync and iCloud. When I click on the Sych button in the menu bar, something happens (i.e. no error messages), but I can't swear that it's doing what it's supposed to be doing. It's definitely not syncing properly with my Sony-Eriksen phone anymore, but I suppose we should be raising this issue as a separate thread.

     

    Thanks again.

     

    ...charles

  • MaartenAertsGeldrop Level 1 (0 points)

    Thanks for the solution. I was about to give up on addressbook...

  • Robin Imandt Level 1 (5 points)

    You are a genius! It worked like a charm. Thank you!!!

  • Columkil Level 1 (0 points)

    Genius!

     

    Thanks! A headache solved!